首页

昙鸾法师文集

北魏·昙鸾法师著 [image] 清凉书屋点校

·2003.08·


往生论注卷上

无量寿经优婆提舍愿生偈注卷上

婆薮槃头菩萨 造
魏永宁寺北天竺沙门菩提流支 译论
魏西河石壁谷玄中寺沙门昙鸾 注解

    谨案龙树菩萨《十住毗婆沙》云：“菩萨求阿毗跋致，有二种道：一者难行道，二者易行道。”“难行道”者，谓于五浊之世，于无佛时，求阿毗跋致为难。此难乃有多途。粗言五三，以示义意：一者外道相善，乱菩萨法；二者声闻自利，障大慈悲；三者无赖恶人，破他胜德；四者颠倒善果，能坏梵行；五者唯是自力，无他力持。如斯等事，触目皆是。譬如陆路，步行则苦。“易行道”者，谓但以信佛因缘，愿生净土。乘佛愿力，便得往生彼清净土。佛力住持，即入大乘正定之聚，正定即是阿毗跋致。譬如水路，乘船则乐。
    此《无量寿经优婆提舍》，盖上衍之极致，不退之风航者也。“无量寿”，是安乐净土如来别号。释迦牟尼佛在王舍城，及舍卫国，于大众之中，说无量寿佛庄严功德。即以佛名号为经体。后圣者婆薮槃头菩萨，服膺如来大悲之教，傍经作《愿生偈》，复造长行重释。
    梵言“优婆提舍”，此间无正名相译。若举一隅，可名为“论”。所以无正名译者，以此间本无佛故。如此间书，就孔子而称“经”；余人制作，皆名为“子”；国史、国纪之徒，各别体例。然佛所说十二部经中，有“论议经”，名“优婆提舍”。若复佛诸弟子解佛经教，与佛义相应者，佛亦许名“优婆提舍”，以入佛法相故。此间云“论”，直是论议而已，岂得正译彼名耶？又如女人，于子称“母”，于兄云“妹”，如是等事，皆随义各别。若但以“女”名，泛谈母、妹。乃不失女之大体，岂含尊卑之义乎？此所云“论”，亦复如是，是以仍存梵音，曰“优婆提舍”。
    此《论》始终凡有二重：一是总说分，二是解义分。总说分者，前五言偈尽是。解义分者，“论曰”以下长行尽是。所以为二重者，有二义：偈以颂经，为总摄故；论以释偈，为解义故。
    “无量寿”者，言无量寿如来，寿命长远不可思量也。“经”者，常也。言安乐国土佛及菩萨清净庄严功德、国土清净庄严功德，能与众生作大饶益，可常行于世，故名曰“经”。“优婆提舍”，是佛论议经名。“愿”，是欲乐义。“生”者，天亲菩萨愿生彼安乐净土如来净华中生，故曰“愿生”。“偈”，是句数义，以五言句略颂佛经，故名为“偈”。
    译“婆薮”云“天”，译“槃头”言“亲”。此人字“天亲”，事在《付法藏经》。“菩萨”者，若具存梵音，应言“菩提萨埵”。“菩提”者，是佛道名。“萨埵”，或云众生，或云勇健。求佛道众生，有勇猛健志，故名“菩提萨埵”。今但言“菩萨”，译者略耳。“造”，亦作也。庶因人重法，故云“某造”。是故言：“《无量寿经优婆提舍愿生偈》，婆薮槃头菩萨造”。
    解论名目竟。

    △偈中分为五念门，如下长行所释。
    第一行四句偈，含有三念门：上三句是礼拜、赞叹门，下一句是作愿门。
    第二行，论主自述：我依佛经造论，与佛教相应，所服有宗。何故云此？为成“优婆提舍”名故。亦是成上三门，起下二门，所以次之说。
    从第三行，尽二十三行，是观察门。
    末后一行，是回向门。
    分偈章门竟。

    【世尊我一心，归命尽十方，无碍光如来，愿生安乐国。】
    “世尊”者，诸佛通号。论智，则义无不达；语断，则习气无余。智、断具足，能利世间，为世尊重，故曰“世尊”。此言意归释迦如来。何以得知？下句言“我依修多罗”。天亲菩萨在释迦如来像法之中。顺释迦如来经教，所以愿生。愿生有宗，故知此言归于释迦。若谓此意遍告诸佛，亦复无嫌。夫菩萨归佛，如孝子之归父母，忠臣之归君后。动静非己，出没必由。知恩报德，理宜先启。又所愿不轻，若如来不加威神，将何以达？乞加神力，所以仰告。
    “我一心”者，天亲菩萨自督之词。言念无碍光如来，愿生安乐，心心相续，无他想间杂。
    问曰：佛法中无我，此中何以称“我”？
    答曰：言“我”有三根本：一是邪见语，二是自大语，三是流布语。今言“我”者，天亲菩萨自指之言。用流布语，非邪见、自大也。
    “归命尽十方无碍光如来”者，“归命”，即是礼拜门；“尽十方无碍光如来”，即是赞叹门。
    何以知“归命”是礼拜？龙树菩萨造《阿弥陀如来赞》中，或言“稽首礼”，或言“我归命”，或言“归命礼”。此《论》长行中，亦言“修五念门”。五念门中，礼拜是一。天亲菩萨既愿往生，岂容不礼？故知归命即是礼拜。然礼拜但是恭敬，不必归命。归命必是礼拜。若以此推，归命为重。偈申己心，宜言“归命”。论解偈义，泛谈“礼拜”。彼此相成，于义弥显。
    何以知“尽十方无碍光如来”是赞叹门？下长行中言：“云何赞叹门？谓称彼如来名，如彼如来光明智相，如彼名义，欲如实修行相应故。”依舍卫国所说《无量寿经》，佛解阿弥陀如来名号：“何故号阿弥陀？彼佛光明无量，照十方国，无所障碍，是故号阿弥陀。又彼佛寿命，及其人民，无量无边阿僧祇劫，故名阿弥陀。”
    问曰：若言无碍光如来光明无量，照十方国土，无所障碍者。此间众生，何以不蒙光照？光有所不照，岂非有碍耶？
    答曰：碍属众生，非光碍也。譬如日光周四天下，而盲者不见，非日光不周也。亦如密云洪霔（灌），而顽石不润，非雨不洽（沾）也。
    若言一佛主领三千大千世界，是声闻论中说。若言诸佛遍领十方无量无边世界，是大乘论中说。天亲菩萨今言“尽十方无碍光如来”，即是依彼如来名，如彼如来光明智相赞叹。故知此句是赞叹门。
    “愿生安乐国”者，此一句是作愿门。天亲菩萨归命之意也。其“安乐”义，具在下观察门中。
    问曰：大乘经论中，处处说众生毕竟无生如虚空。云何天亲菩萨言“愿生”耶？
    答曰：说众生无生如虚空，有二种：一者如凡夫所谓实众生，如凡夫所见实生死，此所见事，毕竟无所有，如龟毛、如虚空。二者谓诸法因缘生故，即是不生，无所有如虚空。天亲菩萨所愿生者，是因缘义。因缘义故，假名生，非如凡夫谓有实众生、实生死也。
    问曰：依何义说往生？
    答曰：于此间假名人中，修五念门，前念与后念作因。秽土假名人、净土假名人，不得决定一，不得决定异。前心、后心，亦复如是。何以故？若一则无因果，若异则非相续。是义《观一异门论》中委曲释。
    第一行三念门竟。

    △次成“优婆提舍”名，又成上起下偈。
    【我依修多罗，真实功德相，说愿偈总持，与佛教相应。】
    此一行，云何成“优婆提舍”名？云何成上三门、起下二门？
    偈言：“我依修多罗”，“与佛教相应”。“修多罗”，是佛经名。我论佛经义，与经相应。以入佛法相故，得名“优婆提舍”。名成竟。
    成上三门、起下二门：何所依、何故依、云何依。何所依者，依修多罗。何故依者，以如来即真实功德相故。云何依者，修五念门相应故。成上起下竟。
    “修多罗”者，十二部经中直说者名“修多罗”，谓《四阿含》、三藏等。三藏外大乘诸经，亦名“修多罗”。此中言“依修多罗”者，是三藏外大乘修多罗，非《阿含》等经也。
    “真实功德相”者，有二种功德：一者从有漏心生，不顺法性。所谓凡夫人天诸善、人天果报，若因若果，皆是颠倒，皆是虚伪。是故名不实功德。二者从菩萨智慧清净业起庄严佛事，依法性入清净相。是法不颠倒、不虚伪，名为真实功德。云何不颠倒？依法性、顺二谛故。云何不虚伪？摄众生入毕竟净故。
    “说愿偈总持，与佛教相应”者，“持”名不散不失，“总”名以少摄多，“偈”言五言句数，“愿”名欲乐往生，“说”谓说诸偈论。总而言之，说所愿生偈，总持佛经，与佛教相应。“相应”者，譬如函盖相称也。

    △此已下，是第四观察门。此门中分为二别：一者观察器世间庄严成就，二者观察众生世间庄严成就。
    【观彼世界相，胜过三界道。】
    此句已下，至“愿生彼阿弥陀佛国”，是观器世间庄严成就。观器世间中，复分为十七别，至文当目。
    此二句，即是第一事，名为观察庄严清净功德成就。此清净是总相。
    佛本所以起此庄严清净功德者，见三界是虚伪相，是轮转相，是无穷相。如蚇蠖（屈伸虫）循环，如蚕茧自缚。哀哉众生，缔（结不解）此三界，颠倒不净。欲置众生于不虚伪处，于不轮转处，于不无穷处，得毕竟安乐大清净处。是故起此清净庄严功德也。“成就”者，言此清净不可破坏，不可污染。非如三界，是污染相，是破坏相也。
    “观”者，观察也。“彼”者，彼安乐国也。“世界相”者，彼安乐世界清净相也。其相别在下。
    “胜过三界道”。“道”者，通也。以如此因，得如此果。以如此果，酬如此因。通因至果，通果酬因。故名为“道”。“三界”者，一是欲界，所谓六欲天、四天下人、畜生、饿鬼、地狱等是也；二是色界，所谓初禅、二禅、三禅、四禅天等是也；三是无色界，所谓空处、识处、无所有处、非想非非想处天等是也。此三界，盖是生死凡夫流转之闇宅。虽复苦乐小殊，修短暂异，统而观之，莫非有漏。倚伏相乘，循环无际；杂生触受，四倒长拘；且因且果，虚伪相袭。安乐，是菩萨慈悲正观之由生，如来神力本愿之所建。胎、卵、湿生，缘兹高揖。业系长维，从此永断。续括之权，不待劝而弯弓。劳谦善让，齐普贤而同德。胜过三界，抑是近言。

    【究竟如虚空，广大无边际。】
    此二句，名庄严量功德成就。
    佛本所以起此庄严量功德者，见三界狭小，堕（败城阜）陉（山绝坎）陪（重土，一曰满）陼（如渚者，陼丘）。或宫观迫迮，或土田逼隘，或志求路促，或山河隔障，或国界分部。有如此等种种拘局事。是故菩萨兴此庄严量功德愿：“愿我国土如虚空广大无际。”
    “如虚空”者，言来生者虽众，犹若无也。“广大无际”者，成上“如虚空”义。何故如虚空？以广大无际故。“成就”者，言十方众生往生者，若已生，若今生，若当生，虽无量无边，毕竟常如虚空，广大无际，终无满时。是故言：“究竟如虚空，广大无边际。”
    问曰：如维摩方丈，苞容有余。何必国界无赀，乃称广大？
    答曰：所言广大，非必以畦（五十亩）畹（三十亩）为喻。但言如空，亦何累方丈？又方丈之所苞容，在狭而广。核论果报，岂若在广而广耶？

    【正道大慈悲，出世善根生。】
    此二句，名庄严性功德成就。
    佛本何故起此庄严？见有国土，以爱欲故，则有欲界。以攀厌禅定故，则有色、无色界。此三界皆是有漏邪道所生。长寝大梦，莫知悕出。是故兴大悲心：“愿我成佛，以无上正见道，起清净土，出于三界。”
    “性”是“本”义，言此净土随顺法性，不乖法本。事同《华严经》宝王如来性起义。又言积习成性，指法藏菩萨集诸波罗蜜积习所成。亦言“性”者，是圣种性。序法藏菩萨于世自在王佛所，悟无生法忍，尔时位名圣种性。于是性中，发四十八大愿，修起此土，即曰安乐净土。是彼因所得。果中说因，故名为“性”。又言“性”是必然义、不改义。如海性一味，众流入者必为一味，海味不随彼改也。又如人身性不净故，种种妙好色香美味，入身皆为不净。安乐净土诸往生者，无不净色，无不净心，毕竟皆得清净平等无为法身，以安乐国土清净性成就故。
    “正道大慈悲出世善根生”者，平等大道也。平等道所以名为正道者，平等是诸法体相，以诸法平等，故发心等；发心等，故道等；道等，故大慈悲等。大慈悲是佛道正因，故言：“正道大慈悲”。慈悲有三缘：一者众生缘，是小悲；二者法缘，是中悲；三者无缘，是大悲。大悲即出世善也。安乐净土，从此大悲生故，故谓此大悲为净土之根。故曰：“出世善根生”。

    【净光明满足，如镜日月轮。】
    此二句，名庄严形相功德成就。
    佛本所以起此庄严功德者，见日行四域，光不周三方；庭燎在宅，明不满十仞。以是故起满净光明愿。如日月光轮，满足自体。彼安乐净土，虽复广大无边，清净光明无不充塞。故曰：“净光明满足，如镜日月轮。”

    【备诸珍宝性，具足妙庄严。】
    此二句，名庄严种种事功德成就。
    佛本何故起此庄严？见有国土，以泥土为宫饰，以木石为华观。或雕金镂玉，意愿不充。或营备百千，具受辛苦。以此故兴大悲心：“愿我成佛，必使珍宝具足，严丽自然，相忘于有余，自得于佛道。”此庄严事，纵使毗首羯磨，工称妙绝，积思竭想，岂能取图？
    “性”者，“本”义也。能生既净，所生焉得不净。故经言：“随其心净，则佛土净。”是故言：“备诸珍宝性，具足妙庄严。”

    【无垢光焰炽，明净曜世间。】
    此二句，名庄严妙色功德成就。
    佛本何故起此庄严？见有国土，优劣不同。以不同故，高下以形。高下既形，是非以起。是非既起，长沦三有。是故兴大悲心，起平等愿：“愿我国土光焰炽盛，第一无比。不如人天金色，能有夺者。”
    若为相夺？如明镜在金边则不现。今日时中金，比佛在时金则不现。佛在时金，比阎浮那金则不现。阎浮那金，比大海中转轮王道中金沙则不现。转轮王道中金沙，比金山则不现。金山，比须弥山金则不现。须弥山金，比三十三天璎珞金则不现。三十三天璎珞金，比焰摩天金则不现。焰摩天金，比兜率陀天金则不现。兜率陀天金，比化自在天金则不现。化自在天金，比他化自在天金则不现。他化自在天金，比安乐国中光明则不现。
    所以者何？彼土金光，从绝垢业生故，清净无不成就故。安乐净土，是无生忍菩萨净业所起，阿弥陀如来法王所领，阿弥陀如来为增上缘故。是故言：“无垢光焰炽，明净曜世间。”“曜世间”者，曜二种世间也。

    【宝性功德草，柔软左右旋，触者生胜乐，过迦旃邻陀。】
    此四句，名庄严触功德成就。
    佛本何故起此庄严？见有国土，虽宝重金玉，不得为衣服。珍玩明镜，无议于敷具。斯缘悦于目，不便于身也。身眼二情，岂弗矛盾乎？是故愿言：“使我国土，人天六情，和于水乳，卒去楚越之劳。”所以七宝柔软，悦目便身。
    “迦旃邻陀”者，天竺柔软草名也，触之者能生乐受，故以为喻。注者言：此间土、石、草、木，各有定体。译者何缘目彼宝为草耶？当以其葻（草得风貌）茸[艹/榮]（草旋貌）[艹/眇]（细草曰[艹/眇]），故以草目之耳。余若参译，当别有途。
    “生胜乐”者，触迦旃邻陀，生染着乐；触彼软宝，生法喜乐。二事相悬，非胜如何？是故言：“宝性功德草，柔软左右旋，触者生胜乐，过迦旃邻陀。”

    【宝华千万种，弥覆池流泉，微风动华叶，交错光乱转。】
    此四句，名庄严水功德成就。
    佛本何故起此愿？见有国土，或澐溺（江水大波，谓之澐溺）洪涛（大海波），滓沫惊人。或凝凘（流冰）[冫+夾][冫+枼]（冻相着），蹙（迫）枷怀忒（失常）。向无安悦之情，背有恐值之虑。菩萨见此，兴大悲心：“愿我成佛，所有流泉池沼，与宫殿相称。种种宝华，布为水饰。微风徐扇，映发有序。开神悦体，无一不可。”是故言：“宝华千万种，弥覆池流泉，微风动华叶，交错光乱转。”

    【宫殿诸楼阁，观十方无碍，杂树异光色，宝栏遍围绕。】
    此四句，名庄严地功德成就。
    佛本何故起此庄严？见有国土，嶕（高貌）峣峻岭，枯木横岑。岝峉（山不齐貌）陉（深山谷，亦山陗貌）嶙（深无崖），莦（恶草貌）茅（道多草不可行）盈壑。茫茫沧海，为绝目之川。葻葻广泽，为无踪之所。菩萨见此，兴大悲愿：“愿我国土，地平如掌。宫殿、楼阁，镜纳十方。的无所属，亦非不属。宝树、宝栏，互为映饰。”是故言：“宫殿诸楼阁，观十方无碍，杂树异光色，宝栏遍围绕。”

    【无量宝交络，罗网遍虚空，种种铃发响，宣吐妙法音。】
    此四句，名庄严虚空功德成就。
    佛本何故起此庄严？见有国土，烟云尘雾，蔽障太虚。震烈[雨/替]（雨声）霍（大雨），从上而堕。不祥灾（天火）霓（屈虹青赤，或白色阴气），每自空来。忧虑百端，为之毛竖。菩萨见此，兴大悲心：“愿我国土，宝网交络，罗遍虚空。铃铎宫商，鸣宣道法。视之无厌，怀道见德。”是故言：“无量宝交络，罗网遍虚空，种种铃发响，宣吐妙法音。”

    【雨华衣庄严，无量香普熏。】
    此二句，名庄严雨功德成就。
    佛本何故兴此庄严？见有国土，欲以服饰布地，延请所尊。或欲以香华、名宝，用表恭敬。而业贫感薄，是事不果。是故兴大悲愿：“愿我国土，常雨此物，满众生意。”
    何故以雨为言？恐取著云：“若常雨华、衣，亦应填塞虚空，何缘不妨？”是故以雨为喻。雨适时则无洪滔之患。安乐报岂有累情之物乎？经言：日夜六时，雨宝衣，雨宝华。宝质柔软。履践其上，则下四寸。随举足时，还复如故。用讫入宝地，如水入坎。是故言：“雨华衣庄严，无量香普熏。”

    【佛慧明净日，除世痴闇冥。】
    此二句，名庄严光明功德成就。
    佛本何故兴此庄严？见有国土，虽复顶背日光，而为愚痴所闇。是故愿言：“使我国土所有光明，能除痴闇，入佛智慧，不为无记之事。”
    亦云安乐国土光明，从如来智慧报起，故能除世闇冥。经言：“或有佛土，以光明为佛事。”即是此也。故言：“佛慧明净日，除世痴闇冥。”

    【梵声悟深远，微妙闻十方。】
    此二句，名庄严妙声功德成就。
    佛本何故兴此愿？见有国土，虽有善法，而名声不远。有名声虽远，复不微妙。有名声妙远，复不能悟物。是故起此庄严。
    天竺国称净行为“梵行”，称妙辞为“梵言”。彼国贵重梵天，多以“梵”为赞。亦言中国法与梵天通故也。“声”者，名也。名谓安乐土名。经言：“若人但闻安乐净土之名，欲愿往生，亦得如愿。”此名悟物之证也。《释论》言：“如斯净土，非三界所摄。何以言之？无欲故，非欲界；地居故，非色界；有色故，非无色界。盖菩萨别业所致耳。”出有而有曰“微”（“出有”者，谓出三有。“而有”者，谓净土有也），名能开悟曰“妙”（“妙”，好也。以名能悟物，故称“妙”）。是故言：“梵声悟深远，微妙闻十方。”

    【正觉阿弥陀，法王善住持。】
    此二句，名庄严主功德成就。
    佛本何故兴此愿？见有国土，罗刹为君，则率土相啖；宝轮驻殿，则四域无虞。譬之风靡，岂无本耶？是故兴愿：“愿我国土，常有法王。法王善力之所住持。”
    “住持”者，如黄鹄持子安，千龄更起。鱼母念持子，经泶（夏有水、冬无水曰泶）不坏。安乐国为正觉善持，其国岂有非正觉事耶？是故言：“正觉阿弥陀，法王善住持。”

    【如来净华众，正觉华化生。】
    此二句，名庄严眷属功德成就。
    佛本何故兴此愿？见有国土，或以胞血为身器，或以粪尿为生元。或槐棘高圻，出猜狂之子。或竖子婢腹，出卓荦之才。讥诮由之怀火，耻辱缘以抱冰。所以愿言：“使我国土，悉于如来净华中生。眷属平等，与夺无路。”故言：“如来净华众，正觉华化生。”

    【爱乐佛法味，禅三昧为食。】
    此二句，名庄严受用功德成就。
    佛本何故兴此愿？见有国土，或探巢破卵，为饛（盛食满貌）饶（饱也、多也）之膳。或悬沙指帒，为相慰之方。呜呼诸子，实可痛心。是故兴大悲愿：“愿我国土，以佛法、以禅定、以三昧为食，永绝他食之劳。”
    “爱乐佛法味”者，如日月灯明佛说《法华经》六十小劫，时会听者亦坐一处，六十小劫谓如食顷，无有一人若身若心而生懈倦。以禅定为食者，谓诸大菩萨常在三昧，无他食也。“三昧”者，彼诸人天若须食时，百味嘉肴，罗列在前。眼见色，鼻闻香，身受适悦，自然饱足。讫已化去，若须复现。其事在经。是故言：“爱乐佛法味，禅三昧为食。”

    【永离身心恼，受乐常无间。】
    此二句，名庄严无诸难功德成就。
    佛本何故兴此愿？见有国土，或朝预衮宠，夕惶斧钺。或幼舍蓬藜，长列方丈。或鸣笳道出，历经催还。有如是等种种违夺。是故愿言：“使我国土，安乐相续，毕竟无间。”
    身恼者，饥渴、寒热、杀害等也。心恼者，是非、得失、三毒等也。是故言：“永离身心恼，受乐常无间。”

    【大乘善根界，等无讥嫌名，女人及根缺，二乘种不生。】
    此四句，名庄严大义门功德成就。门者，通大义之门也。大义者，大乘所以也。如人造城，得门则入。若人得生安乐者，是则成就大乘之门也。
    佛本何故兴此愿？见有国土，虽有佛如来、贤圣等众。由国浊故，分一说三。或以拓眉致诮，或缘指语招讥。是故愿言：“使我国土，皆是大乘一味，平等一味。根败种子，毕竟不生。女人、残缺，名字亦断。”是故言：“大乘善根界，等无讥嫌名，女人及根缺，二乘种不生。”
    问曰：案王舍城所说《无量寿经》，法藏菩萨四十八愿中言：“设我得佛，国中声闻，有能计量知其数者，不取正觉。”是有声闻一证也。又《十住毗婆沙》中，龙树菩萨造《阿弥陀赞》云：“超出三界狱，目如莲华叶，声闻众无量，是故稽首礼。”是有声闻二证也。又《摩诃衍论》中言：“佛土种种不同。或有佛土，纯是声闻僧。或有佛土，纯是菩萨僧。或有佛土，菩萨、声闻会为僧，如阿弥陀安乐国等是也。”是有声闻三证也。诸经中有说安乐国处，多言有声闻，不言无声闻。声闻即是二乘之一。《论》言乃至无二乘名，此云何会？
    答曰：以理推之，安乐净土不应有二乘。何以言之？夫有病则有药，理数之常也。《法华经》言：“释迦牟尼如来，以出五浊世故，分一为三。”净土既非五浊，无三乘明矣。《法华经》道诸声闻：“是人于何而得解脱？但离虚妄，名为解脱。是人实未得一切解脱，以未得无上道故。”核推此理，阿罗汉既未得一切解脱，必应有生。此人更不生三界。三界外除净土更无生处，是以唯应于净土生。如言声闻者，是他方声闻来生，仍本名故，称为声闻。如天帝释生人中时，姓憍尸迦。后虽为天主，佛欲使人知其由来，与帝释语时，犹称憍尸迦。其此类也。又此《论》但言“二乘种不生”，谓安乐国不生二乘种子，亦何妨二乘来生耶？譬如橘栽不生江北，河洛果肆亦见有橘。又言鹦鹉不渡陇西，赵魏架桁亦有鹦鹉。此二物但言其种不渡。彼有声闻亦如是。作如是解，经、论则会。
    问曰：名以召事，有事乃有名。安乐国既无二乘、女人、根缺之事，亦何须复言无此三名耶？
    答曰：如软心菩萨，不甚勇猛，讥言声闻。如人谄曲，或复儜弱，讥言女人。又如眼虽明而不识事，讥言盲人。又如耳虽聪而听义不解，讥言聋人。又如舌虽语而讷口寋吃，讥言哑人。有如是等根虽具足，而有讥嫌之名。是故须言乃至无名，明净土无如是等与夺之名。
    问曰：寻法藏菩萨本愿，及龙树菩萨所赞，皆似以彼国声闻众多为奇。此有何义？
    答曰：声闻以实际为证，计不应更能生佛道根芽。而佛以本愿不可思议神力，摄令生彼。必当复以神力生其无上道心。譬如鸩鸟入水，鱼蚌咸死。犀牛触之，死者皆活。如此不应生而生，所以可奇。然五不思议中，佛法最不可思议。佛能使声闻复生无上道心，真不可思议之至也。

    【众生所愿乐，一切能满足。】
    此二句，名庄严一切所求满足功德成就。
    佛本何故兴此愿？见有国土，或名高位重，潜处无由。或人凡姓鄙，悕出靡路。或修短系业，制不在己，如阿私陀仙人类也。有如是等为业风所吹，不得自在。是故愿言：“使我国土，各称所求，满足情愿。”是故言：“众生所愿乐，一切能满足。”

    【是故愿生彼，阿弥陀佛国。】
    此二句，结成上观察十七种庄严国土成就，所以愿生。
    释器世间清净，讫之于上。

    △次观众生世间清净。此门中分为二别：一者观察阿弥陀如来庄严功德，二者观察彼诸菩萨庄严功德。观察如来庄严功德中有八种，至文当目。
    问曰：有论师泛解“众生”名义，以其轮转三有，受众多生死，故名“众生”。今名佛、菩萨为“众生”，是义云何？
    答曰：经言：“一法有无量名，一名有无量义。”如以受众多生死故名为“众生”者，此是小乘家释三界中众生名义，非大乘家众生名义也。大乘家所言“众生”者，如《不增不减经》言：“言众生者，即是不生不灭义。”何以故？若有生，生已复生，有无穷过故，有不生而生过故，是故无生。若有生，可有灭。既无生，何得有灭？是故无生无灭，是“众生”义。如经中言：“五受阴通达空无所有，是苦义。”斯其类也。

    【无量大宝王，微妙净华台。】
    此二句，名庄严座功德成就。
    佛本何故庄严此座？见有菩萨，于末后身敷草而坐，成阿耨多罗三藐三菩提。人天见者，不生增上信、增上恭敬、增上爱乐、增上修行。是故愿言：“我成佛时，使无量大宝王微妙净华台以为佛座。”
    “无量”者，如《观无量寿经》言：“七宝地上，有大宝莲华王座。莲华一一叶，作百宝色。有八万四千脉，犹如天画。脉有八万四千光。华叶小者，纵广二百五十由旬。如是华有八万四千叶。一一叶间，有百亿摩尼珠王以为映饰。一一摩尼放千光明，其光如盖，七宝合成，遍覆地上。释迦毗楞伽宝以为其台。此莲华台，八万金刚甄叔迦宝、梵摩尼宝、妙真珠网，以为校饰。于其台上，自然而有四柱宝幢。一一宝幢，如百千万亿须弥山。幢上宝幔，如夜摩天宫。有五百亿微妙宝珠以为映饰。一一宝珠，有八万四千光。一一光，作八万四千异种金色。一一金色，遍安乐宝土，处处变化，各作异相。或为金刚台，或作真珠网，或作杂华云。于十方面，随意变现，施作佛事。”如是等事，出过数量。是故言：“无量大宝王，微妙净华台。”

    【相好光一寻，色像超群生。】
    此二句，名庄严身业功德成就。
    佛本何故庄严如此身业？见有佛身，受一丈光明。于人身光，不甚超绝。如转轮王相好亦大同。提婆达多所减唯二，致令阿阇世王以兹惑乱。删阇耶等敢如螳螂，或如此类也。是故庄严如此身业。
    案此间诂训，六尺曰寻。如《观无量寿经》言：“阿弥陀如来身高六十万亿那由他恒河沙由旬，佛圆光如百亿三千大千世界。”译者以“寻”而言，何其晦乎！里舍间人，不简纵横长短，咸谓横舒两手臂为“寻”。若译者或取此类，用准阿弥陀如来舒臂为言，故称“一寻”者。圆光亦应径六十万亿那由他恒河沙由旬。是故言：“相好光一寻，色像超群生。”
    问曰：《观无量寿经》言：“诸佛如来是法界身，入一切众生心想中。是故汝等心想佛时，是心即是三十二相、八十随形好。是心作佛，是心是佛。诸佛正遍知海，从心想生。”是义云何？
    答曰：身名集成，界名事别。如眼界缘根、色、空、明、作意五因缘生，名为眼界。是眼但自行己缘，不行他缘，以事别故。耳、鼻等界亦如是。言“诸佛如来是法界身”者，法界是众生心法也。以心能生世间、出世间一切诸法，故名心为法界。法界能生诸如来相好身，亦如色等能生眼识，是故佛身名法界身。是身不行他缘，是故入一切众生心想中。
    “心想佛时，是心即是三十二相、八十随形好”者，当众生心想佛时，佛身相好，显现众生心中也。譬如水清则色像现，水之与像，不一不异。故言佛相好身即是心想也。
    “是心作佛”者，言心能作佛也。“是心是佛”者，心外无佛也。譬如火从木出，火不能离木也。以不离木故，则能烧木。木为火烧，木即为火也。
    “诸佛正遍知海从心想生”者。正遍知者，真正如法界而知也。法界无相，故诸佛无知也。以无知，故无不知也。无知而知者，是正遍知也。是知深广不可测量，故譬海也。

    【如来微妙声，梵响闻十方。】
    此二句，名庄严口业功德成就。
    佛本何故兴此庄严？见有如来，名似不尊。如外道軵（推车）人，称“瞿昙”姓。成道日声，唯彻梵天。是故愿言：“使我成佛，妙声遐布，闻者悟忍。”是故言：“如来微妙声，梵响闻十方。”

    【同地水火风，虚空无分别。】
    此二句，名庄严心业功德成就。
    佛本何故兴此庄严？见有如来说法云：“此黑此白，此不黑不白，下法、中法、上法、上上法。”有如是等无量差别品，似有分别。是故愿言：“使我成佛，如地荷负，无轻重之殊。如水润长，无莦（恶草）葀（瑞草）之异。如火成熟，无芳臭之别。如风起发，无眠寤之差。如空苞受，无开塞之念。得之于内，物安于外。虚往实归，于是乎息。”是故言：“同地水火风，虚空无分别。”

    【天人不动众，清净智海生。】
    此二句，名庄严大众功德成就。
    佛本何故起此庄严？见有如来说法轮下，所有大众，诸根性欲种种不同。于佛智慧，若退若没，以不等故，众不纯净。所以兴愿：“愿我成佛，所有天人，皆从如来智慧清净海生。”
    “海”者，言佛一切种智深广无涯，不宿二乘杂善中下死尸，喻之如海。是故言：“天人不动众，清净智海生。”“不动”者，言彼天人成就大乘根，不可倾动也。

    【如须弥山王，胜妙无过者。】
    此二句，名庄严上首功德成就。
    佛本何故起此愿？见有如来众中，或有强梁者，如提婆达多流比。或有国王与佛并治，不知甚推佛。或有请佛，以他缘废忘。有如是等，似上首力不成就。是故愿言：“我为佛时，愿一切大众，无能生心敢与我等。唯一法王，更无俗王。”是故言：“如须弥山王，胜妙无过者。”

    【天人丈夫众，恭敬绕瞻仰。】
    此二句，名庄严主功德成就。
    佛本何故起此庄严？见有佛如来，虽有大众，众中亦有不甚恭敬。如一比丘语释迦牟尼佛：“若不与我解十四难，我当更学余道。”亦如居迦离谤舍利弗，佛三语而三不受。又如诸外道辈，假入佛众，而常伺求佛短。又如第六天魔，常于佛所，作诸留难。有如是等种种不恭敬相。是故愿言：“使我成佛，天人大众恭敬无倦。”
    所以但言“天人”者，净土无女人及八部鬼神故也。是故言：“天人丈夫众，恭敬绕瞻仰。”

    【观佛本愿力，遇无空过者，能令速满足，功德大宝海。】
    此四句，名庄严不虚作住持功德成就。
    佛本何故起此庄严？见有如来，但以声闻为僧，无求佛道者。或有值佛而不免三途，善星、提婆达多、居迦离等是也。又人闻佛名号，发无上道心，遇恶因缘，退入声闻、辟支佛地者。有如是等空过者、退没者。是故愿言：“使我成佛时，值遇我者，皆速疾满足无上大宝。”是故言：“观佛本愿力，遇无空过者，能令速满足，功德大宝海。”“住持”义如上。
    观佛庄严八种功德，讫之于上。

    △次观安乐国诸大菩萨四种庄严功德成就。
    问曰：观如来庄严功德，何所阙少？复须观菩萨功德耶？
    答曰：如有明君，则有贤臣。尧舜之称无为，是其比也。若使但有如来法王，而无大菩萨法臣。于翼赞道，岂足云满？亦如薪积小，则火不大。如经言：阿弥陀佛国，有无量无边诸大菩萨，如观世音、大势至等，皆当一生于他方次补佛处。若人称名忆念者、归依者、观察者，如《法华经·普门品》说，无愿不满。然菩萨爱乐功德，如海吞流，无止足情。亦如释迦牟尼如来，闻一目闇比丘吁言：“谁爱功德，为我维针？”尔时如来从禅定起，来到其所，语言：“我爱福德。”遂为其维针。尔时失明比丘暗闻佛语声，惊喜交集，白佛言：“世尊！世尊功德犹未满耶？”佛报言：“我功德圆满，无所复须。但我此身从功德生，知功德恩分故，是故言爱。”如所问观佛功德，实无愿不充。所以复观菩萨功德者，有如上种种义故耳。

    【安乐国清净，常转无垢轮，化佛菩萨日，如须弥住持。】
    佛本何故起此庄严？见有佛土，但是小菩萨，不能于十方世界广作佛事。或但声闻、人、天，所利狭小。是故兴愿：“愿我国中，有无量大菩萨众，不动本处，遍至十方，种种应化，如实修行，常作佛事。”
    譬如日在天上，而影现百川。日岂来耶？岂不来耶？如《大集经》言：“譬如有人善治堤塘，量其所宜，及放水时，不加心力。菩萨亦如是，先治一切诸佛及众生应供养、应教化种种堤塘。及入三昧，身心不动，如实修行，常作佛事。”如实修行者，虽常修行，实无所修行也。是故言：“安乐国清净，常转无垢轮，化佛菩萨日，如须弥住持。”

    【无垢庄严光，一念及一时，普照诸佛会，利益诸群生。】
    佛本何故起此庄严？见有如来眷属，欲供养他方无量诸佛，或欲教化无量众生。此没彼出，先南后北。不能以一念一时，放光普照，遍至十方世界，教化众生。有出没、前后相故。是故兴愿：“愿我佛土诸大菩萨，于一念时顷，遍至十方，作种种佛事。”是故言：“无垢庄严光，一念及一时，普照诸佛会，利益诸群生。”
    问曰：上章云身不动摇，而遍至十方。不动而至，岂非是一时义耶？与此若为差别？
    答曰：上但言不动而至，或容有前后。此言无前无后，是为差别。亦是成上不动义。若不一时，则是往来。若有往来，则非不动。是故为成上不动义故，须观一时。

    【雨天乐华衣，妙香等供养，赞诸佛功德，无有分别心。】
    佛本何故起此庄严？见有佛土，菩萨、人、天志趣不广，不能遍至十方无穷世界，供养诸佛如来大众。或以己土秽浊，不敢向诣净乡。或以所居清净，鄙薄秽土。以如此等种种局分，于诸佛如来所，不能周遍供养，发起广大善根。是故愿言：“我成佛时，愿我国土一切菩萨、声闻、天人大众，遍至十方一切诸佛大会处所，雨天乐、天华、天衣、天香，以巧妙辩辞，供养赞叹诸佛功德。”
    虽叹秽土如来大慈谦忍，不见佛土有杂秽相。虽叹净土如来无量庄严，不见佛土有清净相。何以故？以诸法等故，诸如来等，是故诸佛如来名为等觉。若于佛土起优劣心，假使供养如来，非法供养也。是故言：“雨天乐华衣，妙香等供养，赞诸佛功德，无有分别心。”

    【何等世界无，佛法功德宝，我愿皆往生，示佛法如佛。】
    佛本何故起此愿？见有软心菩萨，但乐有佛国土修行，无慈悲坚牢心。是故兴愿：“愿我成佛时，我土菩萨，皆慈悲勇猛，坚固志愿。能舍清净土，至他方无佛、法、僧处，住持庄严佛、法、僧宝，示如有佛，使佛种处处不断。”是故言：“何等世界无，佛法功德宝，我愿皆往生，示佛法如佛。”
    观菩萨四种庄严功德成就，讫之于上。

    △次下四句，是回向门。
    【我作论说偈，愿见弥陀佛，普共诸众生，往生安乐国。】
    此四句，是论主回向门。回向者，回己功德，普施众生，共见阿弥陀如来，生安乐国。

    【无量寿修多罗章句，我以偈颂总说竟。】
    问曰：天亲菩萨“回向章”中，言：“普共诸众生，往生安乐国。”此指共何等众生耶？
    答曰：案王舍城所说《无量寿经》，佛告阿难：“十方恒河沙诸佛如来，皆共称叹无量寿佛威神功德不可思议。诸有众生，闻其名号，信心欢喜，乃至一念至心回向，愿生彼国，即得往生，住不退转。唯除五逆、诽谤正法。”案此而言，一切外凡夫人，皆得往生。又如《观无量寿经》，有九品往生。下下品生者：“或有众生作不善业，五逆十恶，具诸不善。如此愚人，以恶业故，应堕恶道，经历多劫，受苦无穷。如此愚人，临命终时，遇善知识，种种安慰，为说妙法，教令念佛。此人苦逼，不遑念佛。善友告言：‘汝若不能念者，应称无量寿佛。’如是至心令声不绝，具足十念，称‘南无阿弥陀佛’。称佛名故，于念念中，除八十亿劫生死之罪。命终之时，见金莲华犹如日轮，住其人前。如一念顷，即得往生极乐世界。于莲华中，满十二大劫，莲华方开（当以此消五逆罪也）。观世音、大势至，以大悲音声，为其广说诸法实相，除灭罪法。闻已欢喜，应时即发菩提之心。是名下品下生者。”以此经证，明知下品凡夫，但令不诽谤正法，信佛因缘，皆得往生。
    问曰：《无量寿经》言：愿往生者，皆得往生，唯除五逆、诽谤正法。《观无量寿经》言：作五逆十恶，具诸不善，亦得往生。此二经云何会？
    答曰：一经以具二种重罪：一者五逆，二者诽谤正法。以此二种罪故，所以不得往生。一经但言作十恶五逆等罪，不言诽谤正法。以不谤正法故，是故得生。
    问曰：假使一人具五逆罪，而不诽谤正法，经许得生。复有一人但诽谤正法，而无五逆诸罪，愿往生者，得生与否？
    答曰：但令诽谤正法，虽更无余罪，必不得生。何以言之？经言：五逆罪人，堕阿鼻大地狱中，具受一劫重罪。诽谤正法人，堕阿鼻大地狱中，此劫若尽，复转至他方阿鼻大地狱中。如是展转经百千阿鼻大地狱，佛不记得出时节。以诽谤正法罪极重故。又正法者，即是佛法。此愚痴人既生诽谤，安有愿生佛土之理？假使但贪彼土安乐而愿生者，亦如求非水之冰、无烟之火，岂有得理？
    问曰：何等相是诽谤正法？
    答曰：若言：“无佛、无佛法，无菩萨、无菩萨法。”如是等见，若心自解，若从他受，其心决定，皆名诽谤正法。
    问曰：如是等计，但是己事。于众生有何苦恼，逾于五逆重罪耶？
    答曰：若无诸佛菩萨说世间、出世间善道，教化众生者，岂知有仁、义、礼、智、信耶？如是世间一切善法皆断，出世间一切贤圣皆灭。汝但知五逆罪为重，而不知五逆罪从无正法生。是故谤正法人，其罪最重。
    问曰：《业道经》言：“业道如称，重者先牵。”如《观无量寿经》言：有人造五逆十恶，具诸不善，应堕恶道，经历多劫，受无量苦。临命终时，遇善知识，教称“南无阿弥陀佛”。如是至心令声不绝，具足十念，便得往生安乐净土。即入大乘正定之聚，毕竟不退。与三途诸苦永隔。“先牵”之义，于理如何？又旷劫已来，备造诸行有漏之法，系属三界。但以十念念阿弥陀佛，便出三界。“系业”之义，复欲云何？
    答曰：汝谓五逆十恶系业等为重，以下下品人十念为轻，应为罪所牵，先堕地狱，系在三界者。今当以义较量：轻重之义，在心、在缘、在决定，不在时节久近多少也。
    云何在心？彼造罪人，自依止虚妄颠倒见生。此十念者，依善知识方便安慰，闻实相法生。一实一虚，岂得相比？譬如千岁闇室，光若暂至，即便明朗。闇岂得言在室千岁而不去耶？是名在心。
    云何在缘？彼造罪人，自依止妄想心，依烦恼虚妄果报众生生。此十念者，依止无上信心，依阿弥陀如来方便庄严真实清净无量功德名号生。譬如有人被毒箭所中，截筋破骨。闻灭除药鼓，即箭出毒除（《首楞严经》言：“譬如有药，名曰灭除。若斗战时，用以涂鼓。闻鼓声者，箭出毒除。菩萨摩诃萨亦复如是，住首楞严三昧，闻其名者，三毒之箭自然拔出”）。岂可得言彼箭深毒厉，闻鼓音声不能拔箭去毒耶？是名在缘。
    云何在决定？彼造罪人，依止有后心、有间心生。此十念者，依止无后心、无间心生。是名决定。
    较量三义，十念者重，重者先牵，能出三有。两经一义耳。
    问曰：几时名为一念？
    答曰：百一生灭，名一刹那。六十刹那，名为一念。此中云念者，不取此时节也。但言忆念阿弥陀佛，若总相，若别相。随所观缘，心无他想。十念相续，名为十念。但称名号，亦复如是。
    问曰：心若他缘，摄之令还，可知念之多少。但知多少，复非无间。若凝心注想，复依何可得记念之多少？
    答曰：经言“十念”者，明业事成办耳。不必须知头数也。如言“蟪蛄不识春秋”，伊虫岂知朱阳之节乎？知者言之耳。十念业成者，是亦通神者言之耳。但积念相续，不缘他事便罢。复何暇须知念之头数也？若必须知，亦有方便。必须口授，不得题之笔点。

〖据《净土十要》附本、《大正藏》电子本校订〗

·清凉书屋点校·


往生论注卷下

无量寿经优婆提舍愿生偈注卷下

    【论曰：】
    “论曰”已下，此是解义分。此分中义有十重：一者愿偈大意，二者起观生信，三者观行体相，四者净入愿心，五者善巧摄化，六者离菩提障，七者顺菩提门，八者名义摄对，九者愿事成就，十者利行满足。
    “论”者，议也。言议偈所以也。“曰”者，词也。指下诸句，是议释偈词也。故言：“论曰”。

    △愿偈大意者
    【此愿偈明何义？示现观彼安乐世界，见阿弥陀如来，愿生彼国故。】

    △起观生信者
    此分中又有二重：一者示五念力，二者出五念门。
    示五念力者：
    【云何观？云何生信心？若善男子、善女人，修五念门行成就，毕竟得生安乐国土，见彼阿弥陀佛。】

    △出五念门者
    【何等五念门？一者礼拜门，二者赞叹门，三者作愿门，四者观察门，五者回向门。】
    “门”者，入出义也。如人得门，则入出无碍。前四念，是入安乐净土门。后一念，是出慈悲教化门。

    【云何礼拜？身业礼拜阿弥陀如来、应、正遍知。】
    诸佛如来，德有无量。德无量故，德号亦无量。若欲具谈，纸笔不能载也。是以诸经或举十名，或腾三号。盖存至宗而已，岂此尽耶？所言三号，即此“如来”、“应”、“正遍知”也。
    “如来”者，如法相解，如法相说。如诸佛安隐道来，此佛亦如是来。更不去后有中。故名“如来”。
    “应”者，“应供”也。佛结使除尽，得一切智慧，应受一切天地众生供养，故曰“应”也。
    “正遍知”者，知一切诸法实不坏相，不增不减。云何不坏？心行处灭，言语道过。诸法如涅槃相不动。故名“正遍知”。
    无碍光义，如前偈中解。

    【为生彼国意故。】
    何故言此？菩萨之法，常以昼三时、夜三时，礼十方一切诸佛，不必有愿生意。今应常作愿生意，故礼阿弥陀如来也。

    【云何赞叹？口业赞叹。】
    “赞”者，赞扬也。“叹”者，歌叹也。赞叹非口不宣，故曰“口业”也。

    【称彼如来名，如彼如来光明智相，如彼名义，欲如实修行相应故。】
    “称彼如来名”者，谓称无碍光如来名也。
    “如彼如来光明智相”者，佛光明是智慧相也。此光明照十方世界无有障碍，能除十方众生无明黑闇。非如日、月、珠光，但破空穴中闇也。
    “如彼名义，欲如实修行相应”者，彼无碍光如来名号，能破众生一切无明，能满众生一切志愿。然有称名忆念，而无明犹在，而不满所愿者。何者？由不如实修行，与名义不相应故也。云何为不如实修行，与名义不相应？谓不知如来是实相身，是为物身。又有三种不相应：一者信心不淳，若存若亡故；二者信心不一，无决定故；三者信心不相续，余念间故。此三句，展转相成。以信心不淳，故无决定；无决定，故念不相续。亦可念不相续，故不得决定信；不得决定信，故心不淳。与此相违，名与实修行相应。是故论主建言：“我一心”。
    问曰：名为法指，如指指月。若称佛名号，便得满愿者。指月之指，应能破闇。若指月之指，不能破闇。称佛名号，亦何能满愿耶？
    答曰：诸法万差，不可一概。有名即法，有名异法。名即法者，诸佛菩萨名号、“般若波罗蜜”及陀罗尼章句、禁咒音辞等是也。如《禁肿辞》云“日出东方，乍赤乍黄”等句。假使酉、亥行禁，不关日出，而肿得瘥。亦如行师对阵，但一切齿中诵：“临兵斗者皆陈列在前”。行诵此九字，五兵之所不中。《抱朴子》谓之“要道”者也。又苦转筋者，以木瓜对火熨之则愈。复有人但呼“木瓜”名亦愈。吾身得其效也。如斯近事，世间共知。况不可思议境界者乎？灭除药涂鼓之喻，复是一事。此喻已彰于前，故不重引。有名异法者，如指指月等名也。

    【云何作愿？心常作愿。一心专念，毕竟往生安乐国土，欲如实修行奢摩他故。】
    译“奢摩他”曰“止”。止者，止心一处，不作恶也。此译名乃不乖大意，于义未满。何以言之？如止心鼻端，亦名为止。不净观止贪，慈悲观止瞋，因缘观止痴，如是等亦名为止。如人将行不行，亦名为止。是知“止”语浮漫，不正得“奢摩他”名也。如椿、柘、榆、柳，虽皆名木。若但云“木”，安得榆、柳耶？
    “奢摩他”云“止”者，今有三义：一者一心专念阿弥陀如来，愿生彼土。此如来名号，及彼国土名号，能止一切恶。二者彼安乐土，过三界道。若人一生彼国，自然止身、口、意恶。三者阿弥陀如来正觉住持力，自然止求声闻、辟支佛心。此三种止，从如来如实功德生。是故言：“欲如实修行奢摩他故。”

    【云何观察？智慧观察。正念观彼，欲如实修行毗婆舍那故。】
    译“毗婆舍那”曰“观”。但泛言“观”，义亦未满。何以言之？如观身无常、苦、空、无我、九相等，皆名为观。亦如上“木”名，不得椿、柘也。
    “毗婆舍那”云“观”者，亦有二义：一者在此作想，观彼三种庄严功德。此功德如实故，修行者亦得如实功德。如实功德者，决定得生彼土。二者一得生彼净土，即见阿弥陀佛。未证净心菩萨，毕竟得证平等法身。与净心菩萨，与上地菩萨，毕竟同得寂灭平等。是故言：“欲如实修行毗婆舍那故。”

    【彼观察有三种。何等三种？一者观察彼佛国土庄严功德，二者观察阿弥陀佛庄严功德，三者观察彼诸菩萨庄严功德。】
    心缘其事曰“观”，观心分明曰“察”。

    【云何回向？不舍一切苦恼众生，心常作愿回向为首，得成就大悲心故。】
    回向有二种相：一者往相，二者还相。往相者，以己功德回施一切众生，作愿共往生彼阿弥陀如来安乐净土。还相者，生彼土已，得奢摩他、毗婆舍那方便力成就，回入生死稠林，教化一切众生共向佛道。若往若还，皆为拔众生渡生死海。是故言：“回向为首，得成就大悲心故。”

    △观行体相者
    此分中有二体：一者器体，二者众生体。
    器分中又有三重：一者国土体相，二者示现自利利他，三者入第一义谛。
    国土体相者：
    【云何观察彼佛国土庄严功德？彼佛国土庄严功德者，成就不可思议力故。如彼摩尼如意宝性，相似相对法故。】
    “不可思议力”者，总指彼佛国土十七种庄严功德力不可得思议也。诸经统言有五种不可思议：一者众生多少不可思议，二者业力不可思议，三者龙力不可思议，四者禅定力不可思议，五者佛法力不可思议。此中佛土不可思议，有二种力：一者业力，谓法藏菩萨出世善根大愿业力所成；二者正觉阿弥陀法王善住持力所摄。此不可思议，如下十七种，一一相皆不可思议。至文当释。
    “如彼摩尼如意宝性相似相对”者，借彼摩尼如意宝性，示安乐佛土不可思议性也。诸佛入涅槃时，以方便力，留碎身舍利，以福众生。众生福尽，此舍利变为摩尼如意宝珠。此珠多在大海中。大龙王以为首饰。若转轮圣王出世，以慈悲方便，能得此珠，于阎浮提作大饶益。若须衣服、饮食、灯明、乐具，随意所欲种种物时。王便洁斋，置珠于长竿头，发愿言：“若我实是转轮王者，愿宝珠雨如此之物，若遍一里，若十里，若百里，随我心愿。”尔时即便于虚空中雨种种物，皆称所须，满足天下一切人愿。以此宝性力故。彼安乐佛土亦如是，以安乐性种种成就故。
    “相似相对”者，彼宝珠力，求衣食者，能雨衣食等物，称求者意，非是不求。彼佛土则不然。性满足成就故，无所乏少。片取彼性为喻，故言“相似相对”。又彼宝但能与众生衣食等愿，不能与众生无上道愿。又彼宝但能与众生一身愿，不能与众生无量身愿。有如是等无量差别，故言“相似”。

    【观察彼佛国土庄严功德成就者，有十七种，应知。何等十七？一者庄严清净功德成就，二者庄严量功德成就，三者庄严性功德成就，四者庄严形相功德成就，五者庄严种种事功德成就，六者庄严妙色功德成就，七者庄严触功德成就，八者庄严三种功德成就，九者庄严雨功德成就，十者庄严光明功德成就，十一者庄严妙声功德成就，十二者庄严主功德成就，十三者庄严眷属功德成就，十四者庄严受用功德成就，十五者庄严无诸难功德成就，十六者庄严大义门功德成就，十七者庄严一切所求满足功德成就。】
    先举章门，次续提释。

    【庄严清净功德成就者，偈言“观彼世界相，胜过三界道”故。】
    此云何不思议？有凡夫人烦恼成就，亦得生彼净土。三界系业，毕竟不牵。则是不断烦恼，得涅槃分。焉可思议？

    【庄严量功德成就者，偈言“究竟如虚空，广大无边际”故。】
    此云何不思议？彼国人天，若意欲宫殿、楼阁，若广一由旬、若百由旬、若千由旬，千间、万间，随心所成，人各如此。又十方世界众生愿往生者，若已生、若今生、若当生，一时一日之顷，算数所不能知其多少，而彼世界常若虚空，无迫迮相。彼中众生，住如此量中，志愿广大，亦如虚空无有限量。彼国土量，能成众生心行量。何可思议？

    【庄严性功德成就者，偈言“正道大慈悲，出世善根生”故。】
    此云何不思议？譬如迦罗求罗虫，其形微小。若得大风，身如大山。随风大小，为己身相。生安乐众生亦复如是。生彼正道世界，即成就出世善根，入正定聚。亦如彼虫，非身而身。焉可思议？

    【庄严形相功德成就者，偈言“净光明满足，如镜日月轮”故。】
    此云何不思议？夫忍辱得端正，我心影响也。一得生彼，无瞋、忍之殊。人天色像，平等妙绝。盖净光之力也。彼光非心行，而为心行之事。焉可思议？

    【庄严种种事功德成就者，偈言“备诸珍宝性，具足妙庄严”故。】
    此云何不思议？彼种种事，或一宝、十宝、百千种宝。随心称意，无不具足。若欲令无，倏焉化没。心得自在，有逾神通。安可思议？

    【庄严妙色功德成就者，偈言“无垢光焰炽，明净曜世间”故。】
    此云何不思议？其光曜事，则映彻表里。其光曜心，则终尽无明。光为佛事，焉可思议？

    【庄严触功德成就者，偈言“宝性功德草，柔软左右旋，触者生胜乐，过迦旃邻陀”故。】
    此云何不思议？夫宝例坚强，而此柔软。触乐应著，而此增道。事同“爱作”，何可思议？
    有菩萨字“爱作”，形容端正，生人染著。经言：“染之者，或生天上，或发菩提心。”

    【庄严三种功德成就者，有三种事，应知。何等三种？一者水，二者地，三者虚空。】
    此三种所以并言，以同类者故也。何以言之？一者六大类，所谓虚空、识、地、水、火、风。二者无分别类，所谓地、水、火、风、虚空。但言三类者：识一大，属众生世间故；火一大，彼中无故；虽有风，风不可见故，无住处故。是以六大、五类中，取有而可庄严三种并言之。

    【庄严水功德成就者，偈言“宝华千万种，弥覆池流泉，微风动华叶，交错光乱转”故。】
    此云何不思议？彼净土人天，非水谷身，何须水耶？清净成就，不须洗濯，复何用水耶？彼中无四时，常调适不烦热，复何须水耶？不须而有，当有所以。
    经言：“彼诸菩萨及声闻，若入宝池，意欲令水没足，水即没足。欲令至膝，水即至膝。欲令至腰，水即至腰。欲令至颈，水即至颈。欲令灌身，自然灌身。欲令还复，水辄还复。调和冷暖，自然随意。开神悦体，荡除心垢。清明澄洁，净若无形。宝沙映彻，无深不照。微澜回流，转相灌注。安详徐逝，不迟不疾。波扬无量自然妙声，随其所应，莫不闻者。或闻佛声，或闻法声，或闻僧声，或闻寂静声、空无我声、大慈悲声、波罗蜜声，或闻十力无畏不共法声、诸通慧声、无所作声、不起灭声、无生忍声，乃至甘露灌顶众妙法声。如是等声，称其所闻，欢喜无量。随顺清净离欲寂灭真实之义，随顺三宝力无所畏不共之法，随顺通慧菩萨、声闻所行之道。无有三途苦难之名，但有自然快乐之音。是故其国名曰安乐。”此水为佛事，安可思议？

    【庄严地功德成就者，偈言“宫殿诸楼阁，观十方无碍，杂树异光色，宝栏遍围绕”故。】
    此云何不思议？彼种种事，或一宝、十宝、百宝、无量宝，随心称意，庄严具足。此庄严事，如净明镜，十方国土净秽诸相、善恶业缘，一切悉现。彼中人天见斯事故，探汤、不及之情，自然成就。亦如诸大菩萨，以照法性等宝为冠。此宝冠中，皆见诸佛，又了达一切诸法之性。又如佛说《法华经》时，放眉间光，照于东方万八千土，皆如金色。从阿鼻狱，上至有顶，诸世界中六道众生，生死所趣，善恶业缘，受报好丑，于此悉见。盖斯类也。此影为佛事，安可思议？

    【庄严虚空功德成就者，偈言“无量宝交络，罗网遍虚空，种种铃发响，宣吐妙法音”故。】
    此云何不思议？经言：“无量宝网，弥覆佛土。皆以金镂、真珠、百千杂宝、奇妙珍异，庄严校饰。周匝四面，垂以宝铃。光色晃耀，尽极严丽。自然德风，徐起微动。其风调和，不寒不暑，温凉柔软，不迟不疾。吹诸罗网及众宝树，演发无量微妙法音，流布万种温雅德香。其有闻者，尘劳垢习，自然不起。风触其身，皆得快乐。”此声为佛事，焉可思议？

    【庄严雨功德成就者，偈言“雨华衣庄严，无量香普熏”故。】
    此云何不思议？经言：“风吹散华，遍满佛土。随色次第，而不杂乱。柔软光泽，馨香芬烈。足履其上，陷下四寸。随举足已，还复如故。华用已讫，地辄开裂，以次化没，清净无遗。随其时节，风吹散华，如是六返。又众宝莲华，周满世界。一一宝华，百千亿叶。其华光明，无量种色。青色青光，白色白光。玄、黄、朱、紫，光色赫然。暐晔焕烂，明曜日月。一一华中，出三十六百千亿光。一一光中，出三十六百千亿佛，身色紫金，相好殊特。一一诸佛，又放百千光明，普为十方说微妙法。如是诸佛，各各安立无量众生于佛正道。”华为佛事，安可思议？

    【庄严光明功德成就者，偈言“佛慧明净日，除世痴闇冥”故。】
    此云何不思议？彼土光明，从如来智慧报起。触之者，无明黑闇，终必消除。光明非慧，能为慧用。焉可思议？

    【庄严妙声功德成就者，偈言“梵声悟深远，微妙闻十方”故。】
    此云何不思议？经言：“若人但闻彼国土清净安乐，克念愿生，亦得往生，即入正定聚。”此是国土名字为佛事，安可思议？

    【庄严主功德成就者，偈言“正觉阿弥陀，法王善住持”故。】
    此云何不思议？正觉阿弥陀不可思议。彼安乐净土，为正觉阿弥陀善力住持，云何可得思议耶？
    “住”名不异不灭。“持”名不散不失。如以不朽药涂种子，在水不烂，在火不焦，得因缘则生。何以故？不朽药力故。若人一生安乐净土，后时意愿生三界教化众生。舍净土命，随愿得生。虽生三界杂生水火中，无上菩提种子毕竟不朽。何以故？以经正觉阿弥陀善住持故。

    【庄严眷属功德成就者，偈言“如来净华众，正觉华化生”故。】
    此云何不思议？凡是杂生世界，若胎、若卵、若湿、若化，眷属若干，苦乐万品，以杂业故。彼安乐国土，莫非是阿弥陀如来正觉净华之所化生。同一念佛，无别道故。远通夫法界之内，皆为兄弟也。眷属无量，焉可思议？

    【庄严受用功德成就者，偈言“爱乐佛法味，禅三昧为食”故。】
    此云何不思议？不食而资命，盖所资有以也，岂不是如来满本愿乎？乘佛愿为我命，焉可思议？

    【庄严无诸难功德成就者，偈言“永离身心恼，受乐常无间”故。】
    此云何不思议？经言：“身为苦器，心为恼端。”而彼有身、有心，而受乐无间，安可思议？

    【庄严大义门功德成就者，偈言“大乘善根界，等无讥嫌名，女人及根缺，二乘种不生”故。净土果报，离二种讥嫌过，应知。一者体，二者名。体有三种：一者二乘人，二者女人，三者诸根不具人。无此三过故，名离体讥嫌。名亦三种。非但无三体，乃至不闻二乘、女人、诸根不具三种名故，名离名讥嫌。“等”者，平等一相故。】
    此云何不思议？夫诸天共器，饭有随福之色。足指按地，乃详金砾之旨。而愿往生者，本则三三之品，今无一二之殊。亦如淄渑一味，焉可思议？

    【庄严一切所求满足功德成就者，偈言“众生所愿乐，一切能满足”故。】
    此云何不思议？彼国人天，若欲愿往他方世界无量佛刹，供养诸佛菩萨，及所须供养之具，无不称愿。又欲舍彼寿命，向余国生，修短自在，随愿皆得。未阶自在之位，而同自在之用，焉可思议？

    △示现自利利他者
    【略说彼阿弥陀佛国土十七种庄严功德成就。示现如来自身利益大功德力成就，利益他功德成就故。】
    言“略”者，彰彼净土功德无量，非唯十七种也。夫须弥之入芥子，毛孔之纳大海，岂山、海之神乎？毛、芥之力乎？能神者神之耳。是故十七种虽曰利他，自利之义，炳然可知。

    △入第一义谛者
    【彼无量寿佛国土庄严，第一义谛妙境界相，十六句及一句，次第说，应知。】
    “第一义谛”者，佛因缘法也。此“谛”是“境”义，是故庄严等十六句，称为“妙境界相”。此义至“入一法句”文，当更解释。
    “及一句次第”者，谓观器净等总、别十七句观行次第也。云何起次？建章言：“归命无碍光如来，愿生安乐国。”此中有疑。疑言：“生为有本，众累之元。弃生愿生，生何可尽？”为释此疑，是故观彼净土庄严功德成就。明彼净土，是阿弥陀如来清净本愿无生之生，非如三有虚妄生也。何以言之？夫法性清净，毕竟无生。言生者，是得生者之情耳。生苟无生，生何所尽？尽夫生者，上失无为能为之身，下湎三空不空之痼。根败永亡，号振三千。无反无复，于斯招耻。体夫生理，谓之净土。净土之宅，所谓十七句是也。
    十七句中，总、别为二。初句是总相，所谓是清净佛土过三界道。彼过三界有何相？下十六种庄严功德成就相是也。一者量，究竟如虚空，广大无边际故。既知量，此量以何为本？是故观性。“性”是“本”义。彼净土，从正道大慈悲出世善根生。既言出世善根，此善根生何等相？是故次观庄严形相。既知形相，宜知形相何等体，是故次观种种事。既知种种事，宜知种种事妙色，是故次观妙色。既知妙色，此色有何触？是故次观触。既知身触，应知眼触，是故次观水、地、虚空庄严三事。既知眼触，应知鼻触，是故次观衣华香熏。既知眼、鼻等触，须知离染，是故次观佛慧明照。既知慧光净力，宜知声名远近，是故次观梵声远闻。既知声名，宜知谁为增上，是故次观主。既知有主，谁为主眷属？是故次观眷属。既知眷属，宜知此眷属若为受用，是故次观受用。既知受用，宜知此受用有难、无难，是故次观无诸难。既知无诸难，以何义故无诸难？是故次观大义门。既知大义门，宜知大义门满不满，是故次观所求满足。
    复次此十七句，非但释疑。观此十七种庄严成就，能生真实净信，必定得生彼安乐佛土。
    问曰：上言知生无生，当是上品生者。若下下品人，乘十念往生，岂非取实生耶？但取实生，即堕二执。一恐不得往生，二恐更生生惑。
    答：譬如净摩尼珠，置之浊水，水即清净。若人虽有无量生死之罪浊，闻彼阿弥陀如来至极无生清净宝珠名号，投之浊心。念念之中，罪灭心净，即得往生。又是摩尼珠，以玄黄币裹，投之于水，水即玄黄，一如物色。彼清净佛土，有阿弥陀如来无上宝珠，以无量庄严功德成就帛裹，投之于所往生者心水，岂不能转生见为无生智乎？又如冰上燃火，火猛则冰解，冰解则火灭。彼下品人，虽不知法性无生。但以称佛名力，作往生意，愿生彼土。彼土是无生界。见生之火，自然而灭。

    △众生体者
    此分中有二重：一者观佛，二者观菩萨。
    观佛者：
    【云何观佛庄严功德成就？观佛庄严功德成就者，有八种相，应知。】
    此“观”义已彰前偈。

    【何等八种？一者庄严座功德成就，二者庄严身业功德成就，三者庄严口业功德成就，四者庄严心业功德成就，五者庄严大众功德成就，六者庄严上首功德成就，七者庄严主功德成就，八者庄严不虚作住持功德成就。】

    【何者庄严座功德成就？偈言“无量大宝王，微妙净华台”故。】
    若欲观座，当依《观无量寿经》。

    【何者庄严身业功德成就？偈言“相好光一寻，色像超群生”故。】
    若欲观佛身，当依《观无量寿经》。

    【何者庄严口业功德成就？偈言“如来微妙声，梵响闻十方”故。】

    【何者庄严心业功德成就？偈言“同地水火风，虚空无分别”故。“无分别”者，无分别心故。】
    凡夫众生身、口、意三业以造罪，轮转三界，无有穷已。是故诸佛菩萨庄严身、口、意三业，用治众生虚诳三业也。云何用治？众生以身见故，受三途身、卑贱身、丑陋身、八难身、流转身。如是等众生，见阿弥陀如来相好、光明身者，如上种种身业系缚，皆得解脱。入如来家，毕竟得平等身业。众生以骄慢故，诽谤正法，毁訾贤圣，捐庳尊长（尊者，君、父、师也。长者，有德之人，及兄党也）。如是人应受拔舌苦、喑哑苦、言教不行苦、无名闻苦。如是等种种诸苦众生，闻阿弥陀如来至德名号、说法音声，如上种种口业系缚，皆得解脱。入如来家，毕竟得平等口业。众生以邪见故，心生分别。若有若无，若非若是，若好若丑，若善若恶，若彼若此，有如是等种种分别。以分别故，长沦三有，受种种分别苦、取舍苦，长寝大夜，无有出期。是众生若遇阿弥陀如来平等光照，若闻阿弥陀如来平等意业。是等众生，如上种种意业系缚，皆得解脱。入如来家，毕竟得平等意业。
    问曰：心是觉知相，云何可得同地、水、火、风无分别耶？
    答曰：心虽知相。入实相，则无知也。譬如蛇性虽曲，入竹筒则直。又如人身若针刺，若蜂螫，则有觉知。若石蛭啖，若甘刀割，则无觉知。如是等有知、无知，在于因缘。若在因缘，则非知、非无知也。
    问曰：心入实相，可令无知。云何得有一切种智耶？
    答曰：凡心有知，则有所不知。圣心无知，故无所不知。无知而知，知即无知也。
    问曰：既言无知故无所不知。若无所不知者，岂不是知种种法耶？既知种种之法，复云何言无所分别耶？
    答曰：诸法种种相，皆如幻化。然幻化象、马，非无长颈、鼻、首、足异。而智者观之，岂言定有象、马分别之耶？

    【何者庄严大众功德成就？偈言“天人不动众，清净智海生”故。】

    【何者庄严上首功德成就？偈言“如须弥山王，胜妙无过者”故。】

    【何者庄严主功德成就？偈言“天人丈夫众，恭敬绕瞻仰”故。】

    【何者庄严不虚作住持功德成就？偈言“观佛本愿力，遇无空过者，能令速满足，功德大宝海”故。】
    不虚作住持功德成就者，盖是阿弥陀如来本愿力也。今当略示虚作之相不能住持，用显彼不虚作住持之义。人有辍（止也）餐养士，或釁起舟中；积金盈库，而不免饿死。如斯之事，触目皆是。得非作得，在非守在。皆由虚妄业作，不能住持也。所言不虚作住持者，依本法藏菩萨四十八愿、今日阿弥陀如来自在神力。愿以成力，力以就愿。愿不徒然，力不虚设。力、愿相符，毕竟不差。故曰成就。

    【即见彼佛，未证净心菩萨，毕竟得证平等法身。与净心菩萨，与上地诸菩萨，毕竟同得寂灭平等故。】
    “平等法身”者，八地以上法性生身菩萨也。“寂灭平等”者，即此法身菩萨所证寂灭平等之法也。以得此寂灭平等法故，名为平等法身。以平等法身菩萨所得故，名为寂灭平等法也。此菩萨得报生三昧，以三昧神力，能一处一念一时，遍十方世界，种种供养一切诸佛，及诸佛大会众海。能于无量世界无佛、法、僧处，种种示现，种种教化，度脱一切众生，常作佛事。初无往来想、供养想、度脱想。是故此身名为平等法身，此法名为寂灭平等法也。
    “未证净心菩萨”者，初地以上、七地已还诸菩萨也。此菩萨亦能现身，若百、若千、若万、若亿、若百千万亿，无佛国土施作佛事。要须作心入三昧乃能，非不作心。以作心故，名为未得净心。此菩萨愿生安乐净土，即见阿弥陀佛。见阿弥陀佛时，与上地诸菩萨，毕竟身等、法等。龙树菩萨、婆薮槃头菩萨辈，愿生彼者，当为此耳。
    问曰：案《十地经》，菩萨进趣阶级，渐有无量功勋；经多劫数，然后乃得。此云何见阿弥陀佛时，毕竟与上地诸菩萨身等、法等耶？
    答曰：言“毕竟”者，未言“即等”也。毕竟不失此等，故言“等”耳。
    问曰：若不即等，复何待言？菩萨但登初地，以渐增进，自然当与佛等。何假言与上地菩萨等？
    答曰：菩萨于七地中，得大寂灭。上不见诸佛可求，下不见众生可度。欲舍佛道，证于实际。尔时若不得十方诸佛神力加劝，即便灭度，与二乘无异。菩萨若往生安乐，见阿弥陀佛，即无此难。是故须言“毕竟平等”。
    复次《无量寿经》中，阿弥陀如来本愿言：“设我得佛，他方佛土诸菩萨众来生我国，究竟必至一生补处。除其本愿自在所化，为众生故，被弘誓铠，积累德本，度脱一切。游诸佛国，修菩萨行，供养十方诸佛如来，开化恒沙无量众生，使立无上正真之道。超出常伦诸地之行，现前修习普贤之德。若不尔者，不取正觉。”案此经推，彼国菩萨，或可不从一地至一地。言十地阶次者，是释迦如来于阎浮提一应化道耳。他方净土，何必如此？五种不思议中，佛法最不可思议。若言菩萨必从一地至一地，无超越之理，未敢详也。譬如有树，名曰“好坚”。是树地生，百岁乃具。一日长高百丈，日日如此。计百岁之长，岂类修松耶？见松生长，日不过寸。闻彼好坚，何能不疑？即同有人闻释迦如来，证罗汉于一听，制无生于终朝。谓是接诱之言，非称实之说。闻此《论》事，亦当不信。夫非常之言，不入常人之耳。谓之不然，亦其宜也。

    【略说八句，示现如来自利利他功德庄严次第成就，应知。】
    此云何次第？前十七句，是庄严国土功德成就。既知国土相，应知国土之主，是故次观佛庄严功德。彼佛若为庄严，于何处坐？是故先观座。既知座已，宜知座主，是故次观佛庄严身业。既知身业，应知有何声名，是故次观佛庄严口业。既知名闻，宜知得名所以，是故次观庄严心业。既知三业具足，应为人天大师。堪受化者是谁？是故次观大众功德。既知大众有无量功德，宜知上首者谁，是故次观上首。上首是佛。既知上首，恐同长幼，是故次观主。既知是主，主有何增上？是故次观庄严不虚作住持。八句次第成已。

    △观菩萨者
    【云何观察菩萨庄严功德成就？观察菩萨庄严功德成就者，观彼菩萨有四种正修行功德成就，应知。】
    真如是诸法正体。体如而行，则是不行。不行而行，名如实修行。体唯一如，而义分为四。是故四行以一正统之。

    【何者为四？一者于一佛土身不动摇，而遍十方种种应化，如实修行，常作佛事。偈言“安乐国清净，常转无垢轮，化佛菩萨日，如须弥住持”故。开诸众生淤泥华故。】
    八地以上菩萨，常在三昧。以三昧力，身不动本处，而能遍至十方，供养诸佛，教化众生。
    “无垢轮”者，佛地功德也。佛地功德，无习气烦恼垢。佛为诸菩萨，常转此法轮。诸大菩萨，亦能以此法轮开导一切，无暂时休息。故言“常转”。
    法身如日，而应化身光遍诸世界也。言“日”未足以明不动，复言“如须弥住持”也。
    “淤泥华”者，经言：“高原陆地，不生莲华。卑湿淤泥，乃生莲华。”此喻凡夫在烦恼泥中，为菩萨开导，能生佛正觉华。谅夫！绍隆三宝，常使不绝。

    【二者彼应化身，一切时不前不后，一心一念，放大光明。悉能遍至十方世界，教化众生，种种方便，修行所作，灭除一切众生苦故。偈言“无垢庄严光，一念及一时，普照诸佛会，利益诸群生”故。】
    上言不动而至，容或至有前后。是故复言一念一时无前后也。

    【三者彼于一切世界，无余照诸佛会大众，无余广大无量供养、恭敬、赞叹诸佛如来功德。偈言“雨天乐华衣，妙香等供养，赞诸佛功德，无有分别心”故。】
    “无余”者，明遍至一切世界一切诸佛大会，无有一世界一佛会不至也。肇公言：“法身无像，而殊形并应。至韵无言，而玄籍弥布。冥权无谋，而动与事会。”盖斯意也。

    【四者彼于十方一切世界无三宝处，住持庄严佛、法、僧宝功德大海，遍示令解如实修行。偈言“何等世界无，佛法功德宝，我愿皆往生，示佛法如佛”故。】
    上三句虽言遍至，皆是有佛国土。若无此句，便是法身有所不法，上善有所不善。
    观行体相竟。

    △以下是解义中第四重，名为净入愿心。
    净入愿心者：
    【又向说观察庄严佛土功德成就、庄严佛功德成就、庄严菩萨功德成就。此三种成就，愿心庄严，应知。】
    “应知”者，应知此三种庄严成就，由本四十八愿等清净愿心之所庄严。因净故果净，非无因、他因有也。

    【略说入一法句故。】
    上国土庄严十七句、如来庄严八句、菩萨庄严四句，为广。入一法句，为略。何故示现广略相入？诸佛菩萨有二种法身：一者法性法身，二者方便法身。由法性法身，生方便法身。由方便法身，出法性法身。此二法身，异而不可分，一而不可同。是故广略相入，统以法名。菩萨若不知广略相入，则不能自利利他。

    【一法句者，谓清净句。清净句者，谓真实智慧、无为法身故。】
    此三句展转相入。依何义名之为法？以清净故。依何义名为清净？以真实智慧、无为法身故。
    “真实智慧”者，实相智慧也。实相无相，故真智无知也。“无为法身”者，法性身也。法性寂灭，故法身无相也。无相故能无不相，是故相好庄严，即法身也。无知故能无不知，是故一切种智，即真实智慧也。
    以真实而目智慧，明智慧非作、非非作也。以无为而标法身，明法身非色、非非色也。非于非者，岂非非之能是乎？盖无非之曰是也。自是无待夫非是也。非是、非非，百非之所不喻。是故言清净句。清净句者，谓真实智慧、无为法身也。

    【此清净有二种，应知。】
    上转入句中，通一法入清净，通清净入法身。今将别清净出二种故，故言“应知”。

    【何等二种？一者器世间清净，二者众生世间清净。器世间清净者，如向说十七种庄严佛土功德成就，是名器世间清净。众生世间清净者，如向说八种庄严佛功德成就、四种庄严菩萨功德成就，是名众生世间清净。如是一法句，摄二种清净义，应知。】
    夫众生为别报之体，国土为共报之用。体用不一，所以应知。然诸法心成，无余境界。众生及器，复不得异，不得一。不一则义分。不异同清净。器者，用也。谓彼净土，是彼清净众生之所受用，故名为器。如净食用不净器，以器不净故，食亦不净。不净食用净器，食不净故，器亦不净。要二俱洁，乃得称净。是以一清净名，必摄二种。
    问曰：言众生清净，则是佛与菩萨。彼诸人天，得入此清净数否？
    答曰：得名清净，非实清净。譬如出家圣人，以杀烦恼贼故，名为比丘。凡夫出家者，持戒、破戒，皆名比丘。又如灌顶王子，初生之时，具三十二相，七宝即为所属。虽未能为转轮王事，亦名转轮王，以其必为转轮王故。彼诸人天，亦复如是，皆入大乘正定之聚，毕竟当得清净法身。以当得故，得名清净。

    △善巧摄化者
    【如是菩萨，奢摩他、毗婆舍那广略修行，成就柔软心。】
    “柔软心”者，谓广略止观，相顺修行，成不二心也。譬如以水取影，清净相资而成就也。

    【如实知广略诸法。】
    “如实知”者，如实相而知也。广中二十九句，略中一句，莫非实相也。

    【如是成就巧方便回向。】
    “如是”者，如前后广略，皆实相也。以知实相故，则知三界众生虚妄相也。知众生虚妄，则生真实慈悲也。知真实法身，则起真实归依也。慈悲之与归依，巧方便在下。

    【何者菩萨巧方便回向？菩萨巧方便回向者，谓说礼拜等五种修行，所集一切功德善根，不求自身住持之乐，欲拔一切众生苦故。作愿摄取一切众生，共同生彼安乐佛国。是名菩萨巧方便回向成就。】
    案王舍城所说《无量寿经》，三辈生中，虽行有优劣，莫不皆发无上菩提之心。此无上菩提心，即是愿作佛心。愿作佛心，即是度众生心。度众生心，即摄取众生生净佛国土心。是故愿生彼安乐净土者，要发无上菩提心也。若人不发无上菩提心，但闻彼国土受乐无间，为乐故愿生，亦当不得往生也。是故言：“不求自身住持之乐，欲拔一切众生苦故。”“住持乐”者，谓彼安乐净土为阿弥陀如来本愿力之所住持，受乐无间也。
    凡释“回向”名义，谓以己所集一切功德，施与一切众生共向佛道。“巧方便”者，谓菩萨愿以己智慧火，烧一切众生烦恼草木。若有一众生不成佛，我不作佛。而众生未尽成佛，菩萨已自成佛。譬如火栝，欲摘一切草木烧令使尽。草木未尽，火栝已尽。以后其身而身先，故名巧方便。此中言方便者，谓作愿摄取一切众生，共同生彼安乐佛国。彼佛国即是毕竟成佛道路无上方便也。

    △离菩提障者
    【菩萨如是善知回向成就，即能远离三种菩提门相违法。何等三种？一者依智慧门，不求自乐，远离我心贪著自身故。】
    知进守退曰智，知空无我曰慧。依智故，不求自乐。依慧故，远离我心贪著自身。

    【二者依慈悲门，拔一切众生苦，远离无安众生心故。】
    拔苦曰慈，与乐曰悲。依慈故，拔一切众生苦。依悲故，远离无安众生心。

    【三者依方便门，怜愍一切众生心，远离供养恭敬自身心故。】
    正直曰方，外己曰便。依正直故，生怜愍一切众生心。依外己故，远离供养恭敬自身心。

    【是名远离三种菩提门相违法。】

    △顺菩提门者
    【菩萨远离如是三种菩提门相违法，得三种随顺菩提门法满足故。何等三种？一者无染清净心，以不为自身求诸乐故。】
    菩提是无染清净处。若为身求乐，即违菩提。是故无染清净心，是顺菩提门。

    【二者安清净心，以拔一切众生苦故。】
    菩提是安隐一切众生清净处。若不作心拔一切众生离生死苦，即便违菩提。是故拔一切众生苦，是顺菩提门。

    【三者乐清净心，以令一切众生得大菩提故，以摄取众生生彼国土故。】
    菩提是毕竟常乐处。若不令一切众生得毕竟常乐，则违菩提。此毕竟常乐依何而得？依大乘门。大乘门者，谓彼安乐佛国土是也。是故又言：“以摄取众生生彼国土故。”

    【是名三种随顺菩提门法满足，应知。】

    △名义摄对者
    【向说智慧、慈悲、方便三种门，摄取般若，般若摄取方便，应知。】
    般若者，达如之慧名。方便者，通权之智称。达如则心行寂灭，通权则备省众机。省机之智，备应而无知。寂灭之慧，亦无知而备省。然则智慧、方便，相缘而动，相缘而静。动不失静，智慧之功也。静不废动，方便之力也。是故智慧、慈悲、方便，摄取般若。般若摄取方便。
    “应知”者，谓应知智慧、方便，是菩萨父母。若不依智慧、方便，菩萨法则不成就。何以故？若无智慧，为众生时，则堕颠倒；若无方便，观法性时，则证实际。是故应知。

    【向说远离我心不贪著自身、远离无安众生心、远离供养恭敬自身心。此三种法，远离障菩提心，应知。】
    诸法各有障碍相，如风能障静、土能障水、湿能障火、五黑十恶障人天、四颠倒障声闻果。此中三种不远离，障菩提心。“应知”者，若欲得无障，当远离此三种障碍也。

    【向说无染清净心、安清净心、乐清净心。此三种心，略一处成就妙乐胜真心，应知。】
    乐有三种：一者外乐，谓五识所生乐。二者内乐，谓初禅、二禅、三禅意识所生乐。三者法乐乐，谓智慧所生乐。此智慧所生乐，从爱佛功德起。是远离我心、远离无安众生心、远离自供养心。是三种心，清净增进，略为“妙乐胜真心”。“妙”言其好，以此乐缘佛生故；“胜”言胜出三界中乐；“真”言不虚伪、不颠倒。

    △愿事成就者
    【如是菩萨智慧心、方便心、无障心、胜真心，能生清净佛国土，应知。】
    “应知”者，谓应知此四种清净功德，能得生彼清净佛国土，非是他缘而生也。

    【是名菩萨摩诃萨随顺五种法门，所作随意自在成就。如向所说身业、口业、意业、智业、方便智业，随顺法门故。】
    “随意自在”者，言此五种功德力，能生清净佛土，出没自在也。“身业”者，礼拜也。“口业”者，赞叹也。“意业”者，作愿也。“智业”者，观察也。“方便智业”者，回向也。言此五种业和合，则是随顺往生净土法门自在业成就。

    △利行满足者
    【复有五种门，渐次成就五种功德，应知。何者五门？一者近门，二者大会众门，三者宅门，四者屋门，五者园林游戏地门。】
    此五种，示现入、出次第相。入相中，初至净土是近相。谓入大乘正定聚，近阿耨多罗三藐三菩提。入净土已，便入如来大会众数。入众数已，当至修行安心之宅。入宅已，当至修行所居屋宇。修行成就已，当至教化地。教化地，即是菩萨自娱乐地。是故出门，称园林游戏地门。

    【此五种门，初四种门，成就入功德；第五门，成就出功德。】
    此入、出功德门，何者是。释言。

    【入第一门者，以礼拜阿弥陀佛，为生彼国故，得生安乐世界。是名入第一门。】
    礼佛愿生佛国，是初功德相。

    【入第二门者，以赞叹阿弥陀佛，随顺名义称如来名，依如来光明智相修行故，得入大会众数。是名入第二门。】
    依如来名义赞叹，是第二功德相。

    【入第三门者，以一心专念作愿生彼，修奢摩他寂静三昧行故，得入莲华藏世界。是名入第三门。】
    为修寂静止故，一心愿生彼国，是第三功德相。

    【入第四门者，以专念观察彼妙庄严，修毗婆舍那故，得到彼处，受用种种法味乐。是名入第四门。】
    “种种法味乐”者，毗婆舍那中，有观佛国土清净味、摄受众生大乘味、毕竟住持不虚作味、类事起行愿取佛土味。有如是等无量庄严佛道味，故言“种种”。是第四功德相。

    【出第五门者，以大慈悲，观察一切苦恼众生，示应化身，回入生死园烦恼林中，游戏神通，至教化地，以本愿力回向故。是名出第五门。】
    “示应化身”者，如《法华经》普门示现之类也。“游戏”有二义：一者自在义。菩萨度众生，譬如狮子搏鹿，所为不难，如似游戏。二者度无所度义。菩萨观众生，毕竟无所有。虽度无量众生，而实无一众生得灭度者。示度众生，如似游戏。言“本愿力”者，示大菩萨于法身中，常在三昧，而现种种身、种种神通、种种说法，皆以本愿力起。譬如阿修罗琴，虽无鼓者，而音曲自然。是名教化地第五功德相。

    【菩萨入四种门，自利行成就，应知。】
    “成就”者，谓自利满足也。“应知”者，谓应知由自利故，则能利他。非是不能自利而能利他也。

    【菩萨出第五门，回向利益他行成就，应知。】
    “成就”者，谓以回向因，证教化地果。若因若果，无有一事不能利他。“应知”者，谓应知由利他故，则能自利。非是不能利他而能自利也。

    【菩萨如是修五念门行，自利利他，速得成就阿耨多罗三藐三菩提故。】
    佛所得法，名为阿耨多罗三藐三菩提。以得此菩提，故名为佛。今言“速得阿耨多罗三藐三菩提”，是得早作佛也。
    “阿”名“无”；“耨多罗”名“上”；“三藐”名“正”；“三”名“遍”；“菩提”名“道”。统而译之，名为“无上正遍道”。“无上”者，言此道穷理尽性，更无过者。何以言之？以正故。“正”者，圣智也。如法相而知，故称为正智。法性无相，故圣智无知也。“遍”有二种：一者圣心遍知一切法，二者法身遍满法界。若身若心，无不遍也。“道”者，无碍道也。经言：“十方无碍人，一道出生死。”一道者，一无碍道也。无碍者，谓知生死即是涅槃，如是等入不二法门无碍相也。
    问曰：有何因缘，言“速得成就阿耨多罗三藐三菩提”？
    答曰：《论》言修五门行，以自利利他成就故。然核求其本，阿弥陀如来为增上缘。他利之与利他，谈有左右。若自佛而言，宜言利他。自众生而言，宜言他利。今将谈佛力，是故以利他言之。当知此意也。凡是生彼净土，及彼菩萨、人天所起诸行，皆缘阿弥陀如来本愿力故。何以言之？若非佛力，四十八愿便是徒设。今的取三愿，用证义意：
    愿言：“设我得佛，十方众生至心信乐欲生我国，乃至十念，若不得生者，不取正觉。唯除五逆、诽谤正法。”缘佛愿力故，十念念佛，便得往生。得往生故，即免三界轮转之事。无轮转故，所以得速。一证也。
    愿言：“设我得佛，国中人天，不住正定聚，必至灭度者，不取正觉。”缘佛愿力故，住正定聚。住正定聚故，必至灭度。无诸回复之难，所以得速。二证也。
    愿言：“设我得佛，他方佛土诸菩萨众来生我国，究竟必至一生补处。除其本愿自在所化，为众生故，被弘誓铠，积累德本，度脱一切。游诸佛国，修菩萨行，供养十方诸佛如来，开化恒沙无量众生，使立无上正真之道。超出常伦诸地之行，现前修习普贤之德。若不尔者，不取正觉。”缘佛愿力故，超出常伦诸地之行，现前修习普贤之德。以超出常伦诸地行故，所以得速。三证也。
    以斯而推他力为增上缘，得不然乎？当复引例，示自力、他力相。如人畏三途故，受持禁戒。受持禁戒故，能修禅定。以禅定故，修习神通。以神通故，能游四天下。如是等名为自力。又如劣夫，跨驴不上。从转轮王行，便乘虚空，游四天下，无所障碍。如是等名为他力。愚哉！后之学者，闻他力可乘，当生信心，勿自局分也。

    【《无量寿修多罗优婆提舍愿生偈》略解义竟。】
    经始称“如是”，彰信为能入；末言“奉行”，表服膺事已。《论》初归礼，明宗旨有由；终云“义竟”，示所诠理毕。述作人殊，于兹成例。

〖据《净土十要》附本、《大正藏》电子本校订〗


赞阿弥陀佛偈

昙鸾法师 作

南无阿弥陀佛（释名无量寿傍经奉赞亦曰安养①）

南无至心归命礼西方阿弥陀佛
现在西方去此界，十万亿刹安乐土，
佛世尊号阿弥陀，我愿往生归命礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
成佛已来历十劫，寿命方将无有量，
法身光轮遍法界，照世盲冥故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
智慧光明不可量，故佛又号无量光，
有量诸相蒙光晓，是故稽首真实明。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
解脱光轮无限齐，故佛又号无边光，
蒙光触者离有无，是故稽首平等觉。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
光云无碍如虚空，故佛又号无碍光，
一切有碍蒙光泽，是故顶礼难思议。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
清净光明无有对，故佛又号无对光，
遇斯光者业系除，是故稽首毕竟依。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
佛光照耀最第一，故佛又号光炎王，
三途黑闇蒙光启，是故顶礼大应供。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
道光明朗色超绝，故佛又号清净光，
一蒙光照罪垢除，皆得解脱故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
慈光遐被施安乐，故佛又号欢喜光，
光所至处得法喜，稽首顶礼大安慰。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
佛光能破无明闇，故佛又号智慧光，
一切诸佛三乘众，咸共叹誉故稽首。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
光明一切时普照，故佛又号不断光，
闻光力故心不断，皆得往生故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
其光除佛莫能测，故佛又号难思光，
十方诸佛叹往生，称其功德故稽首。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
神光离相不可名，故佛又号无称光，
因光成佛光赫然，诸佛所叹故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
光明照耀过日月，故佛号超日月光，
释迦佛叹尚不尽，故我稽首无等等。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
哀愍覆护我，令法种增长，
此世及后生，愿佛常摄受。
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界观世音菩萨
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界大势至菩萨
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界诸菩萨清净大海众
愿共诸众生，往生安乐国。

普为师僧、父母及善知识、法界众生断除三障，同得往生阿弥陀佛国，归命忏悔。

南无至心归命礼西方阿弥陀佛
阿弥陀佛初会众，声闻菩萨数无量，
神通巧妙不能算，是故稽首广大会。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐无量摩诃萨，咸当一生补佛处，
除其本愿大弘誓，普欲度脱诸众生，
斯等宝林功德聚，一心合掌头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐国土诸声闻，身②光一寻若流星，
菩萨光轮四千里，若秋满月映紫金，
集佛法藏为众生，故我顶礼大心海。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
又观世音大势至，于诸圣众最第一，
慈光照曜大千界，侍佛左右显神仪。
度诸有缘不暂息，如大海潮不失时，
如是大悲大势至，一心稽首头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
其有众生生安乐，悉具三十有二相，
智慧满足入深法，究畅道要无障碍，
随根利钝成就忍，二忍乃至不可计。
宿命五通常自在，至佛不更杂恶趣，
除生他方五浊世，示现同如大牟尼，
生安乐国成大利，是故至心头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐菩萨承佛神，于一食顷诣十方，
不可算数佛世界，恭敬供养诸如来。
华香伎乐从念现，宝盖幢幡随意出，
珍奇绝世无能名。散华供养殊异宝，
化成华盖光晃耀，香气普熏莫不周。
华盖小者四百里，乃有遍覆一佛界，
随其前后次化去。是诸菩萨佥欣悦，
于虚空中奏天乐，雅赞德颂扬佛慧。
听受经法供养已，未食之前腾虚还，
神力自在不可测，故我顶礼无上尊。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐佛国诸菩萨，夫可宣说随智慧，
于己万物亡我所，净若莲华不受尘。
往来进止若泛舟，利安为务舍适莫，
彼己犹空断二想，燃智慧炬照长夜。
三明六通皆已足，菩萨万行贯心眼，
如是功德无边量，是故至心头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐声闻菩萨众，人天智慧咸洞达，
身相庄严无殊异，但顺他方故列名。
颜容端正无可比，精微妙躯非人天，
虚无之身无极体，是故顶礼平等力。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
敢能得生安乐国，皆悉住于正定聚，
邪定不定其国无，诸佛咸赞故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
诸闻阿弥陀佛号，信心欢喜庆所闻，
乃暨一念至心者，回向愿生皆得往，
唯除五逆谤正法，故我顶礼愿往生。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
安乐菩萨声闻辈，于此世界无比方，
释迦无碍大辩才，设诸假令示少分。
最贱乞人并帝王，帝王复比金轮王，
如是展转至六天，次第相形皆如始。
以天色像喻于彼，千万亿倍非其类，
皆是法藏愿力为，稽首顶礼大心力。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
天人一切有所须，无不称欲应念至，
一宝二宝无量宝，随心化造受用具，
堂宇饮食悉如此，故我稽首无称佛。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
诸往生者悉具足，清净色身无可比，
神通功德及宫殿，服饰庄严如六天。
应器宝钵自然至，百味嘉肴倏已满，
见色闻香意为食，忽然饱足受适悦。
所味清净无所著，事已化去须复现，
晏安快乐次泥洹，是故至心头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
十方佛土菩萨众，及诸比丘生安乐，
无量无数不可计，已生今生当亦然。
皆曾供养无量佛，摄取百千坚固法，
如是大士悉往生，是故顶礼阿弥陀。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
若闻阿弥陀德号，欢喜赞仰心归依，
下至一念得大利，则为具足功德宝。
设满大千世界火，亦应直过闻佛名，
闻阿弥陀不复退，是故至心稽首礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
神力无极阿弥陀，十方无量佛所叹。
东方恒沙诸佛国，菩萨无数悉往觐，
亦复供养安乐国，菩萨声闻诸大众，
听受经法宣道化，自余九方亦如是。
释迦如来说偈颂，无量功德故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
诸来无量菩萨众，为植德本致虔恭，
或奏音乐歌叹佛，或颂佛慧照世间，
或以天华衣供养，或睹净土兴等愿。
如是圣众悉现前，蒙八梵声授佛记，
一切菩萨增愿行，故我顶礼婆伽婆。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
圣主世尊说法时，大众云集七宝堂，
听佛开示咸悟入，欢喜充遍皆得道。
于时四面起清风，击动宝树出妙响，
和韵清彻遏丝③竹，逾于金石无伦比。
天华缤纷逐香风，自然供养常不息，
诸天复持天华香，百千伎乐用致敬。
如是功德三宝聚，故我运想礼讲堂。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
妙土广大超数限，自然七宝所合成，
佛本愿力庄严起，稽首清净大摄受。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
世界光曜妙殊绝，适悦宴安无四时，
自利利他力圆满，归命方便巧庄严。
宝地澄静平如掌，无有山川陵谷阻，
若佛神力须则见，稽首不可思议尊。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
道树高四百万里，周围由旬有五千④，
枝叶布里二十万，自然众宝所合成，
月光摩尼海轮宝，众宝之王而庄严。
周匝垂间宝璎珞，百千万种色变异，
光焰照曜超千日，无极宝网覆其上，
一切庄严随应现，稽首顶礼道场树。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
微风吹树出法音，普流十方诸佛刹，
闻斯音得深法忍，至成佛道不遭苦，
神力广大不可量，稽首顶礼道场树。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
树香树色树音声，树触树味及树法，
六情遇者得法忍，故我顶礼道场树。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
蒙道场树对六根，乃至成佛根清彻，
音响柔顺无生忍，随力浅深咸得证。
此树威德所由来，皆是如来五种力，
神力本愿及满足，明了坚固究竟愿。
慈悲方便不可称，归命稽首真无量。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
从世帝王至六天，音乐转妙有八重，
展转胜前亿万倍，宝树音丽倍亦然。
复有自然妙伎乐，法音清和悦心神，
哀婉雅亮超十方，故我稽首清净乐。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
七宝树林周世界，光耀鲜明相映发，
华果枝叶更互为，稽首本愿功德聚。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
清风时时吹宝树，出五音声宫商和，
微妙雅曲自然成，故我顶礼清净熏。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
其土广大无崖际，众宝罗网遍覆上，
金缕珠玑奇异珍，不可名宝为校⑤饰。
周匝四面垂宝铃，调风吹动出妙法，
和雅德香常流布，闻者尘劳习不起，
此风触身受快乐，如比丘得灭尽定。
风吹散华满佛土，随色次第不杂乱，
华质柔软烈芬芳，足履其上下四指，
随举足时还如故，用讫地开没无遗，
随其时节华六返，不可议报故顶礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
众宝莲华盈世界，一一华百千亿叶，
其华光明色无量，朱紫红绿间五色，
炜烨焕烂曜日光，是故一心稽首礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
一一华中所出光，三十六百有千亿，
一一光中有佛身，多少亦如所出光。
佛身相好如金山，一一又放百千光，
普为十方说妙法，各安众生于佛道。
如是神力无边量，故我归命阿弥陀。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
楼阁殿堂非工造，七宝雕绮化所成，
明月珠珰交露幔，各有浴池形相称。
八功德水满池中，色味香洁如甘露，
黄金池者白银沙，七宝池沙互如此。
池岸香树垂布上，栴檀芬馥常流馨，
天华璀璨为映饰，水上熠耀若景云。
无漏依果难思议，是故稽首功德藏。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
菩萨声闻入宝池，随意浅深如所欲，
若须灌身自然注，欲令旋复水寻还，
调和冷暖无不称，神开体悦荡心垢。
清明澄洁若无形，宝沙映彻如不深，
澹淡回转相注灌，绰约⑥容豫和人神，
微波无量出妙响，随其所应闻法语。
或闻三宝之妙章，或闻寂静空无我，
或闻无量波罗蜜，力不共法诸通慧，
或闻无作无生忍，乃至甘露灌顶法。
随根性欲皆欢喜，顺三宝相真实义，
菩萨声闻所行道，于是一切悉具闻。
三途苦难名永闭，但有自然快乐音，
是故其国号安乐，头面顶礼无极尊。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
本师龙树摩诃萨，诞形像始理颓纲，
关闭邪扇开正辙，是阎浮提一切眼，
伏承尊悟欢喜地，归阿弥陀生安乐。⑦
譬如龙动云必随，阎浮提放百卉舒，
南无慈悲龙树尊，至心归命头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
我从无始循三界，为虚妄轮所回转，
一念一时所造业，足系大地滞三途，
唯愿慈光护念我，令我不失菩提心。
我赞佛慧功德音，愿闻十方诸有缘，
欲得往生安乐者，普皆如意无障碍，
所有功德若大少，回施一切共往生。
南无不可思议光，一心归命稽首礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
十方三世无量慧，同乘一如号正觉，
二智圆满道平等，摄化随缘故若干。
我归阿弥陀净土，即是归命诸佛国，
我以一心赞一佛，愿遍十方无碍人，
如是十方无量佛，咸各至心头面礼。
愿共诸众生，往生安乐国。

南无至心归命礼西方阿弥陀佛
哀愍覆护我，令法种增长，
此世及后生，愿佛常摄受。
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界观世音菩萨
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界大势至菩萨
愿共诸众生，往生安乐国。

南无至心归命礼西方极乐世界诸菩萨清净大海众
愿共诸众生，往生安乐国。

普为师僧、父母及善知识、法界众生断除三障，同得往生阿弥陀佛国，归命忏悔。

（赞一百九十五⑧，礼五十一拜⑨）

    【校注】
    ①释名无量寿傍经奉赞亦曰安养：此注文颇费解。案此偈又名《无量寿经奉赞》，迦才《净土论·昙鸾传》：“法师撰集《无量寿经奉赞》七言偈，百九十五行。”故注中“无量寿傍经奉赞”，应即指此偈为依《无量寿经》所作之礼赞文。又，汤用彤《汉魏两晋南北朝佛教史》以“傍”为“佛”字之误，解为“《无量寿佛经奉赞》”。
    ②身：《大正藏》电子本作“皆”，《卍续藏》本作“背”。今据《无量寿经》改。经云：“彼佛国中诸声闻众，身光一寻。”又可参证后出之《无量寿如来会》（唐译）：“彼佛刹中诸声闻众，皆有身光，能照一寻。”
    ③丝：原本作“糸”，为“丝”之异体字。
    ④千：原本作“十”，今据《无量寿经》改。经云：“其道场树高四百万里，其本周围五千由旬，枝叶四布二十万里，一切众宝自然合成。”又可参证后出之《无量寿如来会》（唐译）：“有菩提树高十六亿由旬，树叶垂布八亿由旬，树本隆起高五千由旬，周圆亦尔。”
    ⑤校：原本作“挍”，同“校”。
    ⑥绰约：原本作“婥约”，同“绰约”。
    ⑦此段赞颂龙树菩萨，原本分作两段，即以前三行、后两行各为一段。因各段均以致礼文字结束，而此前三行则无，显为误分，故今仍并为一段。又原本卷末云“礼五十一拜”，当指全偈顶礼阿弥陀佛共五十一拜。此处若作两段，则偈中礼文“南无至心归命礼西方阿弥陀佛”为五十二处，合并以后方合五十一之数。
    ⑧赞一百九十五：指除各段“南无至心归命礼西方阿弥陀佛”及“愿共诸众生，往生安乐国”等礼文外，全文七言偈每两句为一行，共一百九十五行，计二千七百三十字。
    ⑨礼五十一拜：应指偈中顶礼阿弥陀佛共五十一拜。

〖据《大正藏》电子本、《卍续藏》本、《无量寿经》校订〗


略论安乐净土义

魏西河石壁谷玄中寺沙门昙鸾撰

    问曰：安乐国于三界中何界所摄？
    答曰：如《释论》言：“如斯净土，非三界所摄。何以故？无欲故，非欲界；地居故，非色界；有形色故，非无色界。”经曰：阿弥陀佛本行菩萨道时，作比丘名曰法藏。于世自在王佛所，请问诸佛净土之行。时佛为说二百一十亿诸佛刹土，天人善恶，国土精粗，悉现与之。于时法藏菩萨，即于佛前，发弘誓大愿，取诸佛土。于无量阿僧祇劫，如所发愿，行诸波罗蜜。万善圆满，成无上道。别业所得，非三界也。

    问曰：安乐国有几种庄严，名为净土？
    答曰：若依经据义，法藏菩萨四十八愿，即是其事。寻《赞》可知①，不复重叙。若依《无量寿论》，以二种清净，摄二十九种庄严成就。二种清净者，一器世间清净②、二是众生世间清净。
    器世间清净，有十七种庄严成就：一者国土相胜过三界道。二者其国广大，量如虚空，无有齐限。三者从菩萨正道大慈悲出世善根所起。四者清净光明圆满庄严。五者备具第一珍宝性，出奇妙宝物。六者洁净光明，常照世间。七者其国宝物柔软，触者适悦，生于胜乐。八者千万宝华，庄严池沼；宝殿、宝楼阁、种种宝树，杂色光明，影纳世界；无量宝网覆虚空，四面悬铃，常吐法音。九者于虚空中自然常雨天华、天衣、天香，庄严普熏。十者佛慧光明，照除痴闇。十一者梵声开悟，远闻十方。十二者阿弥陀佛无上法王善力住持。十三者从如来净华所化生。十四者爱乐佛法味，禅三昧为食。十五者永离身心诸苦，受乐无间。十六者乃至不闻二乘、女人、根缺之名。十七者众生有所欲乐，随心称意，无不满足。如是等十七种，是名器世间清净。
    众生世间清净，有十二种庄严成就：一者无量大珍宝王微妙华台以为佛座。二者无量相好、无量光明庄严佛身。三者佛无量辩才，应机说法，具足清白，令人乐闻；闻者必悟解，言不虚说。四者佛真如智慧犹如虚空，照了诸法总相、别相，心无分别。五者天人不动众广大庄严，譬如须弥山，映显四大海，法王相具足。六者成就无上果，尚无能及，况复过者。七者为天人丈夫调御师，大众恭敬围绕，如狮子王狮子围绕。八者佛本愿力庄严住持诸功德，遇者无空过，能令速满足一切功德海；未证净心菩萨毕竟得证平等法身，与净心菩萨、与上地菩萨毕竟同得寂灭平等。九者安乐国诸菩萨众，身不动摇而遍至十方，种种应化，如实修行，常作佛事。十者如是菩萨应化身，一切时不前不后，一心一念放大光明，悉能遍至十方世界，教化众生，种种方便修行所作，灭除一切众生苦恼。十一者是等菩萨于一切世界，无余照诸佛大会，无余广大无量供养、恭敬、赞叹诸佛如来功德。十二者是诸菩萨于十方一切世界无三宝处，住持庄严佛、法、僧宝功德大海，遍示令解，如实修行。如是等法王八种庄严功德成就，如是菩萨四种庄严功德成就，是名众生世间清净。
    安乐国土具如是等二十九种庄严功德成就，故名净土。

    问曰：生安乐土者，凡有几辈？有几因缘？
    答曰：《无量寿经》中，唯有三辈，上、中、下。《无量寿观经》中，一品分为上、中、下，三三而九，合为九品。今依傍《无量寿经》为赞。且据此经作三品论之。
    上辈生者，有五因缘：一者舍家离欲而作沙门；二者发无上菩提心；三者一向专念无量寿佛；四者修诸功德；五者愿生安乐国。具此因缘，临命终时，无量寿佛与诸大众现其人前，即便随佛往生安乐。于七宝华中，自然化生，住不退转。智慧勇猛，神通自在。
    中辈生者，有七因缘：一者发无上菩提心；二者一向专念无量寿佛；三者多少修善，奉持斋戒；四者起立塔像；五者饭食沙门；六者悬缯燃灯，散华烧香；七者以此回向，愿生安乐。临命终时，无量寿佛化现其身，光明、相好具如真佛，与诸大众现其人前。即随化佛往生安乐，住不退转。功德智慧，次如上辈。
    下辈生者，有三因缘：一者假使不能作诸功德，当发无上菩提心；二者一向专意，乃至十念念无量寿佛；三者以至诚心愿生安乐。临命终时，梦见无量寿佛，亦得往生。功德智慧，次如中辈。
    又有一种往生安乐，不入三辈中。谓以疑惑心修诸功德，愿生安乐。不了佛智、不思议智、不可称智、大乘广智、无等无伦最上胜智。于此诸智，疑惑不信。然犹信罪福，修习善本。生安乐国七宝宫殿，或百由旬，或五百由旬。各于其中受诸快乐，如忉利天，亦皆自然。于五百岁中，常不见佛，不闻经法，不见菩萨、声闻圣众。安乐国土谓之“边地”，亦曰“胎生”。边地者，言其五百岁中不见闻三宝，义同边地之难；或亦于安乐国土最在其边。胎生者，譬如胎生人，初生之时，人法未成。“边”言其难，“胎”言其闇。此二名皆借此况彼耳，非是“八难”中边地，亦非胞胎中胎生。何以知之？安乐国土一向化生故，故知非实胎生。五百年后，还得见闻三宝故，故知非“八难”中边地也。

    问曰：彼胎生者，处七宝宫殿中，受快乐否？复何所忆念？
    答曰：经喻云：譬如转轮王子得罪于王，内于后宫，系以金锁，一切供具无所乏少，犹如王。王子于时虽有好妙种种自娱乐具，心不受乐，但念设诸方便，求免悕出。彼胎生者，亦复如是。虽处七宝宫殿，有好色香味触，不以为乐。但不见三宝，不得供养修诸善本，以之为苦。识其本罪，深自责悔，求离彼处，即得如意，还同三辈生者。当是五百年末，方识罪悔耳。

    问曰：以疑惑心往生安乐，名曰胎生者，云何起疑？
    答曰：经中但云“疑惑不信”，不出所以疑意。寻“不了”五句，敢以对治言之。“不了佛智”者，谓不能信了佛一切种智。不了故，故起疑。此一句总辨所疑。下四句一一对治所疑。疑有四意：

    一者，疑但忆念阿弥陀佛，不必得往生安乐。何以故？经曰：“业道如秤，重者先牵。”云何一生，或百年、或十年、或一月，无恶不造。但以十念相续，便得往生，即入正定聚，毕竟不退，与三途诸苦永隔乎？若尔，先牵之义，何以可信？又旷劫已来，具造诸行有漏之法，系属三界。云何不断三界结惑，直以少时念阿弥陀佛，便出三界乎？系业之义，复欲云何？
    对治此疑，故言不思议智。不思议智者，谓佛智力能以少作多，以多作少；以近为远，以远为近；以轻为重，以重为轻；以长为短，以短为长。如是等佛智无量无边，不可思议。譬如百夫百年聚薪，积高千仞。豆许火焚，半日便尽。岂可得言百年之薪积，半日不尽乎？又如躄者寄载他船，因风帆势，一日至千里。岂可得言躄者云何一日至千里乎？又如下贱贫人，获一瑞物，而以贡主。主庆所得，加诸重赏。斯须之顷，富贵盈溢。岂可得言以颇有数十年仕，备尽辛勤，上下尚不达归者，言彼富贵无此事乎？又如劣夫，以己身力，掷驴不上。从转轮王行，便乘虚空，飞腾自然。复可以掷驴之劣夫，言必不能乘空耶？又如十围之索，千夫不制。童子挥剑，瞬顷两分。岂可得言一小儿力不能断索乎？又如鸩鸟入水，鱼蚌斯毙。犀角触泥，死者咸起。岂可得言性命一断，无可生乎？又如黄鹄呼子安，子安还活。岂可得言坟下千岁灵，决无可苏乎？一切万法，皆有自力、他力，自摄、他摄。千开万闭，无量无边。安得以有碍之识，疑彼无碍之法乎？又五不思议中，佛法最不可思议。而以百年之恶为重，疑十念念佛为轻，不得往生安乐入正定聚者，是事不然。

    二者，疑佛智于人不为悬绝。何以故？夫一切名字从相待生，觉智从不觉生。如人迷方，从记方生。若使迷绝不迷，迷卒不解。迷若可解，必迷者解，亦可云解者迷。迷解、解迷，犹手反覆耳。乃可明、昧为异，亦安得超然哉？起此疑故，于佛智慧生疑不信。
    对治此疑，故言不可称智。不可称智者，言佛智绝称谓，非相形待。何以言之？法若是有，必应有知有之智。法若是无，亦应有知无之智。诸法离于有无，故佛冥诸法，则智绝相待。汝引解迷为喻，犹是一迷耳，不成迷解。亦如梦中与他解梦，虽云解梦，非是不梦。以知取佛，不曰知佛；以不知取佛，非知佛；以非知非不知取佛，亦非知佛；以非非知非非不知取佛，亦非知佛。佛智离此四句。缘之者心行灭，指之者言语断。以是义故，《释论》云：“若人见般若，是则为被缚；若不见般若，是亦为被缚。若人见般若，是则为解脱；若不见般若，是亦为解脱。”此偈中说，不离四句者为缚，离四句者为解脱。汝疑佛智与人不悬绝者，是事不然。

    三者，疑佛不能实度一切众生。何以故？过去世有无量阿僧祇恒沙诸佛，现在十方世界亦有无量无边阿僧祇恒沙诸佛。若使佛实能度一切众生，则应久无三界。第二佛则不应复为众生发菩提心，具修净土摄受众生。而实有第二佛摄受众生，乃至实有三世十方无量诸佛摄受众生，故知佛实不能度一切众生。起此疑故，于阿弥陀佛作有量想。
    对治此疑，故言大乘广智。大乘广智者，言无法不知，无烦恼不断，无善不备，无众生不度。所以有三世十方者，有五义：一者，若使无第二佛，乃至无阿僧祇恒沙诸佛者，佛便不能度一切众生。以实能度一切众生故，则有十方无量诸佛。无量诸佛即是前佛所度众生。二者，若一佛度一切众生尽者，后亦不应复有佛。何以故？无觉他义故。复依何义说有三世佛乎？依觉他义故，说佛佛皆度一切众生。三者，后佛能度，犹是前佛之能。何以故？由前佛有后佛故。譬如帝王之中，得相绍袭，后王即是前王之能故。四者，佛力虽能度一切众生，要须有因缘。若众生与前佛无因缘，复须后佛。如是无缘众生，动经百千万佛，不闻不见。非佛力劣也。譬如日月周四天下，破诸闇冥，而盲者不见，非日不明也。雷震裂耳，而聋者不闻，非声不厉也。觉诸缘理，号之曰佛。若情强违缘理，非正觉也。是故众生无量，佛亦无量。征佛莫问有缘无缘，何不尽度一切众生者，非理言也。五者，众生若尽，世间即堕有边。以是义故，即有无量佛度一切众生。
    问曰：若众生不可尽，世间复须堕无边。无边故，佛则不能实度一切众生。
    答曰：世间非有边非无边，亦绝四句。佛令众生离此四句，名之为度。其实非度非不度，非尽非不尽。譬如梦渡大河，值涛波诸难，其人畏怖，叫声彻外。外人唤觉，坦然无忧。但为渡梦，不为渡河。
    问曰：言度与不度，皆堕边见。何以但说度一切众生为大乘广智，不说不度众生为大乘广智？
    答曰：众生莫不厌苦求乐，畏缚求解。闻度则归向。闻不度，不知所以不度，便谓佛非大慈悲，则不归向。故长寝久梦，无由可息。为是人故，多说度，不说不度。复次《诸法无行经》亦言：“佛不得佛道，亦不度众生。凡夫强分别，作佛度众生。”言度众生，是对治悉檀。言不度众生，是第一义悉檀。二言各有所以，不相违背。
    问曰：如梦得息，岂不是度耶？若一切众生所梦皆息，世间岂不尽？
    答曰：说梦为世间，若梦息则无梦者。若无梦者，亦不说度者。如是知世间即是出世间。虽度无量众生，则不堕颠倒。

    四者，疑佛不得一切种智。何以故？若能遍知诸法，诸法堕有边故。若不能遍知，则非一切种智故。
    对治此疑，故言无等无伦最上胜智。无等无伦最上胜智者，凡夫智虚妄，佛智如实，虚实悬殊，理无得等，故言“无等”。声闻、辟支佛欲有所知，入定方知，出定不知，又知亦有限。佛得如实三昧，常在深定而遍知，照万法二与无二。深法非伦，故言“无伦”。八地已上菩萨，虽得报生三昧，用无出入。而习气微熏，三昧不极明净。形待佛智，犹为有上。佛智断具足，如法而照。法无量故，照亦无量。譬如函大盖亦大。故言“最上”。此三句亦可展转相成，以佛智无与等者故，所以无伦，以无伦故最上胜；亦可最上胜故无等，无等故无伦。但言无等便足，复何以须下二句者。如须陀洹智不与阿罗汉等，而是其类。初地至十地亦如是。智虽不等，非不其伦。何以故？非最上故。汝以知有边为难，疑佛非一切智者，是事不然。

    问曰：下辈生中云：“十念相续，便得往生。”云何名为十念相续？
    答曰：譬如有人，空旷迥处，值遇怨贼，拔刀奋勇，直来欲杀。其人劲走，视渡一河。若得渡河，首领可全。尔时但念渡河方便：“我至河岸，为着衣渡，为脱衣渡？若着衣纳，恐不得过。若脱衣纳，恐无得暇。”但有此念，更无他缘。唯念何当渡河，即是一念。如是不杂心，名为十念相续。行者亦尔，念阿弥陀佛，如彼念渡，经于十念。若念佛名字，若念佛相好，若念佛光明，若念佛神力，若念佛功德，若念佛智慧，若念佛本愿。无他心间杂，心心相次，乃至十念，名为十念相续。
    一往言十念相续，似若不难。然凡夫心犹野马，识剧猿猴，驰骋六尘，不暂停息。宜至信心，预自克念，使积习成性，善根坚固也。如佛告频婆娑罗王：“人积善行，死无恶念。如树西倾，倒必随西。”若使风刀一至，百苦凑身。若前习不在怀，念何可办？又宜同志五三，共结言要。垂命终时，迭相开晓。为称阿弥陀佛名号，愿生安乐。声声相次，使成十念也。譬如蜡印印泥，印坏文成。此命断时，即是生安乐时。一入正定聚，更何所忧也！

    【校注】
    ①寻《赞》可知：《净土十要》附本作“寻读可知”，今从《大正藏》本。所言“赞”，下文亦言“今依傍《无量寿经》为赞”，均指《赞阿弥陀佛偈》（一名《无量寿经奉赞》），为昙鸾法师依照魏译《无量寿经》经文，所作之礼赞西方净土依正庄严的偈颂。由此亦知本文撰于《赞阿弥陀佛偈》之后。
    ②器世间清净：《净土十要》附本略作“器世间”，据《大正藏》本补。

〖据《净土十要》附本、《大正藏》电子本校订〗


经、赞章句对照

《无量寿经》、《赞阿弥陀佛偈》
章句对照

《无量寿经》经文（魏译） 《赞阿弥陀佛偈》
    阿难白佛：“法藏菩萨，为已成佛而取灭度，为未成佛，为今现在？”
    佛告阿难：“法藏菩萨，今已成佛，现在西方，去此十万亿刹。其佛世界，名曰安乐。”
    阿难又问：“其佛成道已来，为经几时？”
    佛言：“成佛已来，凡历十劫。”

    佛告阿难：“无量寿佛，威神光明，最尊第一。诸佛光明，所不能及。或照百佛世界，或千佛世界，取要言之，乃照东方恒沙佛刹。南西北方，四维上下，亦复如是。或有佛光照于七尺，或一由旬，二、三、四、五由旬，如是转倍，乃至照一佛刹。是故无量寿佛，号无量光佛、无边光佛、无碍光佛、无对光佛、炎王光佛、清净光佛、欢喜光佛、智慧光佛、不断光佛、难思光佛、无称光佛、超日月光佛。其有众生遇斯光者，三垢消灭，身意柔软，欢喜踊跃，善心生焉。若在三途极苦之处，见此光明，皆得休息，无复苦恼。寿终之后，皆蒙解脱。无量寿佛，光明显赫，照曜十方。诸佛国土，莫不闻焉。不但我今称其光明，一切诸佛、声闻、缘觉、诸菩萨众，咸共叹誉，亦复如是。若有众生，闻其光明威神功德，日夜称说，至心不断，随意所愿，得生其国。为诸菩萨、声闻之众，所共叹誉，称其功德。至其最后得佛道时，普为十方诸佛菩萨叹其光明，亦如今也。”
    佛言：“我说无量寿佛光明威神，巍巍殊妙，昼夜一劫，尚未能尽。” 		现在西方去此界，十万亿刹安乐土，
佛世尊号阿弥陀，我愿往生归命礼。

成佛已来历十劫，寿命方将无有量，
法身光轮遍法界，照世盲冥故顶礼。

智慧光明不可量，故佛又号无量光，
有量诸相蒙光晓，是故稽首真实明。

解脱光轮无限齐，故佛又号无边光，
蒙光触者离有无，是故稽首平等觉。

光云无碍如虚空，故佛又号无碍光，
一切有碍蒙光泽，是故顶礼难思议。

清净光明无有对，故佛又号无对光，
遇斯光者业系除，是故稽首毕竟依。

佛光照耀最第一，故佛又号光炎王，
三途黑闇蒙光启，是故顶礼大应供。

道光明朗色超绝，故佛又号清净光，
一蒙光照罪垢除，皆得解脱故顶礼。

慈光遐被施安乐，故佛又号欢喜光，
光所至处得法喜，稽首顶礼大安慰。

佛光能破无明闇，故佛又号智慧光，
一切诸佛三乘众，咸共叹誉故稽首。

光明一切时普照，故佛又号不断光，
闻光力故心不断，皆得往生故顶礼。

其光除佛莫能测，故佛又号难思光，
十方诸佛叹往生，称其功德故稽首。

神光离相不可名，故佛又号无称光，
因光成佛光赫然，诸佛所叹故顶礼。

光明照耀过日月，故佛号超日月光，
释迦佛叹尚不尽，故我稽首无等等。
    佛语阿难：“彼佛初会声闻众数不可称计，菩萨亦然。如大目犍连，百千万亿无量无数，于阿僧祇那由他劫，乃至灭度，悉共计校，不能究了多少之数。譬如大海，深广无量。假使有人析其一毛，以为百分，以一分毛，沾取一滴。于意云何，其所滴者，于彼大海，何所为多？”
    阿难白佛：“彼所滴水，比于大海多少之量，非巧历算数、言辞譬类所能知也。”
    佛语阿难：“如目连等，于百千万亿那由他劫，计彼初会声闻、菩萨。所知数者，犹如一滴，其所不知，如大海水。” 		阿弥陀佛初会众，声闻菩萨数无量，
神通巧妙不能算，是故稽首广大会。
    佛告阿难：“彼国菩萨，皆当究竟一生补处。除其本愿为众生故，以弘誓功德，而自庄严，普欲度脱一切众生。” 安乐无量摩诃萨，咸当一生补佛处，
除其本愿大弘誓，普欲度脱诸众生，
斯等宝林功德聚，一心合掌头面礼。
    “阿难，彼佛国中诸声闻众，身光一寻。菩萨光明，照百由旬。” 安乐国土诸声闻，身光一寻若流星，
菩萨光轮四千里，若秋满月映紫金，
集佛法藏为众生，故我顶礼大心海。
    “有二菩萨，最尊第一，威神光明，普照三千大千世界。”
    阿难白佛：“彼二菩萨，其号云何？”
    佛言：“一名观世音，二名大势至。此二菩萨，于此国土，修菩萨行，命终转化，生彼佛国。” 		又观世音大势至，于诸圣众最第一，
慈光照曜大千界，侍佛左右显神仪。
度诸有缘不暂息，如大海潮不失时，
如是大悲大势至，一心稽首头面礼。
    “阿难，其有众生，生彼国者，皆悉具足三十二相，智慧成满，深入诸法，究畅要妙，神通无碍，诸根明利。其钝根者，成就二忍。其利根者，得不可计无生法忍。又彼菩萨，乃至成佛，不受恶趣。神通自在，常识宿命。除生他方五浊恶世，示现同彼，如我国也。” 其有众生生安乐，悉具三十有二相，
智慧满足入深法，究畅道要无障碍，
随根利钝成就忍，二忍乃至不可计。
宿命五通常自在，至佛不更杂恶趣，
除生他方五浊世，示现同如大牟尼，
生安乐国成大利，是故至心头面礼。
    佛语阿难：“彼国菩萨，承佛威神，一食之顷，往诣十方无量世界，恭敬供养诸佛世尊。随心所念华香、伎乐、衣盖、幢幡、无数无量供养之具，自然化生，应念即至。珍妙殊特，非世所有。辄以奉散诸佛，及诸菩萨、声闻之众。在虚空中，化成华盖，光色昱烁，香气普熏。其华周圆四百里者，如是转倍，乃覆三千大千世界。随其前后，以次化没。其诸菩萨，佥然欣悦。于虚空中，共奏天乐，以微妙音，歌叹佛德。听受经法，欢喜无量。供养佛已，未食之前，忽然轻举，还其本国。” 安乐菩萨承佛神，于一食顷诣十方，
不可算数佛世界，恭敬供养诸如来。
华香伎乐从念现，宝盖幢幡随意出，
珍奇绝世无能名。散华供养殊异宝，
化成华盖光晃耀，香气普熏莫不周。
华盖小者四百里，乃有遍覆一佛界，
随其前后次化去。是诸菩萨佥欣悦，
于虚空中奏天乐，雅赞德颂扬佛慧。
听受经法供养已，未食之前腾虚还，
神力自在不可测，故我顶礼无上尊。
    佛语阿难：“生彼佛国诸菩萨等，所可讲说，常宣正法。随顺智慧，无违无失。于其国土所有万物，无我所心，无染著心。去来进止，情无所系。随意自在，无所适莫。无彼无我，无竞无讼。于诸众生，得大慈悲饶益之心。柔润调伏，无忿恨心。离盖清净，无厌怠心。等心，胜心，深心，定心，爱法、乐法、喜法之心。灭诸烦恼，离恶趣心。究竟一切菩萨所行，具足成就无量功德。得深禅定，诸通明慧。游志七觉，修心佛法。肉眼清彻，靡不分了。天眼通达，无量无限。法眼观察，究竟诸道。慧眼见真，能度彼岸。佛眼具足，觉了法性。” 安乐佛国诸菩萨，夫可宣说随智慧，
于己万物亡我所，净若莲华不受尘。
往来进止若泛舟，利安为务舍适莫，
彼己犹空断二想，燃智慧炬照长夜。
三明六通皆已足，菩萨万行贯心眼，
如是功德无边量，是故至心头面礼。
    “其诸声闻、菩萨、天人，智慧高明，神通洞达，咸同一类，形无异状。但因顺余方，故有天人之名。颜貌端正，超世希有。容色微妙，非天非人。皆受自然虚无之身，无极之体。” 安乐声闻菩萨众，人天智慧咸洞达，
身相庄严无殊异，但顺他方故列名。
颜容端正无可比，精微妙躯非人天，
虚无之身无极体，是故顶礼平等力。
    佛告阿难：“其有众生，生彼国者，皆悉住于正定之聚。所以者何？彼佛国中，无诸邪聚，及不定聚。十方恒沙诸佛如来，皆共赞叹无量寿佛威神功德不可思议。” 敢能得生安乐国，皆悉住于正定聚，
邪定不定其国无，诸佛咸赞故顶礼。
    “诸有众生，闻其名号，信心欢喜，乃至一念，至心回向，愿生彼国，即得往生，住不退转。唯除五逆、诽谤正法。” 诸闻阿弥陀佛号，信心欢喜庆所闻，
乃暨一念至心者，回向愿生皆得往，
唯除五逆谤正法，故我顶礼愿往生。
    佛告阿难：“譬如世间贫穷乞人，在帝王边，形貌容状，宁可类乎？”
    阿难白佛：“假令此人在帝王边，羸陋丑恶，无以为喻，百千万亿不可计倍。……”
    佛告阿难：“汝言是也。计如帝王，虽人中尊贵，形色端正。比之转轮圣王，甚为鄙陋，犹彼乞人在帝王边也。转轮圣王，威相殊妙，天下第一。比之忉利天王，又复丑恶，不得相喻万亿倍也。假令天帝，比第六天王，百千亿倍不相类也。设第六天王，比无量寿佛国菩萨、声闻，光颜容色，不相及逮，百千万亿不可计倍。” 		安乐菩萨声闻辈，于此世界无比方，
释迦无碍大辩才，设诸假令示少分。
最贱乞人并帝王，帝王复比金轮王，
如是展转至六天，次第相形皆如始。
以天色像喻于彼，千万亿倍非其类，
皆是法藏愿力为，稽首顶礼大心力。
    佛告阿难：“无量寿国，其诸天人，衣服、饮食、华香、璎珞、缯盖、幢幡、微妙音声、所居舍宅、宫殿、楼阁，称其形色，高下大小。或一宝、二宝，乃至无量众宝，随意所欲，应念即至。” 天人一切有所须，无不称欲应念至，
一宝二宝无量宝，随心化造受用具，
堂宇饮食悉如此，故我稽首无称佛。
    “阿难，彼佛国土，诸往生者，具足如是清净色身、诸妙音声、神通功德。所处宫殿、衣服、饮食、众妙华香、庄严之具，犹第六天自然之物。若欲食时，七宝钵器，自然在前。金、银、琉璃、砗磲、玛瑙、珊瑚、琥珀、明月、真珠，如是诸钵，随意而至。百味饮食，自然盈满。虽有此食，实无食者。但见色闻香，意以为食，自然饱足。身心柔软，无所味著。事已化去，时至复现。彼佛国土，清净安隐，微妙快乐，次于无为泥洹之道。” 诸往生者悉具足，清净色身无可比，
神通功德及宫殿，服饰庄严如六天。
应器宝钵自然至，百味嘉肴倏已满，
见色闻香意为食，忽然饱足受适悦。
所味清净无所著，事已化去须复现，
晏安快乐次泥洹，是故至心头面礼。
    佛告弥勒：“于此世界，六十七亿不退菩萨，往生彼国。一一菩萨，已曾供养无数诸佛，次如弥勒者也。诸小行菩萨，及修习少功德者，不可称计，皆当往生。”
    佛告弥勒：“不但我刹诸菩萨等，往生彼国。他方佛土，亦复如是。其第一佛，名曰远照，彼有百八十亿菩萨，皆当往生。……其第十二佛，名曰无上华，彼有无数不可称计诸菩萨众，皆不退转，智慧勇猛，已曾供养无量诸佛。于七日中，即能摄取百千亿劫大士所修坚固之法。斯等菩萨，皆当往生。其第十三佛，名曰无畏，彼有七百九十亿大菩萨众，诸小菩萨及比丘等，不可称计，皆当往生。”
    佛语弥勒：“不但此十四佛国中诸菩萨等，当往生也。十方世界无量佛国，其往生者，亦复如是，甚多无数。我但说十方诸佛名号，及菩萨、比丘生彼国者，昼夜一劫，尚未能尽。我今为汝略说之耳。” 		十方佛土菩萨众，及诸比丘生安乐，
无量无数不可计，已生今生当亦然。
皆曾供养无量佛，摄取百千坚固法，
如是大士悉往生，是故顶礼阿弥陀。
    佛告弥勒：“其有得闻彼佛名号，欢喜踊跃，乃至一念，当知此人为得大利，则是具足无上功德。是故弥勒，设有大火，充满三千大千世界，要当过此，闻是经法，欢喜信乐，受持读诵，如说修行。所以者何？多有菩萨，欲闻此经，而不能得。若有众生，闻此经者，于无上道，终不退转。是故应当专心信受，持诵说行。” 若闻阿弥陀德号，欢喜赞仰心归依，
下至一念得大利，则为具足功德宝。
设满大千世界火，亦应直过闻佛名，
闻阿弥陀不复退，是故至心稽首礼。

    佛告阿难：“无量寿佛，威神无极。十方世界无量无边不可思议诸佛如来，莫不称叹。于彼东方恒河沙佛国，无量无数诸菩萨众，皆悉往诣无量寿佛所，恭敬供养，及诸菩萨、声闻之众，听受经法，宣布道化。南西北方，四维上下，亦复如是。”
    尔时世尊而说颂曰：

“东方诸佛国，其数如恒沙，
彼土菩萨众，往觐无量觉。
南西北四维，上下亦复然，
彼土菩萨众，往觐无量觉。
一切诸菩萨，各赍天妙华，
宝香无价衣，供养无量觉。
咸然奏天乐，畅发和雅音，
歌叹最胜尊，供养无量觉。
究达神通慧，游入深法门，
具足功德藏，妙智无等伦。
慧日朗世间，消除生死云，
恭敬绕三匝，稽首无上尊。
见彼严净土，微妙难思议，
因发无量心，愿我国亦然。
应时无量尊，动容发欣笑，
口出无数光，遍照十方国。
回光围绕身，三匝从顶入，
一切天人众，踊跃皆欢喜。
大士观世音，整服稽首问，
白佛何缘笑，唯然愿说意。
梵声犹雷震，八音畅妙响：
‘当授菩萨记，今说仁谛听！
十方来正士，吾悉知彼愿，
志求严净土，受决当作佛。
觉了一切法，犹如梦幻响，
满足诸妙愿，必成如是刹。
知法如电影，究竟菩萨道，
具诸功德本，受决当作佛。
通达诸法性，一切空无我，
专求净佛土，必成如是刹。’
诸佛告菩萨，令觐安养佛，
闻法乐受行，疾得清净处。
至彼严净土，便速得神通，
必于无量尊，受记成等觉。
其佛本愿力，闻名欲往生，
皆悉到彼国，自致不退转。
菩萨兴至愿，愿己国无异，
普念度一切，名显满十方。
奉事亿如来，飞化遍诸刹，
恭敬欢喜去，还到安养国。”

神力无极阿弥陀，十方无量佛所叹。
东方恒沙诸佛国，菩萨无数悉往觐，
亦复供养安乐国，菩萨声闻诸大众，
听受经法宣道化，自余九方亦如是。
释迦如来说偈颂，无量功德故顶礼。

诸来无量菩萨众，为植德本致虔恭，
或奏音乐歌叹佛，或颂佛慧照世间，
或以天华衣供养，或睹净土兴等愿。
如是圣众悉现前，蒙八梵声授佛记，
一切菩萨增愿行，故我顶礼婆伽婆。
    佛语阿难：“无量寿佛，为诸声闻、菩萨、天人，颁宣法时，都悉集会七宝讲堂，广宣道教，演畅妙法，莫不欢喜，心解得道。即时四方自然风起，吹七宝树，出五音声。无量妙华，随风四散，自然供养，如是不绝。一切诸天，皆赍天上百千华香、万种伎乐，供养其佛，及诸菩萨、声闻之众。普散华香，奏诸音乐。前后来往，更相开避。当斯之时，熙怡快乐，不可胜言。” 圣主世尊说法时，大众云集七宝堂，
听佛开示咸悟入，欢喜充遍皆得道。
于时四面起清风，击动宝树出妙响，
和韵清彻遏丝竹，逾于金石无伦比。
天华缤纷逐香风，自然供养常不息，
诸天复持天华香，百千伎乐用致敬。
如是功德三宝聚，故我运想礼讲堂。
    “其佛国土，自然七宝，金、银、琉璃、珊瑚、琥珀、砗磲、玛瑙合成为地。恢廓旷荡，不可限极。悉相杂厕，转相间入。光赫煜烁，微妙奇丽，清净庄严。超逾十方一切世界众宝中精，其宝犹如第六天宝。又其国土，无须弥山，及金刚围，一切诸山。亦无大海、小海、溪、渠、井、谷。佛神力故，欲见则见。亦无地狱、饿鬼、畜生诸难之趣。亦无四时春秋冬夏，不寒不热，常和调适。” 妙土广大超数限，自然七宝所合成，
佛本愿力庄严起，稽首清净大摄受。

世界光曜妙殊绝，适悦宴安无四时，
自利利他力圆满，归命方便巧庄严。

宝地澄静平如掌，无有山川陵谷阻，
若佛神力须则见，稽首不可思议尊。
    “又无量寿佛，其道场树，高四百万里，其本周围五千由旬，枝叶四布二十万里，一切众宝自然合成。以月光摩尼、持海轮宝，众宝之王，而庄严之。周匝条间，垂宝璎珞，百千万色，种种异变，无量光炎，照曜无极。珍妙宝网，罗覆其上。一切庄严，随应而现。微风徐动，吹诸宝树，演出无量妙法音声。其声流布，遍诸佛国。闻其音者，得深法忍，住不退转，至成佛道，耳根清彻，不遭苦患。目睹其色，鼻知其香，口尝其味，身触其光，心以法缘，皆得甚深法忍，住不退转，至成佛道，六根清彻，无诸恼患。阿难，若彼国土天人，见此树者，得三法忍：一者音响忍，二者柔顺忍，三者无生法忍。此皆无量寿佛威神力故，本愿力故，满足愿故，明了愿故，坚固愿故，究竟愿故。” 道树高四百万里，周围由旬有五千，
枝叶布里二十万，自然众宝所合成，
月光摩尼海轮宝，众宝之王而庄严。
周匝垂间宝璎珞，百千万种色变异，
光焰照曜超千日，无极宝网覆其上，
一切庄严随应现，稽首顶礼道场树。

微风吹树出法音，普流十方诸佛刹，
闻斯音得深法忍，至成佛道不遭苦，
神力广大不可量，稽首顶礼道场树。

树香树色树音声，树触树味及树法，
六情遇者得法忍，故我顶礼道场树。

蒙道场树对六根，乃至成佛根清彻，
音响柔顺无生忍，随力浅深咸得证。
此树威德所由来，皆是如来五种力，
神力本愿及满足，明了坚固究竟愿。
慈悲方便不可称，归命稽首真无量。
    佛告阿难：“世间帝王，有百千音乐，自转轮圣王，乃至第六天上，伎乐音声，展转相胜千亿万倍。第六天上万种乐音，不如无量寿国诸七宝树一种音声千亿倍也。亦有自然万种伎乐。又其乐声，无非法音。清畅哀亮，微妙和雅，十方世界音声之中，最为第一。” 从世帝王至六天，音乐转妙有八重，
展转胜前亿万倍，宝树音丽倍亦然。
复有自然妙伎乐，法音清和悦心神，
哀婉雅亮超十方，故我稽首清净乐。
    “又其国土，七宝诸树，周满世界。金树、银树、琉璃树、玻璃树、珊瑚树、玛瑙树、砗磲之树，或有二宝、三宝，乃至七宝，转共合成。或有金树，银叶、华、果。或有银树，金叶、华、果。或琉璃树，玻璃为叶，华、果亦然。或水精树，琉璃为叶，华、果亦然。……或有宝树，紫金为本，白银为茎，琉璃为枝，水精为条，珊瑚为叶，玛瑙为华，砗磲为实。或有宝树，白银为本，琉璃为茎，水精为枝，珊瑚为条，玛瑙为叶，砗磲为华，紫金为实。……行行相值，茎茎相望，枝枝相准，叶叶相向，华华相顺，实实相当。荣色光曜，不可胜视。清风时发，出五音声，微妙宫商，自然相和。” 七宝树林周世界，光耀鲜明相映发，
华果枝叶更互为，稽首本愿功德聚。

清风时时吹宝树，出五音声宫商和，
微妙雅曲自然成，故我顶礼清净熏。
    “无量宝网，弥覆佛土。皆以金缕、真珠、百千杂宝、奇妙珍异，庄严校饰。周匝四面，垂以宝铃。光色晃曜，尽极严丽。自然德风，徐起微动。其风调和，不寒不暑，温凉柔软，不迟不疾。吹诸罗网，及众宝树，演发无量微妙法音，流布万种温雅德香。其有闻者，尘劳垢习，自然不起。风触其身，皆得快乐，譬如比丘得灭尽三昧。又风吹散华，遍满佛土。随色次第，而不杂乱。柔软光泽，馨香芬烈。足履其上，蹈下四寸，随举足已，还复如故。华用已讫，地辄开裂，以次化没，清净无遗。随其时节，风吹散华，如是六反。” 其土广大无崖际，众宝罗网遍覆上，
金缕珠玑奇异珍，不可名宝为校饰。
周匝四面垂宝铃，调风吹动出妙法，
和雅德香常流布，闻者尘劳习不起，
此风触身受快乐，如比丘得灭尽定。
风吹散华满佛土，随色次第不杂乱，
华质柔软烈芬芳，足履其上下四指，
随举足时还如故，用讫地开没无遗，
随其时节华六返，不可议报故顶礼。
    “又众宝莲华，周满世界。一一宝华，百千亿叶。其华光明，无量种色。青色青光，白色白光，玄黄朱紫，光色赫然。炜烨焕烂，明曜日月。一一华中，出三十六百千亿光。一一光中，出三十六百千亿佛，身色紫金，相好殊特。一一诸佛，又放百千光明，普为十方说微妙法。如是诸佛，各各安立无量众生于佛正道。” 众宝莲华盈世界，一一华百千亿叶，
其华光明色无量，朱紫红绿间五色，
炜烨焕烂曜日光，是故一心稽首礼。

一一华中所出光，三十六百有千亿，
一一光中有佛身，多少亦如所出光。
佛身相好如金山，一一又放百千光，
普为十方说妙法，各安众生于佛道。
如是神力无边量，故我归命阿弥陀。
    “其讲堂、精舍、宫殿、楼观，皆七宝庄严，自然化成。复以真珠、明月、摩尼众宝，以为交络，覆盖其上。内外左右，有诸浴池。或十由旬，或二十、三十，乃至百千由旬。纵广深浅，皆各一等。八功德水，湛然盈满，清净香洁，味如甘露。黄金池者，底白银沙。白银池者，底黄金沙。水精池者，底琉璃沙。琉璃池者，底水精沙。珊瑚池者，底琥珀沙。琥珀池者，底珊瑚沙。砗磲池者，底玛瑙沙。玛瑙池者，底砗磲沙。白玉池者，底紫金沙。紫金池者，底白玉沙。或有二宝、三宝，乃至七宝，转共合成。其池岸上，有栴檀树，华叶垂布，香气普熏。天优钵罗华、钵昙摩华、拘牟头华、分陀利华，杂色光茂，弥覆水上。” 楼阁殿堂非工造，七宝雕绮化所成，
明月珠珰交露幔，各有浴池形相称。
八功德水满池中，色味香洁如甘露，
黄金池者白银沙，七宝池沙互如此。
池岸香树垂布上，栴檀芬馥常流馨，
天华璀璨为映饰，水上熠耀若景云。
无漏依果难思议，是故稽首功德藏。
    “彼诸菩萨，及声闻众，若入宝池，意欲令水没足，水即没足。欲令至膝，即至于膝。欲令至腰，水即至腰。欲令至颈，水即至颈。欲令灌身，自然灌身。欲令还复，水辄还复。调和冷暖，自然随意。开神悦体，荡除心垢。清明澄洁，净若无形。宝沙映彻，无深不照。微澜回流，转相灌注。安详徐逝，不迟不疾。波扬无量自然妙声，随其所应，莫不闻者。或闻佛声，或闻法声，或闻僧声，或寂静声、空无我声、大慈悲声、波罗蜜声，或十力无畏不共法声、诸通慧声、无所作声、不起灭声、无生忍声，乃至甘露灌顶众妙法声。如是等声，称其所闻，欢喜无量。随顺清净离欲寂灭真实之义，随顺三宝力无所畏不共之法，随顺通慧菩萨、声闻所行之道。无有三途苦难之名，但有自然快乐之音。是故其国，名曰安乐。” 菩萨声闻入宝池，随意浅深如所欲，
若须灌身自然注，欲令旋复水寻还，
调和冷暖无不称，神开体悦荡心垢。
清明澄洁若无形，宝沙映彻如不深，
澹淡回转相注灌，绰约容豫和人神，
微波无量出妙响，随其所应闻法语。
或闻三宝之妙章，或闻寂静空无我，
或闻无量波罗蜜，力不共法诸通慧，
或闻无作无生忍，乃至甘露灌顶法。
随根性欲皆欢喜，顺三宝相真实义，
菩萨声闻所行道，于是一切悉具闻。
三途苦难名永闭，但有自然快乐音，
是故其国号安乐，头面顶礼无极尊。

－－ 		本师龙树摩诃萨，诞形像始理颓纲，
关闭邪扇开正辙，是阎浮提一切眼，
伏承尊悟欢喜地，归阿弥陀生安乐。
譬如龙动云必随，阎浮提放百卉舒，
南无慈悲龙树尊，至心归命头面礼。

－－ 		我从无始循三界，为虚妄轮所回转，
一念一时所造业，足系大地滞三途，
唯愿慈光护念我，令我不失菩提心。
我赞佛慧功德音，愿闻十方诸有缘，
欲得往生安乐者，普皆如意无障碍，
所有功德若大少，回施一切共往生。
南无不可思议光，一心归命稽首礼。

－－ 		十方三世无量慧，同乘一如号正觉，
二智圆满道平等，摄化随缘故若干。
我归阿弥陀净土，即是归命诸佛国，
我以一心赞一佛，愿遍十方无碍人，
如是十方无量佛，咸各至心头面礼。

·清凉书屋敬辑·
2003.05


传记资料七种

昙鸾法师传记资料（七种）

    ●唐·道绰《安乐集》卷下：
    昙鸾法师康存之日，常修净土。亦每有世俗君子，来呵法师曰：“十方佛国，皆为净土。法师何乃独意注西，岂非偏见生也？”法师对曰：“吾既凡夫，智慧浅短。未入地位，念力须均。如似置草引牛，恒须系心槽枥，岂得纵放，全无所归？”虽复难者纷纭，而法师独决。是以无问一切道俗，但与法师一面相遇者，若未生正信，劝令生信；若已生正信者，皆劝归净国。是故法师临命终时，寺傍左右道俗，皆见旛花映院，尽闻异香，音乐迎接，遂往生也。

    ●唐·道宣《续高僧传·义解篇·魏西河石壁谷玄中寺释昙鸾传》：
    释昙鸾，或为峦。未详其氏，雁门人也。家近五台山，神迹灵怪逸于民听。时未志学，便往寻焉。备觌遗踪，心神欢悦，便即出家。内外经籍，具陶文理，而于《四论》、“佛性”，弥所穷研。读《大集经》，恨其词义深密，难以开悟，因而注解。文言过半，便感气疾。权停笔功，周行医疗。行至汾州秦陵故墟，入城东门，上望青霄，忽见天门洞开。六欲阶位，上下重复，历然齐睹。由斯疾愈，欲继前作。顾而言曰：“命惟危脆，不定其常。《本草》诸经，具明正治。长年神仙，往往间出。心愿所指，修习斯法。果克既已，方崇佛教，不亦善乎？”承江南陶隐居者，方术所归，广博弘赡，海内宗重，遂往从之。
    既达梁朝，时大通中也。乃通名云：“北国虏僧昙鸾，故来奉谒。”时所司疑为细作，推勘无有异词，以事奏闻。帝曰：“斯非觇国者，可引入重云殿，仍从千迷道。”帝先于殿隅却坐绳床，衣以袈裟，覆以衲帽。鸾至殿前，顾望无承对者。见有施张高座，上安几拂，正在殿中，傍无余座。径往升之，竖佛性义。三命帝曰：“大檀越，佛性义深，略已标叙，有疑赐问。”帝却衲帽，便以数关往复。因曰：“今日向晚，明须相见。”鸾从座下，仍前直出。诘曲重沓，二十余门，一无错误。帝极叹讶曰：“此千迷道，从来旧侍，往还疑阻。如何一度，遂乃无迷？”明旦，引入太极殿。帝降阶礼接，问所由来。鸾曰：“欲学佛法，恨年命促减，故来远造陶隐居，求诸仙术。”帝曰：“此傲世遁隐者，比屡征不就，任往造之。”
    鸾寻致书通问。陶乃答曰：“去月耳闻音声，兹辰眼受文字，将由顶礼岁积，故使应真来仪。正尔整拂藤蒲，具陈花水，端襟敛思，伫聆警锡也。”及届山，所接对欣然，便以《仙经》十卷，用酬远意。还至浙江，有鲍郎子神者，一鼓涌浪，七日便止。正值波初，无由得度。鸾便往庙所，以情祈告：“必如所请，当为起庙。”须臾，神即见形，状如二十，来告鸾曰：“若欲度者，明旦当得，愿不食言。”及至明晨，涛犹鼓怒。才入船里，帖然安静。依期达帝，具述由缘。有敕，为江神更起灵庙。因即辞还魏境，欲往名山，依方修治。
    行至洛下，逢中国三藏菩提留支。鸾往启曰：“佛法中颇有长生不死法，胜此土《仙经》者乎？”留支唾地曰：“是何言欤？非相比也。此方何处有长生法？纵得长年，少时不死，终更轮回三有耳。”即以《观经》授之曰：“此大仙方，依之修行，当得解脱生死也。”鸾寻顶受。所赍仙方并火焚之。自行化他，流靡弘广。魏主重之，号为“神鸾”焉。下敕令住并州大寺。晚复移住汾州北山石壁玄中寺。时往介山之阴，聚徒蒸业，今号“鸾公岩”是也。以魏兴和四年，因疾卒于平遥山寺，春秋六十有七。临至终日，旛花幢盖，高映院宇，香气熢勃，音声繁闹。预登寺者，并同瞩之。以事上闻，敕乃葬于汾西泰陵文谷，营建砖塔，并为立碑，今并存焉。
    然鸾神宇高远，机变无方，言晤不思，动与事会。调心练气，对病识缘，名满魏都，用为方轨，因出《调气论》。又著作王邵，随文注之。又撰《礼净土十二偈》，续龙树偈后。又撰《安乐集》两卷等，广流于世。仍自号为“有魏玄简大士”云。

    ●唐·迦才《净土论》卷下：
    沙门昙鸾法师者，并州汶水人也。魏末、高齐之初犹在。神智高远，三国知闻。洞晓众经，独步人外。梁国天子萧王，恒向北礼“昙鸾菩萨”。注解天亲菩萨《往生论》，裁成两卷。法师撰集《无量寿经奉赞》七言偈百九十五行，并《问答》一卷，流行于世。劝道俗等，决定往生，得见诸佛。恒请龙树菩萨临终开悟，诚如所愿。此方报尽，半霄之内现圣僧像，忽来入室云：“我是龙树。”便为说曰：“已落之叶，不可更附枝也。未束之粟，不可仓中求也。白驹过隙，不可暂时留也。已去者叵反，未来未可追，现在今何在，白驹难可回。”法师妙达言旨。如是告终，即半夜内，发遣使者。遍告诸村白衣弟子，及寺内出家弟子，可三百余人，一时云集。法师沐浴，着新净衣，手执香炉，正面西坐。教诫门徒，索西方业。日初出时，大众齐声念弥陀佛，便即寿终。寺西五里之外，有比丘尼寺，并是门徒。明相出后，集堂食粥，举众皆闻空内有微妙音乐西来东去。中有智者告大众言：“法师和上，一生教人修净土业。今此音声向东去者，必应多是迎法师来。”食讫，相命觐法师去。庭前相待，未出寺庭之间，复闻音乐，远在空中，向西而去。尼僧等相与至彼，乃见无常。此依经论，定得生西方也。

    ●南宋·王日休《龙舒净土文·往生事迹·后魏壁谷僧昙鸾》：
    昙鸾，初自陶隐居得《仙经》十卷，鸾欣然自得，以为神仙必可致也。后遇僧菩提留支，问云：“佛道有长生乎？能却老为不死乎？”支云：“长生不死，吾佛道也。”遂以《十六观经》与之云：“汝可诵此，则三界无复生，六道无复往。盈虚消息，祸福成败，无得而至。其为寿也，有劫石焉，有河沙焉。沙、石之数有限，寿量之数无穷，此吾金仙氏之长生也。”鸾深信之，遂焚《仙经》，而专修《观经》。虽寒暑之变，疾病之来，亦不懈怠。魏主怜其志尚，又嘉其自行化他，流传甚广，号为“神鸾”。一日，告弟子云：“地狱诸苦，不可以不惧。九品净业，不可以不修。”因令弟子高声念阿弥陀佛，鸾西向闭目叩头而亡。是时僧俗，同闻管弦丝竹之声，从西而来，良久乃止。

    ●南宋·宗晓《乐邦文类·卷三·后魏壁谷神鸾法师传》：
    释昙鸾，雁门人。少游五台，因感灵异，誓而出俗。三乘、顿、渐，具陶文理。师性好方术，闻江南陶隐居有长生法，千里就之。陶即以所学《仙经》十卷授之。师喜跃自得，以谓神仙必可致也。后还洛下，遇三藏菩提留支，意颇得之，问支曰：“佛道有长生乎？其能却老为不死乎？”支笑曰：“长生不死，吾佛道也。道家何有焉？”遂以《十六观经》授之曰：“汝可诵此，则三界无复生，六道无长往。盈虚消息，祸福成败，无得而至。其为寿也，有劫石焉，有河沙焉。沙、石之数有限，寿量之数无穷，此吾金仙氏之长生也。”鸾承其语，骤起深信，遂焚所学《仙经》，而专《观经》，修三福业，想像九莲。虽寒暑之变，疾病之侵，不懈于始念。魏主怜其志尚，号为“神鸾”。一夕正持诵次，忽一梵僧昂然入室曰：“吾龙树也，所居者净土焉。以汝有净土之心，故来见汝。”鸾曰：“何以教我？”树曰：“已去不可及，未来未可追，现在今何在，白驹难与回。”言讫而失。鸾以所见胜异，必知死期至矣。即集众盛陈教诫，因令高声唱阿弥陀佛，鸾乃西向瞑目而终。一众同闻管弦丝竹之声，由西而来，良久乃寂。魏主感之，敕葬汾西，条其行业以立碑焉。

    ●明·莲池《往生集·沙门往生类·神鸾》：
    后魏昙鸾，少游五台，感灵异出家。而性嗜长生，受陶隐居《仙经》十卷。后遇菩提流支，乃问曰：“佛有长生不死术乎？”支笑曰：“长生不死，吾佛道也！”乃授《十六观经》曰：“学此，则三界无复生，六道无复往。其为寿也，河沙、劫石莫能比焉，此吾金仙氏之长生也。”鸾大喜，遂焚《仙经》，而修净业。寒暑、疾痛，曾无少懈。魏主号为“神鸾”。一夕室中见梵僧谓曰：“吾龙树也，久居净土。以汝同志，故来相见。”鸾自知时至，集众教诫曰：“劳生役役，其止无日。地狱诸苦，不可以不惧。九品净业，不可以不修。”因令弟子高声念佛，西向稽颡而终。众闻天乐自西而来，良久乃已。
    赞曰：黄冠者恒言曰：“释氏有死，神仙长生。”今支公谓佛有长生，仙无长生。此论痛快简当，高出千古。鸾法师舍伪归真，如脱敝屣，岂非宿有正因者哉！

    ●清·彭希涑《净土圣贤录·往生比丘·魏昙鸾》：
    昙鸾，雁门人。少游五台山，见神迹灵异，因发信心出家。读《大集经》，以其词义深密，因为注解。文言过半，便感气疾，周行医疗。既而叹曰：“人命危脆，旦夕无常。吾闻长年神仙，往往间出。得是法已，方崇佛教，不亦可乎？”遂往江南陶隐居所，恳求仙术。隐居授以《仙经》十卷。欣然而还，至洛下，遇三藏菩提留支。鸾问曰：“佛法中颇有长生不死法，胜此《仙经》者乎？”留支曰：“此方何处有长生不死法？纵得长年，少时不死，卒归轮转，曷足贵乎？夫长生不死，吾佛道也。”乃以《十六观经》授之曰：“学此，则三界无复生，六道无复往。盈虚消息，祸福成败，无得而至。其为寿也，河沙劫量，莫能比也。此吾金仙氏之长生也。”鸾大喜，遂焚《仙经》，而专修净观。自行化他，流布弥广。撰《礼净土十二偈》，续龙树偈。又撰《安乐集》两卷，传于世。魏主重之，号为“神鸾”，敕住并州大寺。晚移汾州玄中寺。兴和四年，一夕室中见梵僧谓曰：“吾龙树也，久居净土。以汝同志，故来相见。”鸾自知时至，集众教诫曰：“劳生役役，其止无日。地狱诸苦，不可不惧。九品净业，不可不修。”因令弟子高声唱佛，西向稽颡而终。在寺者俱见幡华幢盖，自西而来。天乐盈空，良久乃已。事闻于朝，敕葬汾西文谷，建塔立碑。

·清凉书屋敬辑·
2003.05


印光法师之评赞

印光法师对昙鸾法师
及所著《往生论注》之评赞

    ○粤自大教东流，庐山创兴莲社，一倡百和，无不率从。而其大有功而显著者，北魏则有昙鸾，鸾乃不测之人也。因事至南朝见梁武帝，后复归北。武帝每向北稽首曰：“鸾法师，肉身菩萨也。”陈隋则有智者。唐则有道绰，踵昙鸾之教，专修净业，一生讲净土三经，几二百遍。绰之门出善导，以至承远、法照、少康、大行，则莲风普扇于中外矣。由此诸宗知识，莫不以此道密修显化，自利利他矣。（《增广文钞·与大兴善寺体安和尚书》）

    ○及至大教东来，庐山创开莲社，一唱百和，无不率从。千五百余年来，潜修显化者，多难胜数。举其尤者，元魏则有昙鸾，陈隋则有智者，唐则有道绰、善导、怀感、飞锡、承远、法照、少康、大行。如上诸师，悉皆道超十地，德震九重。无一法而不通，唯此法以是尚。（《增广文钞·陕西南五台山大觉岩西林茅篷专修净业缘起记》）

    ○迨至大教东来，远公大师，遂以此为宗。……若终公之世，三十余年之内，其入莲社而修净业，蒙接引而得往生者，则多难胜数也。自后若昙鸾、智者、道绰、善导、清凉、永明，莫不以此，自行化他。昙鸾著《往生论注》，妙绝古今。智者作《十疑论》，极陈得失；著《观经疏》，深明谛观。道绰讲净土三经，近二百遍。善导疏净土三经，力劝专修。清凉疏《行愿品》，发挥究竟成佛之道。永明说《四料简》，直指即生了脱之法。（《增广文钞·庐山青莲寺结社念佛宣言书》）

    ○《往生论注》阅一遍。文义显豁直捷。真能上继匡庐，下启天台、西河、长安等。宜细看之。（《增广文钞·与康泽师书》）

    ○《往生论注》，照光标示，已标过否？此书文理甚好，宜熟看之。（《增广文钞·复马契西居士书三》）

    ○所言看书，汝身膺职务，无多闲暇，只可先从《文钞》、《嘉言录》起。而《净土三经》、《往生论注》、《彻悟语录》、《净土十要》、《净土圣贤录》、《净土指归集》、《龙舒净土文》，宜详看。其余若禅宗，教家天台宗、贤首宗、慈恩宗，并及密宗，且置之，以力不暇及。（《文钞续编·复杨慧昌居士书》）

    ○净土经典甚多，《钞》中多皆具录。如《观经善导疏》（现南京观音庵新刻，颇比前杨仁山刻者的确多）、《无量寿经疏》、《普贤行愿品疏抄撷》（此范古农所撷）。《阿弥陀经》、《无量寿经》、《观无量寿佛经》、《普贤行愿品》，为净土四经。《往生论注》，此须请北京新刻者，一则错讹少，二则眉目清，此书好极。《弥陀疏钞》，虽复广大精微，但以文繁义广，反令初机难以得益。而《弥陀要解》，实为千古第一妙解，乃古今绝无而仅有者，切勿以等闲视之，则幸甚。（《文钞三编·复王尊莲居士书》）

    ○生死，吾人第一大事也。净土法门，了生死无上妙法也。一代时教，浩若渊海。其究竟畅佛普度众生之本怀者，唯净土一法而已。以下凡信愿念佛，即可带业往生。上圣若肯回向，速得圆成觉道。仗佛慈力，与唯仗自力，其难易固日劫相倍。天亲菩萨广造诸论，宏阐佛乘。复宗《无量寿经》，作《愿生偈论》。示五门修法，令毕竟得生。具显礼拜、赞叹、作愿、观察、回向之法。于观察门，详示净土庄严、如来法力、菩萨功德。凡见闻者，悉愿往生。昙鸾法师，撰注详释。直将弥陀誓愿、天亲衷怀，彻底圆彰，和盘托出。若非深得佛心，具无碍辩，何克臻此！夫净土一法，为一切诸法之所归趣。以故《华严》证齐诸佛之等觉菩萨，尚须以十大愿王，回向往生。则文殊、普贤、马鸣、龙树、智者、慈恩、清凉、永明等，自行化他，同归净土者，有由来矣。知此，则唯执自力，不仗佛力者，可以怵然惊、憬然悟。以期现生即得出此娑婆，生彼极乐。与观音、势至等诸上善人，俱会一处。常时亲炙阿弥陀佛，以冀证无生忍，圆满菩提而后已也。吾言不足信，请质之普贤菩萨，自可无疑矣。（《增广文钞·往生论注跋》）

    ○蕅益大师所选《净土十要》，实为净宗最要之妙典。成时大师欲为广布，特节略之，致使有文义隐晦，稍拂初机之处。因搜罗原本，特为排印，仍作四册。以卷有薄者，遂取古德宏扬净土之要文附之。如帝网珠，互相辉映，诚为净宗一大快事。窃以天亲菩萨《往生论》，净宗之要典也，世罕流通。昙鸾法师之注，文畅达而义深邃，洵足开人正智，起人正信，乃净业学人之大导师。惜中国久已失传，清末杨仁山居士请于东瀛，刻以流通。因论、注相联，初机殊难分判。乃逐段标出，令徐蔚如居士刻于北京。今拟将此书，并《莲华世界诗》，合作一册，以作《净土十要》之附本，冀与《十要》并传于世。庶可熢[火+孛]火宅，常被焚烧之同伦，知此宅之外，原有最极清净安隐之家乡。从兹当仁不让，贾勇先登，同出五浊，同登九品，同预莲池海会，同侍无量寿佛，以渐证夫无生法忍，与无上菩提。得以上不辜于佛化，下不负于己灵，方可名为真大丈夫也已！（《净土十要·往生论注重排序》）

    ○四十八愿中，十念称名，即得往生，唯除五逆、诽谤正法。此约平时说。以五逆罪大，谤法不信，此种罪障，岂悠悠泛泛之修持所能灭乎？《观经》五逆十恶，将欲命终，地狱相现，有善知识（此不论僧俗男女，但能教彼念佛者，即名善知识）教以念佛，或止十声，或不及十声，直下命终，亦得仗佛慈力，带业往生。此之十念，比平常之十念，其猛切有天渊相殊之势，故得往生也。以地狱极苦所逼，其一闻佛名，乃以全副精神为之称念。除此念外，绝无他念。虽非亲证一心不乱，然其心毕竟了无异念。当此之时，绝无有三心二意、疑信相参之心相，故不言及谤法。即平素谤法之人，亦必如堕水火以求救援，何暇生疑起谤耶？《往生论》谓谤法者，决定不生。以既谤正法，自无正信，何能往生？此极劝人生正信耳。若先曾谤法，后知改悔，则得往生。譬如病愈即是好人，归降即是顺民也。若谓谤法之人，后纵改悔，亦不得往生，便完全失却修持准绳。与儒教尚不合，况佛以一切众生同具佛性，皆当成佛乎？《书》云：“惟圣罔念作狂，惟狂克念作圣。”是知儒、佛皆以改过迁善，以期希圣希贤、断惑证真为事也。世人不善会其意，徒执其文，自生障碍，可不哀哉！（《文钞三编·复陈薪儒居士书》）

·清凉书屋敬辑·
2003.05