首页

释迦如来教法灭尽记

（版本号：1.01）

一切行无常，信是生灭法，
生灭既灭已，寂灭为最乐。

清凉书屋 辑校
·2003.06·


前　言

    此专集共收录了十三种典籍。其中《佛说当来变经》、《佛说法灭尽经》、《大集月藏经·法灭尽品》、《杂阿含经》卷第二十五、《佛临涅槃记法住经》、《涅槃经·梵行品》（节录）、《摩诃摩耶经》卷下、《佛使比丘迦旃延说法没尽偈》、《迦丁比丘说当来变经》、《大阿罗汉难提蜜多罗所说法住记》十种，记述了本师释迦牟尼佛及弟子对如来圣教在末法时代逐渐衰亡与最后灭尽情况的预言。这些教典并对佛法逐渐衰亡的内在原因作了深刻的揭示。
    其中《大集月藏经·法灭尽品》、《杂阿含经》卷第二十五、《涅槃经·梵行品》（节录）、《摩诃摩耶经》卷下、《佛使比丘迦旃延说法没尽偈》、《迦丁比丘说当来变经》六种，对将会发生在拘睒弥国的最后六百（或说一千）比丘相残，而导致如来教法最终灭尽的重大事件，有着一致的确切描述。此事件发生后，比丘僧团一时不复存在。如《大集月藏经·法灭尽品》记：其时比丘袈裟变白，“染色不复现”。《杂阿含经》卷第二十五记：“尔时诸邪见辈，诤竞打破塔庙及害比丘，从是佛法索然顿灭。”《摩诃摩耶经》卷下记：“恶魔波旬及外道众踊跃欢喜，竞破塔寺，杀害比丘。一切经藏皆悉流移至鸠尸那竭国，阿耨达龙王悉持入海，于是佛法而灭尽也。”但在《涅槃经·梵行品》中，如来又悬记：“尔时凡夫各共说言：‘哀哉！佛法于是灭尽。’而我正法实不灭也。尔时其国有十二万诸大菩萨，善持我法，云何当言我法灭耶？”或可推知其时虽比丘僧团已消失，但由于贤劫诸大菩萨的护持（《大集月藏经·法灭尽品》记载，佛预记末法时事，嘱诸菩萨护持，咸皆默然。唯弥勒等贤劫大士出语承当），如来教法仍在部分在家有缘众中流传不绝。
    另据玄奘法师所译《大阿罗汉难提蜜多罗所说法住记》，佛临涅槃时付嘱十六大阿罗汉并诸眷属，令其护持正法，使不灭没。至南赡部洲人寿十岁时刀兵劫起，“佛法尔时当暂灭没”。刀兵劫后人寿增至百岁时，十六大阿罗汉与诸眷属复来人间宣说正法，度无量众出家，重新建立比丘僧团。至人寿六万岁时，正法炽然流行。直至人寿七万岁时，“无上正法方永灭没”。其时十六大阿罗汉与诸眷属会聚于南赡部洲，将释迦牟尼佛所有真身舍利皆集于所造七宝塔内，其塔自然陷入地下，停住于金轮际。十六大阿罗汉与诸眷属，一时俱入无余涅槃。《法住记》还悬记，在释迦牟尼佛正法中，于佛、法、僧三宝所植下善根的众生，将在弥勒成佛时分别于三会中出家，得证涅槃正果。
    除以上十种外，还收录了《法华经·如来寿量品》，以便读者更为全面地了解本师“成佛已来甚大久远，寿命无量阿僧祇劫，常住不灭”，及“为度众生故，方便现涅槃，而实不灭度，常住此说法”的本迹，对如来因我等众生迷失本心，不肯如说奉行，而方便示现灭度的悲心有所感悟。
    此外，《佛垂般涅槃略说教诫经》（又名《佛遗教经》）为本师释迦牟尼佛在将入涅槃的中夜时分，对诸比丘弟子所作的最后叮咛。《楞严经·四种清净明诲》为本师针对如来灭度后，末法之中邪说炽盛，预先所作的特别垂训。此二种教诫匡扶末法流弊，最为深切著明，宜深味而力行之，故本集一并收录。
    以上所收十三种典籍，一一作了详细的校勘与标点，并对其中部分典籍作了必要的注释，希望能对三宝弟子准确理解当前佛教现状及变化趋势有所帮助。摩耶夫人曾因本师灭度而叹道：“呜呼生死法，可畏可厌离！”愿诸阅者因着本师入灭及未来佛法灭尽之事实，而对世间万法无常变灭的本质深生警悟。真为生死，发菩提心，护佛正法，勤求解脱之道。
    愿以此辑录、校订功德，回向三宝龙天，愿如来正法永久住世！

净业学人 张景岗
2003年3月记于北京清凉书屋


法华经·如来寿量品

妙法莲华经卷第五
如来寿量品

姚秦三藏法师鸠摩罗什译

    尔时佛告诸菩萨及一切大众：“诸善男子，汝等当信解如来诚谛之语。”
    复告大众：“汝等当信解如来诚谛之语。”
    又复告诸大众：“汝等当信解如来诚谛之语。”
    是时菩萨大众，弥勒为首，合掌白佛言：“世尊，惟愿说之，我等当信受佛语。”如是三白已，复言：“惟愿说之，我等当信受佛语。”
    尔时世尊，知诸菩萨三请不止，而告之言：“汝等谛听。如来秘密神通之力，一切世间天、人及阿修罗，皆谓今释迦牟尼佛，出释氏宫，去伽耶城不远，坐于道场，得阿耨多罗三藐三菩提。然善男子，我实成佛已来，无量无边百千万亿那由他劫。譬如五百千万亿那由他阿僧祇三千大千世界，假使有人，抹为微尘。过于东方五百千万亿那由他阿僧祇国，乃下一尘。如是东行，尽是微尘。诸善男子，于意云何？是诸世界，可得思惟校计，知其数否？”
    弥勒菩萨等俱白佛言：“世尊，是诸世界，无量无边，非算数所知，亦非心力所及。一切声闻、辟支佛，以无漏智，不能思惟知其限数。我等住阿惟越致地，于是事中，亦所不达。世尊，如是诸世界，无量无边。”
    尔时佛告大菩萨众：“诸善男子，今当分明宣语汝等。是诸世界，若着微尘，及不着者，尽以为尘，一尘一劫。我成佛已来，复过于此百千万亿那由他阿僧祇劫。自从是来，我常在此娑婆世界，说法教化。亦于余处百千万亿那由他阿僧祇国，导利众生。诸善男子，于是中间，我说燃灯佛等。又复言其入于涅槃。如是皆以方便分别。诸善男子，若有众生来至我所，我以佛眼，观其信等诸根利钝，随所应度。处处自说名字不同，年纪大小。亦复现言当入涅槃。又以种种方便，说微妙法，能令众生发欢喜心。诸善男子，如来见诸众生，乐于小法，德薄垢重者，为是人说：‘我少出家，得阿耨多罗三藐三菩提。’然我实成佛已来，久远若斯。但以方便教化众生，令入佛道，作如是说。诸善男子，如来所演经典，皆为度脱众生。或说己身，或说他身。或示己身，或示他身。或示己事，或示他事。诸所言说，皆实不虚。所以者何？如来如实知见三界之相，无有生死若退若出，亦无在世及灭度者，非实非虚，非如非异，不如三界见于三界。如斯之事，如来明见，无有错谬。以诸众生有种种性、种种欲、种种行、种种忆想分别故，欲令生诸善根，以若干因缘譬喻言辞，种种说法。所作佛事，未曾暂废。如是我成佛已来，甚大久远，寿命无量阿僧祇劫，常住不灭。
    “诸善男子，我本行菩萨道所成寿命，今犹未尽，复倍上数。然今非实灭度，而便唱言当取灭度。如来以是方便，教化众生。所以者何？若佛久住于世，薄德之人，不种善根；贫穷下贱，贪著五欲，入于忆想妄见网中。若见如来常在不灭，便起骄恣，而怀厌怠，不能生难遭之想、恭敬之心。是故如来以方便说：‘比丘当知，诸佛出世，难可值遇。’所以者何？诸薄德人，过无量百千万亿劫，或有见佛，或不见者。以此事故，我作是言：‘诸比丘，如来难可得见。’斯众生等闻如是语，必当生于难遭之想。心怀恋慕，渴仰于佛，便种善根。是故如来虽不实灭，而言灭度。
    “又善男子，诸佛如来，法皆如是。为度众生，皆实不虚。譬如良医，智慧聪达，明练方药，善治众病。其人多诸子息，若十、二十，乃至百数。以有事缘，远至余国。诸子于后饮他毒药，药发闷乱，宛转于地。是时其父，还来归家。诸子饮毒，或失本心，或不失者，遥见其父，皆大欢喜，拜跪问讯：‘善安隐归！我等愚痴，误服毒药。愿见救疗，更赐寿命。’父见子等苦恼如是，依诸经方，求好药草，色香美味，皆悉具足。捣筛和合，与子令服。而作是言：‘此大良药，色香美味，皆悉具足。汝等可服，速除苦恼，无复众患。’其诸子中不失心者，见此良药色香俱好，即便服之，病尽除愈。余失心者，见其父来，虽亦欢喜问讯，求索治病，然与其药，而不肯服。所以者何？毒气深入，失本心故，于此好色香药，而谓不美。父作是念：‘此子可愍，为毒所中，心皆颠倒。虽见我喜，求索救疗，如是好药，而不肯服。我今当设方便，令服此药。’即作是言：‘汝等当知，我今衰老，死时已至。是好良药，今留在此，汝可取服，勿忧不瘥。’作是教已，复至他国，遣使还告：‘汝父已死。’是时诸子闻父背丧，心大忧恼，而作是念：‘若父在者，慈愍我等，能见救护。今者舍我，远丧他国。自惟孤露，无复恃怙。’常怀悲感，心遂醒悟，乃知此药色味香美。即取服之，毒病皆愈。其父闻子悉已得瘥，寻便来归，咸使见之。诸善男子，于意云何？颇有人能说此良医虚妄罪否？”
    “不也，世尊。”
    佛言：“我亦如是，成佛已来，无量无边百千万亿那由他阿僧祇劫。为众生故，以方便力，言当灭度。亦无有能如法说我虚妄过者。”
    尔时世尊欲重宣此义，而说偈言：

“自我得佛来，所经诸劫数，
无量百千万，亿载阿僧祇。
常说法教化，无数亿众生，
令入于佛道。尔来无量劫，
为度众生故，方便现涅槃，
而实不灭度，常住此说法。
我常住于此，以诸神通力，
令颠倒众生，虽近而不见。
众见我灭度，广供养舍利，
咸皆怀恋慕，而生渴仰心。
众生既信伏，质直意柔软，
一心欲见佛，不自惜身命。
时我及众僧，俱出灵鹫山，
我时语众生，常在此不灭，
以方便力故，现有灭不灭。
余国有众生，恭敬信乐者，
我复于彼中，为说无上法。
汝等不闻此，但谓我灭度。
我见诸众生，没在于苦恼，
故不为现身，令其生渴仰，
因其心恋慕，乃出为说法。
神通力如是，于阿僧祇劫，
常在灵鹫山，及余诸住处。
众生见劫尽，大火所烧时，
我此土安隐，天人常充满。
园林诸堂阁，种种宝庄严，
宝树多华果，众生所游乐。
诸天击天鼓，常作众伎乐，
雨曼陀罗华，散佛及大众。
我净土不毁，而众见烧尽，
忧怖诸苦恼，如是悉充满。
是诸罪众生，以恶业因缘，
过阿僧祇劫，不闻三宝名。
诸有修功德，柔和质直者，
则皆见我身，在此而说法。
或时为此众，说佛寿无量。
久乃见佛者，为说佛难值。
我智力如是，慧光照无量，
寿命无数劫，久修业所得。
汝等有智者，勿于此生疑，
当断令永尽，佛语实不虚。
如医善方便，为治狂子故，
实在而言死，无能说虚妄。
我亦为世父，救诸苦患者，
为凡夫颠倒，实在而言灭。
以常见我故，而生骄恣心，
放逸著五欲，堕于恶道中。
我常知众生，行道不行道，
随所应可度，为说种种法。
每自作是意，以何令众生，
得入无上慧，速成就佛身。”

据《乾隆大藏经》、《大正藏》校订

·清凉书屋点校·
2003.03


楞严经·四种清净明诲

大佛顶首楞严经卷第六
四种决定清净明诲

唐天竺沙门般刺密谛译

    佛告阿难：“汝常闻我毗奈耶中，宣说修行三决定义。所谓摄心为戒，因戒生定，因定发慧，是则名为三无漏学。
    “阿难，云何摄心，我名为戒？若诸世界六道众生，其心不淫，则不随其生死相续。汝修三昧，本出尘劳。淫心不除，尘不可出。纵有多智禅定现前，如不断淫，必落魔道。上品魔王，中品魔民，下品魔女。彼等诸魔，亦有徒众，各各自谓成无上道。我灭度后，末法之中，多此魔民炽盛世间。广行贪淫，为善知识，令诸众生，落爱见坑，失菩提路。汝教世人修三摩地，先断心淫，是名如来先佛世尊，第一决定清净明诲。是故阿难，若不断淫，修禅定者，如蒸沙石，欲其成饭，经百千劫，只名热沙。何以故？此非饭本，沙石成故。汝以淫身，求佛妙果，纵得妙悟，皆是淫根。根本成淫，轮转三途，必不能出。如来涅槃，何路修证？必使淫机，身心俱断，断性亦无，于佛菩提，斯可希冀。如我此说，名为佛说。不如此说，即波旬说。
    “阿难，又诸世界六道众生，其心不杀，则不随其生死相续。汝修三昧，本出尘劳。杀心不除，尘不可出。纵有多智禅定现前，如不断杀，必落神道。上品之人，为大力鬼；中品则为飞行夜叉、诸鬼帅等；下品当为地行罗刹。彼诸鬼神，亦有徒众，各各自谓成无上道。我灭度后，末法之中，多此鬼神炽盛世间。自言食肉，得菩提路。阿难，我令比丘食五净肉，此肉皆我神力化生，本无命根。汝婆罗门，地多蒸湿，加以沙石，草菜不生。我以大悲神力所加，因大慈悲，假名为肉，汝得其味。奈何如来灭度之后，食众生肉，名为释子？汝等当知，是食肉人，纵得心开似三摩地，皆大罗刹，报终必沉生死苦海，非佛弟子。如是之人，相杀相吞，相食未已，云何是人得出三界？汝教世人修三摩地，次断杀生，是名如来先佛世尊，第二决定清净明诲。是故阿难，若不断杀，修禅定者，譬如有人自塞其耳，高声大叫，求人不闻，此等名为欲隐弥露。清净比丘，及诸菩萨，于歧路行，不蹋生草，况以手拔。云何大悲，取诸众生血肉充食？若诸比丘，不服东方丝绵绢帛，及是此土靴履裘毳、乳酪醍醐。如是比丘，于世真脱，酬还宿债，不游三界。何以故？服其身分，皆为彼缘。如人食其地中百谷，足不离地。必使身心，于诸众生，若身、身分，身心二途，不服不食。我说是人，真解脱者。如我此说，名为佛说。不如此说，即波旬说。
    “阿难，又复世界六道众生，其心不偷，则不随其生死相续。汝修三昧，本出尘劳。偷心不除，尘不可出。纵有多智禅定现前，如不断偷，必落邪道。上品精灵；中品妖魅；下品邪人，诸魅所著。彼等群邪，亦有徒众，各各自谓成无上道。我灭度后，末法之中，多此妖邪炽盛世间。潜匿奸欺，称善知识，各自谓己得上人法。詃惑无识，恐令失心。所过之处，其家耗散。我教比丘，循方乞食，令其舍贪，成菩提道。诸比丘等，不自熟食，寄于残生，旅泊三界，示一往还，去已无返。云何贼人，假我衣服，裨贩如来，造种种业，皆言佛法，却非出家具戒比丘为小乘道。由是疑误无量众生，堕无间狱。若我灭后，其有比丘，发心决定修三摩地，能于如来形像之前，身燃一灯，烧一指节，及于身上爇一香炷。我说是人，无始宿债，一时酬毕，长揖世间，永脱诸漏。虽未即明无上觉路，是人于法已决定心。若不为此舍身微因，纵成无为，必还生人，酬其宿债。如我马麦，正等无异。汝教世人修三摩地，后断偷盗，是名如来先佛世尊，第三决定清净明诲。是故阿难，若不断偷，修禅定者，譬如有人，水灌漏卮，欲求其满，纵经尘劫，终无平复。若诸比丘，衣钵之余，分寸不畜。乞食余分，施饿众生。于大集会，合掌礼众。有人捶詈，同于称赞。必使身心二俱捐舍，身肉骨血，与众生共。不将如来不了义说，回为己解，以误初学。佛印是人，得真三昧。如我所说。名为佛说。不如此说，即波旬说。
    “阿难，如是世界六道众生，虽则身心无杀盗淫，三行已圆。若大妄语，即三摩地不得清净。成爱见魔，失如来种。所谓未得谓得，未证言证，或求世间尊胜第一。谓前人言：‘我今已得须陀洹果、斯陀含果、阿那含果、阿罗汉道、辟支佛乘、十地、地前诸位菩萨。’求彼礼忏，贪其供养。是一颠迦，销灭佛种。如人以刀断多罗木。佛记是人，永殒善根，无复知见，沉三苦海，不成三昧。我灭度后，敕诸菩萨及阿罗汉，应身生彼末法之中，作种种形，度诸轮转。或作沙门、白衣居士、人王宰官、童男童女，如是乃至淫女寡妇、奸偷屠贩，与其同事，称赞佛乘，令其身心入三摩地。终不自言：‘我真菩萨，真阿罗汉。’泄佛密因，轻言未学。唯除命终，阴有遗付。云何是人，惑乱众生，成大妄语？汝教世人修三摩地，后复断除诸大妄语，是名如来先佛世尊，第四决定清净明诲。是故阿难，若不断其大妄语者，如刻人粪，为栴檀形，欲求香气，无有是处。我教比丘，直心道场，于四威仪一切行中，尚无虚假，云何自称得上人法？譬如穷人，妄号帝王，自取诛灭。况复法王，如何妄窃？因地不真，果招纡曲。求佛菩提，如噬脐人，欲谁成就？若诸比丘，心如直弦，一切真实，入三摩地，永无魔事。我印是人，成就菩萨无上知觉。如我所说，名为佛说。不如此说，即波旬说。”

据《乾隆大藏经》、《大正藏》校订


佛说当来变经

西晋三藏法师竺法护译

    闻如是。一时，佛在舍卫国祇树给孤独园，与大比丘众俱，比丘五百，及诸菩萨。
    尔时世尊告诸比丘：“将来之世，当有比丘，因有一法不从法化，令法毁灭，不得长益。何谓为一？不护禁戒，不能守心，不修智慧。放逸其意，唯求善名。不顺道教，不肯勤慕度世之业。是为一事，令法毁灭。”
    佛告比丘：“复有二事，令法毁灭。何谓为二？一、不护禁戒，不摄其心，不修智慧。畜妻养子，放心恣意。贾作治产，以相供活。二、伴党相著，憎奉法者。欲令陷堕，故为言议，谓之谀谄。内私犯恶，外扬清白。是为二事，令法毁灭。”
    佛告比丘：“复有三事，令法毁灭。何谓为三？一、既不护戒，不能摄心，不修经义。二、自读文字，不谛句逗，以上着下，以下着上，头尾颠倒，不能解了义之所归，自以为是。三、明者呵之，不从其教，反怀瞋恨，谓相嫉妒。识义者少，多不别理，咸自为是。是为三事，令法毁灭。”
    佛告比丘：“复有四事，令法毁灭。何谓为四？一、将来比丘，已舍家在空闲处，不修道业。二、喜游人间，愦闹之中行来，比丘谈言，求好袈裟、五色之服。三、高望远视，以为绮饰，自以高德，无能及者。以杂碎之智，比日月之明畜已。四、不摄三事，不护根门。行妇女间，宣文饰辞。多言合偶，以动人心。使清变浊，身行荒乱，正法废迟。是为四事，令法毁灭。”
    佛告比丘：“复有五事，令法毁灭。何谓为五？一、或有比丘，本以法故，出家修道，废深经教十二因缘、三十七品、方等深妙玄虚之慧；智度无极、善权方便、空无相愿至化之即。二、反习杂句，浅末小经，世俗行故。王者经典，乱道之原，好讲此业。易解世事，趣得人心，令其欢悦，因致名闻。三、新闻法人，浅解之士，意用妙快。深达之人，不用为佳。四、天龙鬼神不以为喜，心怀悒戚，口发斯言：‘大法欲灭，故使其然。舍妙化法，反宣杂句。’诸天流泪，速逝而去。五、由是正法稍稍见舍，无精修者。是为五事，令法毁灭。”
    佛告比丘：“吾灭度后，有此邪事十五之乱，令法毁灭，一何痛哉！若有比丘欲谛学道，弃捐绮饰，不求名闻，质朴守真。宣传正经，佛之雅典，深法之辞，不用多言。案其本经，不舍正句，希言屡中，不失佛意。粗衣趣食，得美不甘，得粗不恶。衣食好丑，随施者意，不以瞋喜。摄身口意，守诸根门，不违佛教。寿命甚短，恍惚已过。如梦所见，觉不知处。三途之难，不可称计。勤修佛法，犹救头燃。五戒十善、六度无极、四等四恩、智慧善权，咸可修行。虽复后生，不值佛世，出家为道，学不唐捐，平其本心，愍哀一切，十方蒙恩。”
    佛说如是。诸比丘悲喜，前自归佛，作礼而去。

据《乾隆大藏经》、《大正藏》校订


佛说法灭尽经

失译人名

    闻如是。一时佛在拘夷那竭国，如来三月当般涅槃，与诸比丘，及诸菩萨。无央数众，来诣佛所，稽首于地。眷属围绕，渴仰闻法。世尊寂静，默无所说，光明不现。
    贤者阿难作礼白佛言：“世尊前后说法，威光独显。今大众会，光更不现，何故如此？必有缘故，愿闻其意。”佛默不应，如是至三。
    佛告阿难：“吾涅槃后，法欲灭时，五逆浊世，魔道兴盛。魔作沙门，坏乱吾道。着俗衣裳，乐好袈裟、五色之服。饮酒啖肉，杀生贪味，无有慈心，更相憎嫉。
    “时有菩萨、辟支、罗汉，精进修德，一切敬待，人所宗尚。教化平等，怜贫念老，救育穷厄。恒以经像，令人奉事，作诸功德。志性思善，不侵害人，捐身济物，不自惜己，忍辱仁和。设有是人，众魔比丘咸共嫉之，诽谤扬恶，摈黜驱遣，不令得住。
    “自共于后，不修道德，寺庙空荒，无复修理，转就毁坏。但贪财物，积聚不散，不作福德。贩卖奴婢，耕田种植，焚烧山林，伤害众生，无有慈心。奴为比丘，婢为比丘尼，无有道德，淫泆浊乱，男女不别。令道薄淡，皆由斯辈。
    “或避县官，依倚吾道，求作沙门，不修戒律。月半、月尽，虽名诵戒，厌倦懈怠，不欲听闻。抄略前后，不肯尽说。经不诵习，设有读者，不识字句，为强言是，不咨明者。贡高求名，虚显雅步，以为荣冀，望人供养。
    “众魔比丘命终之后，精神当堕无择地狱。五逆罪中，饿鬼、畜生，靡不经历恒河沙劫。罪竟乃出，生在边国，无三宝处。
    “法欲灭时，女人精进，恒作福德。男子懈慢，不用法语。眼见沙门，如视粪土，无有信心。
    “法将殄没，当尔之时，诸天泣泪。水旱不调，五谷不熟。疫气流行，死亡者众。人民勤苦，县官克罚。不顺道理，皆思乐乱。恶人转多，如海中沙。善者甚少，若一若二。劫欲尽故，日月转促，人命转短，四十头白。男子淫佚，精尽夭命，或寿六十。男子寿短，女人寿长，七十、九十，或至百岁。大水忽起，卒至无期，世人不信，故为有常。众生杂类，不问豪贱，没溺流漂，鱼鳖食啖。
    “时有菩萨、辟支、罗汉，众魔驱逐，不预众会。三乘入山福德之地，恬泊自守，以为欣快，寿命延长，诸天卫护。月光出世，得相遭值。共兴吾道，五十二岁。《首楞严经》、《般舟三昧》先化灭去。十二部经，寻后化灭，尽不复现，不见文字。沙门袈裟，自然变白。吾法灭时，譬如油灯，临欲灭时，光更明盛，于是便灭。吾法灭时，亦如灯灭。自此之后，难可数说。
    “如是之后，数千万岁，弥勒当下世间作佛。天下泰平，毒气消除，雨润和适，五谷滋茂，树木长大。人长八丈，皆寿八万四千岁。众生得度，不可称计。”
    贤者阿难作礼白佛：“当何名斯经，云何奉持？”
    佛言：“阿难，此经名为《法灭尽》，宣告一切，宜令分别。功德无量，不可称计。”
    四部弟子，闻经悲惨惆怅，皆发无上圣真道意，悉为佛作礼而去。

据《乾隆大藏经》、《大正藏》校订


大集月藏经·法灭尽品

大集月藏经
法灭尽品

高齐天竺三藏那连提耶舍译

    尔时月藏菩萨摩诃萨，复从座起，整理衣服，偏袒右肩，合掌向于十方一切诸来菩萨摩诃萨众，口眼微笑。顾视月灯菩萨摩诃萨，而说偈言：

“观此希有慈悲士，释迦大仙尊导师，
今以此法甘露味，付嘱夜叉令护持。
普告一切作是言：‘我之正法汝当护，
一切声闻器非器(1)，当视如子护养育，
为我剃头着袈裟，勿令于后有恼害。
休息诸恶俭病疫，亦息非时风热雨，
如是三种精气(2)增，正法久住于世间，
众生不堕诸恶道，速能趣向大涅槃。’
我从昔来未见闻，慈悲希有余土无，
除佛更无余众生，能令正法久炽然。
诸佛慈悲慧无量，广持正法令久住，
导师灭后佛正法，炽然久住事希有。
此土不善烦恼山，坚固希有最难坏，
转正梵轮法眼住，悉令住善到涅槃。
此土极恶人与魔，夜叉修罗鸠槃荼，
彼等究竟灭烦恼，护持世尊真妙法。
以是因缘得最胜，能尽所作诸恶业，
彼勤供养于三宝，是故速能趣涅槃。
断除烦恼牟尼尊，世间自在大导师，
怜愍一切众生故，告令护持佛正法。”

    尔时月灯菩萨摩诃萨，闻月藏菩萨说是偈已，复说偈言：

“我欲问佛无边慧，法眼几时住于世？
如此佛月灭度后，烦恼痴诤闇世间。
云何贤圣复得集？当作何人方便护？
云何示世安隐道，能度三趣亿众生？”

    尔时一切诸来大众，向诸菩萨摩诃萨赞言：“善哉！善哉！”
    尔时月灯菩萨摩诃萨，从座而起，偏袒右肩，整理衣服，右膝着地，合掌向佛，头面作礼。以偈问曰：

“我今问佛无边慧，以我今有诸疑网。
以何因缘法眼灭？云何法灯久炽然？
谁能破坏此法鼓？谁能枯涸正法河？
云何法眼得久住？我当于彼助护持。
为以尸罗精进力？为以羼提禅般若？
为以何力法久住？唯愿速说何方便。
云何法水得久流，有多亿数助佛者？
我等精勤坚固行，为令法海不速竭，
大地精味常增长，及以众生法精味，
枯涸众生烦恼海，众生更不趣恶道。”

    尔时佛伸金色右臂，而说偈言：

“汝等共谛听，一切有为法，
无常火所烧，无有少常者。
譬如诸戏人，作诸种种戏，
如是等众生，皆为烦恼转。
犹如幻芭蕉，亦如水中月，
三界有为法，一切皆如是。
诸法我自觉，道成如先佛，
我今大众会，天人作证明，
正法付天神，护持众苦尽。
成于三界尊，能令法炽盛，
显现八正路，邪意恶觉灭。
沙门刹利王，激动相瞋恼，
我今当不久，涅槃灭无余。
大智诸声闻，亦随我涅槃。
余方诸佛国，一切诸菩萨，
具大神通者，复还向他方。
福德诸国王，大臣长者灭。
限满百年后，佛法渐隐没。
薄福众生等，于我法出家，
不乐于三乘，亦不畏后世，
活命故出家(3)，多诈无羞耻。
贪求诸名利，处处谄嫉妒，
远离于禅诵，复舍诸善法。
昼则乐言讼，夜则多睡眠，
乐读外杂典，舍离佛所说。
复与女人通，严饰身衣服，
为求名利故，但营世俗业。
常为他作使，通致诸信命(4)，
往返俗人家，贩卖以自活，
乐作诸田业，又复喜斗诤。
见诸善比丘，梵行多闻者，
嫉妒复瞋骂，不容彼坐卧。
而作粗犷语，诽谤及毁呰，
于诸俗人边，称扬不善事。
言‘此诈比丘，是贼最恶人，
若有供养者，多得恶名闻，
于彼不获福，亦莫信彼说。’
诸寺恶比丘，道说梵行者，
种种不善事，是以刹利(5)瞋。
彼诸恶比丘，杂以外文颂，
称赞彼刹利，能令刹利喜。
毗舍(6)婆罗门(7)，利喜亦如是，
以是得供养，持戒被欺凌。
刹利婆罗门，嫌恨持戒者，
嫌恨持戒故，致使诸天瞋，
弃舍彼国土。刹利辅相臣，
向于宝国土，在彼而安住。
轻贱持戒故，菩萨亦舍离。
诸天舍离后，其国大可畏，
恶龙恶夜叉，罗刹鸠槃荼，
入国夺精气，及食其肉血。
恶王婆罗门，毗舍首陀(8)等，
共护国城邑，及以诸村落。
宫舍国园林，恶鬼遍充满，
常夺彼精气，触恼诸刹利。
婆罗毗舍陀，男女等皆瞋，
复令心变恶，互共相斗诤。
彼等斗诤故，布萨(9)行檀(10)绝。
其国水枯涸，非时风雨起，
饥馑极俭短，乏少资生具。
果苗不成熟，地味众生味，
法味及精气，一切皆损减，
兴动诸兵仗，互共相劫夺。
如是悭贪国，恶比丘往返，
复以佛僧物，饮食诸果药，
持用与俗人，因此得供养。
奴婢及田宅，与彼令摄受，
不善比丘等，以之为尊长。
少智诈多闻，不喜禅戒者，
禅戒者去后，为财共斗诤。
刹利闻生瞋，打害恶比丘，
还俗舍法服，系闭于牢狱。
以是诸天瞋，迭共相告语，
如是国土中，旃陀罗(11)王治。
朋党恶比丘，毁破袈裟服，
自坏己国土，不久当败亡。
堕在阿鼻狱，受苦极长远，
于是贤劫中，无脱地狱时。
是旃陀罗王，众圣所厌贱，
听读檀尸法(12)，谄曲虚诈现，
是王多诈伪，速灭己国土。
苗稼不成熟，亢旱及水涝，
螽鼠恶象暴，自他国兵起。
曜入非常宿，大地普震动，
白虹妖星堕，时气多病疫，
焚烧诸聚落，速坏国城邑。
剃头着袈裟，诸佛所加护，
一人出家者，天人所供养。
唯除诸如来，无有自在者。
彼旃陀罗王，谪罚恶比丘，
毁坏三世佛，二种净法身，
烦恼疮深重，难得值诸佛。
诸天皆舍离，彼旃陀罗王，
如是国土坏，法眼当散灭。
诸天舍离故，如是国土坏，
三种精气减，毁灭天宫殿。
白法善朋少，黑法恶党增，
于彼浊恶世，无有明智人。
所住阿兰若(13)，乐法安隐住，
彼持我正法，能令多众信。
鬼神敬信故，遮障诸怖畏，
增长三精气，炽然我正法。
彼以禅定乐，充满天宫殿。
是故以我法，付诸鬼神王，
遮障恶刹利，莫恼我声闻。
国王于持戒，亲近常供养，
破戒不亲供，舍离各随住。
国王不恼彼，持戒及毁禁，
刹利净持戒，彼此皆信敬。
毗舍婆罗门，不恼诸天神，
正法得久住，白法常增长。
汝等于此土，随意而安住。
汝等若发心，此土常安住，
乃至我法尽，莫向诸余国，
以檀尸罗法，令多众归信，
智者能成熟，彼非是希有。
于彼恶世时，炽然我正法，
遮障恶刹利，此事为希有。
慈心常相应，莫打我声闻，
彼二说正法，能救地狱苦。
比丘不护戒，国王莫谪罚，
汝诸刹利王，莫共沙门斗。
俗人作诸恶，速趣于地狱。
软语向彼二，遮除诸恶业。
莫以粗犷语，亦莫打治罚，
以是国不坏，增长三精气，
正法得久住，佛法久炽然。
多有说法者，能闭三恶趣，
休息世间恶，增益诸天众。
涅槃门得开，无漏者则入，
菩萨得增长，犹如明分月，
能以于六度，充满诸佛法。
是故诸智者，所来诸菩萨，
当住于此土，炽然我正法。
盲冥失道者，当与正法眼，
众生以六度，成熟于菩提。
汝等则成供，三世诸如来，
速证菩提果，净国作导师。”

大众皆默然。唯有贤劫众，
弥勒为上首，一切皆悉起，
合掌而白佛，咸作如是言：
“我不诣余方，护持佛正法，
尽我精进力，成熟大菩提，
随于彼时中，应机而说法。
欲有留难时，我等不能遮，
法欲灭尽时，我亦不能遮。”

    尔时世尊，告彼自智童真菩萨摩诃萨，而说偈言：

“观此诸菩萨，勇猛执智炬，
无量阿僧祇，他方佛土来。
种种善根宝，归依诸佛海，
慈悲方便力，于佛法不动。
于此无有一，能持我法者。
贤劫诸菩萨，堪能持我法。
于我灭度后，佛法欲灭时，
所有出家者，而无有惭耻。
远离功德智，懈怠不精进，
舍道学世业，不乐持禁戒。
愚痴与俗交，多言复无羞，
贪取佛僧物，染着五欲乐。
如是比丘等，资生(14)与俗同，
疑惑多贪财，邪淫怒嫉妒。
见住兰若(15)者，说其诸过恶，
不乐读诵经，嗜睡多喜斗。
如是等沙门，厌贱禅兰若，
坚着于恶事，自高轻蔑他。
沙门及俗人，悭贪不舍施，
啖食佛僧物，多遭种种病，
无有慈愍心，少力恶喜斗。
以是天不雨，润泽悉枯涸，
饥馑遍世间，果实无滋味。
乏少于饮食，瞋诤相侵夺，
造十不善业，少福无供养。
法味不纯厚，行法心亦薄，
迭共作粗想，杀害无慈愍。
不孝于父母，亦不供尊长，
多修世俗行，疑惑复嫉妒。
贪染于邪法，非法无厌足，
贪求无厌故，是以久流转。
如是诸国王，及以辅相臣，
沙门婆罗门，毗舍首陀罗，
乐斗憎持戒，互共相谤毁。
南方边夷国，王名波罗帝，
百千诸军众，士将共围绕。
西方边夷国，有王名百祀，
亦将百千军，前后共围绕。
北方边夷王，名善意释迦，
士将诸营从，围绕亦百千。
东方睒弥国(16)，王名为大军，
眷属百千众，围绕而侍卫。
大军王有子，名之为难看(17)，
生时身着铠，把刀血涂身，
大力身坚固，而从母胎生。
是时长者等，大臣五百人，
同时俱生子，身亦着铠甲，
执刀血涂身，皆从母胎生。
是日于其国，天龙降血雨。
五百长者子，难看同处养，
难看年七岁，父王授其位。
边夷三恶王，又至北天竺，
破国杀害人，怨仇妒女色，
积财以火烧，瞋怒向中国(18)。
边夷王等来，毁破佛塔寺，
杀害诸众僧，劫夺佛僧物。
病瘦诸比丘，不能走逃避，
少壮强力者，散走于诸方。
诸余比丘等，少年初出家，
未善学戒者，威仪法不具。
处处走逃避，随至被欺凌，
毁辱而打骂，恒受诸苦恼。
彼三边夷王，及与诸军众，
渐诣拘睒弥，十二年中斗。
三王及眷属，难看王杀尽，
统领阎浮提，而作一盖王。
于后大悔恨：‘我获无量罪，
颇有明比丘，当于我忏悔？’
说言有三藏，父名为火施，
种姓常清净，是大婆罗门。
子名失师迦(19)，高才智勇博，
释子中大名，今住波梨国。
时王即遣使，请彼三藏来，
为王演正法，令王生敬信：
‘我于十二年，战斗大作罪，
三王及眷属，军众我杀尽。
我亦十二年，具设般遮会(20)，
普告阎浮提，释子皆来集。
所有诸比丘，住在阎浮提，
愿各悉来此，受我等供养。’
比丘等悉集，睒弥般遮会，
在路有饿死，或病在道傍，
中有遭水毒，或值贼虎伤，
或复坠山涧，比丘死无数。
余残到睒弥，威仪法则坏，
百千皆来集，设大般遮会。
初起般遮日，大云皆悉起，
普遍阎浮提，降澍于大雨。
时王甚欢喜：‘此是众僧力。’
比丘既集已，互共相借问：
‘颇见我和尚，及问阿阇梨，
知识诸等侣，同学何处去？
我今得来此，彼或道路亡。’
高声大悲哭，相恋而号啼。
失师三藏起，少时静默住，
比丘大号哭，惆怅不自抑。
王见彼号哭，晓谕亦不止，
时王自思惟：‘此有罗汉否？’
天神夜告王：‘还于彼梨弗，
善财长者子，名曰涷罗多(21)，
是大阿罗汉，恒在香山中，
三明解脱具(22)，而来安住此。
今于此大月，十五日布萨，
由此布萨故，百千众集会，
中有一三藏，复有阿罗汉。
于时诸天众，皆来听布萨，
今是最后集，当作无上护，
法幢当摧折，法炬当散灭，
法山欲崩颓，法海当枯涸，
八种功德水，最后当亦竭。’
比丘众声乱，三藏于时起，
高声言：‘寂静，谛听戒律仪。
所有诸释子，一切皆来集，
我于此众中，多闻到彼岸，
学戒犹不净，何况于余人？
若有一比丘，能持此禁戒，
威仪无缺者，今当为布萨。
若于毗尼戒，威仪无缺犯，
于此大众前，有者今当现。
为学戒律者，今当作布萨。’
罗汉涷罗多，即起狮子吼：
‘依如经中说，我学戒清净，
决定无有疑，布萨我当听，
如佛之所说，禁戒我善学。’
三藏有弟子，名曰鸯伽多，
惨恶即瞋骂，咄彼涷罗多：
‘经中未见汝，是学戒律者。
大德如是说，云何故违反？’
鸯伽瞋极盛，两手执大棒，
打杀阿罗汉，净戒可敬者。
诸善比丘等，大哭而号啼，
各各相瞋怒，毁破身衣服。
时有大夜叉，名目佉檀提，
于佛深生信，敬重佛正法，
即以金刚杵，杀害彼鸯伽。
由杀阿罗汉，无著涷罗多，
复有恶比丘，名曰鸡多罗，
两手亦执棒，复杀彼三藏。
比丘皆悉起，各各共相杀，
百千诸比丘，存活者无几。
是时须臾顷，大地普震动，
于其虚空中，出大恶音声。
四方起大恶，火攒数百千，
火幢大可畏，现住在虚空，
彗星及妖星，四方而流堕。
千亿诸天神，皆作如是言：
‘释迦所集法，今日当隐没！’
色界诸天子，一切欲界天，
正法隐没已，大声悲号哭。
见佛诸夜叉，堕地而宛转：
‘从今于世间，更无有佛法，
律仪木叉戒，一切悉空无。
闇冥遍世间，无救无归趣，
诸人等不久，无异于獐鹿。
法幢当摧折，法鼓声亦绝，
甘露门闭塞，法师亦丧亡。
法炬当散灭，法轮更不转，
正法桥破坏，法足不复行。
法水止不流，法河永枯涸，
法山欲崩颓，法海当复竭。’
住林阿兰若，所有诸天子，
于时大怖畏，悲号而自扑。
有诸魔眷属，邪见诸恶党，
歌舞皆欢喜，踊跃弄衣服：
‘释迦所说法，趣彼甘露者，
隐没是其宜，我法得炽盛！’
难看王既知，正法隐没已，
从初至后夜，出城往诣彼，
见诸比丘尸，堕地即闷绝。
良久乃得苏，而复更悲啼：
‘见杀阿罗汉，三藏失师迦，
无量比丘死，我亦不久活。’
收拾阿罗汉，别取三藏尸，
及诸比丘丧，种种而阇维。
余残在比丘，召唤集一处，
肴膳众美味，种种而供养。
复舍千万宝，一宝直百千，
以此众宝物，拟造五百寺。
一一诸比丘，各施百千物：
‘师等在此住，我等当养育，
为我说正法，我当至心听。’
一切皆默然，无有说法者。
其王三劝请，白诸比丘已，
亦皆默然住，一切无说者。
王白诸比丘：‘可不知法耶？’
语已袈裟白，染色不复现，
从床皆堕落，宛转在于地。
咸皆称佛告，佛法实隐没，
须发爪皆长，诸法亦忘失。
当时虚空中，大声震于地，
一切皆遍动，犹如水上轮。
城壁碎落下，屋宇悉圮坼，
树林根枝叶，花叶果药尽。
唯除净居天，欲界一切处，
七味三精气，损减无有余。
解脱诸善论，当时一切尽。
所生花果味，希少亦不美，
诸有井泉池，一切尽枯涸。
土地悉咸卤，剖裂成丘涧，
诸山皆焦然，天龙不降雨。
苗稼皆枯死，甘蔗劫贝药，
生者皆死尽，余草更不生。
雨土皆昏闇，日月不现明，
四方皆亢旱，数现诸恶瑞。
十善隐业道，贪瞋痴倍增，
众生于父母，视之如獐鹿。
众生及寿命，色力威乐减，
远离人天乐，皆悉堕恶道。
如是不善业，恶王恶比丘，
毁坏我正法，损减天人道。
诸天善神王，悲愍众生者，
弃此浊恶国，皆悉向余方。
先佛不作者，我今为众生，
弃舍身寿命，为增三精气。
悲愍众生故，舍寿第三分(23)，
令我法海满，洗浴诸天人。
过去诸如来，依寿而灭度，
彼于七日后，正法皆隐没。
今我涅槃后，正法五百年，
住在于世间，众生烦恼尽。
精进诸菩萨，得满于六度，
行者速能入，无漏安隐城。
像法住于世，限满一千年。
剃头着袈裟，持戒及毁禁，
天人所供养，常令无所乏，
如是供养彼，则为供养我。
若有为我法，归依而剃头，
身着袈裟衣，说彼是我子，
假使破禁戒，悉住不退地。
若有挝打彼，则为打我身，
若有骂辱彼，则为毁辱我，
是人心欲灭，正法大明灯。
故为器非器，舍寿第三分，
为众得安乐，饶益诸天人。
我昔行苦行，为诸众生故，
舍己自身乐，令法久炽然。
我昔舍身命，为诸病人故，
亦为贫众生，令法久炽然。
我昔为菩提，舍财及妻子，
宝象马车乘，令法久炽然。
我昔供诸佛，缘觉及声闻，
父母诸师长，令法久炽然。
为闻菩提故，无量阿僧祇，
备受种种苦，令法久炽然。
我修戒律仪，长夜常勤行，
十方佛为证，令法久炽然。
我昔常忍辱，忍诸恶众生，
为众除烦恼，令法久炽然。
我昔勤精进，坚固常伏他，
度脱诸众生，令法久炽然。
我修禅解脱(24)，无色三摩提(25)，
恒沙不可数，令法久炽然。
我昔为般若，住在于闲林，
演说无量论，令法久炽然。
我昔常怜愍，舍己身血肉，
及舍身支节，为增长法眼。
我愍恶众生，以慈而成熟，
安置于三乘，增长正法施。
我昔智方便，度脱诸恶见，
安置于正慧，法雨令不绝。
我昔以四摄，救度诸众生，
灭恶烦恼火，令四众久住。
我昔除外道，诸恶邪见网，
安置于正路，四众得供养。
我为彼舍命，慈愍度众生，
不令世间闇，而有所归趣。
如是于后时，欲令法不坏，
是故嘱法眼，饶益诸众生。
于我灭度后，菩萨向余方。
为欲不灭坏，一切贤圣法，
故我今说咒，令法久炽然。
金刚密无缺，解脱味所依，
所有十方佛，当与我说欲，
在此所来者，大众亦与欲。”

    尔时世尊，为令正法得久住故，说大陀罗尼咒：

    哆地夜他　阿婆牟寄　婆牟寄　质阇牟寄　佉啰牟寄　遮罗摩兮　阿兮　阿兮　达啰婆帝　摩呵地唎滞　悉耽婆罗兮　阇迦利　磨什婆隶　达啰牟驶　能伽咩　什婆隶　什婆啰　摩涅婆波　苏婆诃

    尔时世尊说此金刚坚固深密解脱味体陀罗尼句时，遍此三千大千世界，六种震动，天降花雨，一切乐器不鼓自鸣。诸来大众遍满大地，皆悉悲泣，流泪赞叹，而作是言：“释迦牟尼如来、应、正遍知，甚为奇特未曾有法，大悲具足，随彼众生为成熟故，安置显现未来法故，舍第三分寿。”
    说是语时，在会众生，依烦恼身者，心得敬信。尽虚空量诸众生等，未发无上菩提心者，皆悉发心。九十二那由他众生，得柔顺忍。八那由他众生，得首楞严三昧、圣灯三昧。十万诸夜叉，见四真谛。二千菩萨，得共行测量毗尼三昧。六十四百千阿修罗，得殊胜行那罗延三昧。八那由他百千诸天，得清净行三昧。三十那由他百千鸠槃荼，得胜幢上灯三昧。二十那由他百千诸龙，得不欺陵力行三昧。二万比丘，尽诸有漏，心得解脱。
    尔时智炬童真菩萨摩诃萨，白文殊师利菩萨摩诃萨言：“了知清净士，观此释迦牟尼如来，以大名称，充满十方诸佛国土。云何充满？谓释迦牟尼佛，从初发心求阿耨多罗三藐三菩提已来，于一切众生平等安置，以福田心，种种勤修而行布施，于一切菩萨道修最胜行。成熟一切诸众生故，发最胜愿，舍清净国，至此五浊众苦世界，于阿耨多罗三藐三菩提而成正觉。以大慈悲因缘力故，为无间业、诽谤正法、毁呰贤圣、一切不善恶业缠缚、十方一切清净佛土所弃众生，为诸烦恼之所缚者，成熟如是诸众生故，于此娑婆世界，求阿耨多罗三藐三菩提，于一切菩萨道修最胜行。是人今于五浊世界，于阿耨多罗三藐三菩提而成正觉。此无间业诸众生等，种种骂辱诽谤如来，轻贱毁呰，勤加逼恼。彼等以嫉妒因缘故，种种方便，心欲杀害。复以种种兵仗、刀箭、[矛+赞]鉾、钺斧、崩大石山、毒药、水火，复放狂象、狮子、虎豹、恶牛、恶狗，勤加害佛。尔时如来犹于彼等诸众生所，以大慈悲，哀怜覆护，逾于父母视其一子。于诸苦海，方便拔济。是以今佛释迦如来，于十方佛土，名称普闻。今复为此诸众生故，以一切法付嘱天、龙、诸鬼神等，为令法眼久住炽然。复为众生舍第三分寿，亦为法眼久住炽然。一切声闻器以非器，及诸剃头着袈裟者，为护持故，不恼害故，增长三精气故。以是释迦如来，于此十方一切佛土、一切如来、一切菩萨摩诃萨、一切大智诸天人所，极得名称，充满十方。是故一切诸来菩萨摩诃萨等，各各相与随力所堪，皆设第一最上供具，供养如来，尊重恭敬。”
    尔时一切诸来大众、菩萨摩诃萨等，从座而起，口眼微笑。彼诸菩萨，于此娑婆世界，遍雨种种宝供养具，供养世尊。有雨碎金，有雨碎银，有雨碎毗琉璃，有雨碎玻瓈，有雨赤真珠，有雨碎玛瑙，有雨碎砗磲，有雨龙蛇所爱重者碎栴檀香，有雨牛头栴檀香，有雨多摩罗跋香，有雨黑坚沉水香，有雨种种众妙宝花，有雨七宝盖、七宝幢、七宝幡、金缕、真珠、璎珞、环钏，有持劫波如意宝树，有持宝衣树，有持宝花树，有持宝器树，有持宝香树，供养世尊。复有菩萨，于娑婆土所有树林、花叶、果实、一切草木，变成七宝，而供养佛。复有菩萨，于娑婆土，一切所有山石、砖瓦，变成七宝，而供养佛。复有菩萨，于娑婆土，一切所有大地界分，变为微妙诸天宝香，而供养佛。一切众生依地住者，彼等七日七夜身心快乐，犹若诸天。复有菩萨，于娑婆土，一切所有大水界分，变为诸天第一微妙甘露，美味香洁醇具。水界众生，七日七夜身心快乐，犹若诸天。复有菩萨，以一切风，变为微妙清净香风，而供养佛。于三恶道所有众生，一切无余，香风触故，七日七夜身心快乐，犹若诸天。尔时上至阿迦腻吒天(26)，下至四天王身天(27)，及诸天女，一切无余，而以种种微妙音声，赞叹世尊。复以种种歌舞、音乐，而供养佛。一切夜叉，一切罗刹，一切鸠槃荼，一切乾闼婆，一切阿修罗，一切紧那罗、饿鬼、毗舍遮、富单那、迦吒富单那、人非人等，彼等一切，随力所堪，作种种赞叹，乃至种种供养世尊。
    尔时世尊，告上首弥勒，及贤劫中一切菩萨摩诃萨言：“诸善男子，我昔行菩萨道时，曾于过去诸佛如来，作是供养。以此善根，与我作于三菩提因。我今怜愍诸众生故，以此报果，分作三分。留一分自受。第二分者，于我灭后，与禅解脱三昧坚固相应声闻，令无所乏。第三分者，与彼破戒读诵经典相应声闻，正法、像法剃头着袈裟者，令无所乏。弥勒，我今复以三业相应诸声闻众、比丘、比丘尼、优婆塞、优婆夷，寄付汝手，勿令乏少，孤独而终。及以正法、像法毁破禁戒、着袈裟者，寄付汝手，勿令彼等，于诸资具，乏少而终，亦勿令有旃陀罗王，共相恼害，身心受苦。我今复以彼诸施主，寄付汝手，我今所有器以非器、为我出家而供养者，汝等亦当护持养育。
    “弥勒，若于现在，及未来世，读诵受持此法门者，彼等当得十种清净功德。何等为十？身清净故，离杀生、离偷盗、离邪行；口清净故，不妄语、不恶口、不两舌、不绮语；心清净故，离贪欲、离瞋恚、离邪见，是为十。从是已后，百千万生，常得如是十种清净功德。
    “若有至心听此法门者，是人住如实际，得于八种清净功德。何等为八？一者长寿，二者端正，三者富贵，四者名称，五者常为诸天守护，六者所须常无所乏，七者尽诸业障，八者命欲终时，有十方佛及诸大众，放大光明，照其眼目，令其人见，得生善处。于百千万生，常得如是八种功德。
    “我今更复略说是人当得十三种清净功德。何谓十三？一者生死流转终不更起颠倒恶见，二者不生五浊无佛国土，三者常得见佛，四者常闻正法，五者常得供养众僧，六者值善知识，七者常与六波罗蜜相应，八者不堕小乘，九者常以大慈大悲大方便力成熟众生，十者常发胜愿，十一者乃至菩提而常不离如上等法，十二者速能满足六波罗蜜，十三者于阿耨多罗三藐三菩提而成正觉。
    “若有受持、书写、读诵、为他解说、如说修行此月藏法门者，所得功德，如前所说。”
    作是语时，月藏菩萨摩诃萨、尊者阿若憍陈如，及于一切诸来大众，天、人、阿修罗、乾闼婆等一切众生，闻佛所说，皆悉欢喜，顶戴奉行。

    【注释】
    (1) 器：指堪能受持佛法的根器。非器：指不堪受持佛法的根器。
    (2) 三种精气：指大地精气、众生精气、正法精气，又称作“三精气”。
    (3) 活命故出家：由于世间生计无着，而被迫出家以求衣食。
    (4) 信命：书信、命令。
    (5) 刹利：即刹帝利。印度四种姓之一，担任国王、大臣等政治、军事职位，地位仅次于婆罗门。
    (6) 毗舍：又作吠舍，印度四种姓的第三等级，为从事商业贸易等活动的阶层。
    (7) 婆罗门：印度四姓中的最高阶层，从事经典的研习与教授，及祭祀等宗教活动。
    (8) 首陀：又作首陀罗，印度四种姓的第四等级，从事农业生产的阶层。
    (9) 布萨：出家比丘每半月集会说戒，若有犯戒者则于众前忏悔。
    (10) 行檀：布施。
    (11) 旃陀罗：位居第四种姓首陀罗之下，从事屠宰、渔猎等恶行的卑贱阶层。
    (12) 檀：即檀那，意为布施。尸：即尸罗，意为戒行。
    (13) 阿兰若：适于出家人修行的寂静空闲处。
    (14) 资生：指满足日常生活所需的衣食、住所、用具等。
    (15) 兰若：阿兰若的略称。
    (16) 睒弥国：即拘睒弥国，位于中印度。
    (17) 难看：《杂阿含经》卷第二十五译作“难当”。
    (18) 中国：指古代天竺地域。
    (19) 失师迦：《杂阿含经》卷第二十五译作“弟子”、“失沙”，《迦丁比丘说当来变经》译作“尸依仇”，《佛使比丘迦旃延说法没尽偈》译作“尸师”。
    (20) 般遮会：无遮大会。
    (21) 涷罗多：《杂阿含经》卷第二十五译作“修罗他”，《迦丁比丘说当来变经》译作“须陀流”（此言“日善”），《佛使比丘迦旃延说法没尽偈》译作“须赖”。
    (22) 三明：阿罗汉所证得的三种智慧神通，即宿命智证明、死生智证明、漏尽智证明，相当于六通中的宿命通、天眼通、漏尽通。具：圆满具足。
    (23) 舍寿第三分：即舍第三分寿。《大毗婆沙论》云：“若说诸佛舍第三分寿者，彼说世尊释迦牟尼寿量应住百二十岁，舍后四十，但受八十。”
    (24) 禅解脱：即色界四禅。
    (25) 无色三摩提：即无色界定。三摩提：三摩地、三昧。
    (26) 阿迦腻吒天：即色究竟天。色界十八天之一，五净居天之一。此天乃修最上品四禅者所生之处，其果报于色界中为最胜。
    (27) 四天王身天：即四天王天，住于须弥山腰。

据《乾隆大藏经》、《大正藏》校订

·清凉书屋校注·


杂阿含经卷第二十五

宋天竺三藏求那跋陀罗译

    尔时世尊告尊者阿难：“此摩偷罗国，将来世当有商人子，名曰掘多。掘多有子，名优波掘多，我灭度后百岁，当作佛事。于教授师中，最为第一。阿难，汝遥见彼青色丛林否？”
    阿难白佛：“唯然已见，世尊。”
    “阿难，是处名为优留曼茶山。如来灭后百岁，此山当有那吒跋置迦阿兰若处。此处随顺寂默，最为第一。”
    尔时世尊作是念：“我若以教法付嘱人者，恐我教法不得久住。若付嘱天者，恐我教法亦不得久住，世间人民则无有受法者。我今当以正法付嘱人、天。诸天、世人共摄受法者，我之教法则千岁不动。”
    尔时世尊起世俗心。时天帝释，及四大天王，知佛心念。来诣佛所，稽首礼足，退坐一面。
    尔时世尊告天帝释及四大天王：“如来不久，当于无余涅槃而般涅槃。我般涅槃后，汝等当护持正法。”
    尔时世尊复告东方天王：“汝当于东方护持正法。”
    次告南方、西方、北方天王：“汝当于北方护持正法。”
    “过千岁后，我教法灭时，当有非法(1)出于世间，十善悉坏。阎浮提中，恶风暴起，水雨不时，世多饥馑。雨则灾雹，江河消减，花果不成，人无光泽。虫村、鬼村悉皆磨灭。饮食失味，珍宝沉没，人民服食粗涩草木。
    “时有释迦王、耶槃那王、钵罗婆王、兜沙罗王，众多眷属。如来顶骨、佛牙、佛钵，安置东方。西方有王名钵罗婆，百千眷属，破坏塔寺，杀害比丘。北方有王名耶槃那，百千眷属，破坏塔寺，杀害比丘。南方有王名释迦，百千眷属，破坏塔寺，杀害比丘。东方有王，名兜沙罗，百千眷属，破坏塔寺，杀害比丘。四方尽乱，诸比丘来集中国(2)。
    “时拘睒弥国(3)有王名摩因陀罗西那。其王生子，手似血涂，身似甲胄，有大勇力。其生之日，五百大臣生五百子，皆类王子，血手胄身。时拘睒弥国一日雨血。拘睒弥王见此恶相，即大恐怖，请问相师。相师白王：‘王今生子，当王阎浮提，多杀害人。’生子七日，字曰难当(4)，年渐长大。
    “时四恶王，从四方来杀人民，摩因陀罗西那王闻则恐怖。时有天神告言：‘大王，且立难当为王，足能降伏彼四恶王。’时摩因陀罗西那王，受天神教，即舍位与子。以髻中明珠，冠其子首，集诸大臣，香水灌顶。召五百大臣同日生子，身被甲胄，从王出征，与四恶王大众战。胜，杀害都尽。王阎浮提，治在拘睒弥国。”
    尔时世尊告四大天王：“巴连弗国，于彼国当有婆罗门，名曰阿耆尼达多，通达《毗陀》经论。彼婆罗门当纳妻，后时中阴众生，当来与其作子，入母胎中。时彼母欲与人论议(5)。彼婆罗门即问诸相师。相师答云：‘是胎中众生，当了达一切论，故令母生如是论议之心，欲将人论议。’如是日月满足，出生母胎，以为童子，了达一切经论，恒以经论教授五百婆罗门子，及余诸论教授余人，以医方教医方者，如是有众多弟子。有众多弟子故，名曰弟子(6)。次当从父母求出家学道，乃至父母听其出家。彼即于我法中出家学道，通达三藏，善能说法，辩才巧妙，言语谈说，摄多眷属。”
    又复世尊告四大天王：“即此巴连弗邑国中，当有大商主，名曰须陀那。中阴众生来入母胎，彼众生入母胎时，令母质直柔和，无诸邪想，诸根寂静。时彼商主即问相师。相师答曰：‘胎中众生，极为良善，故令母如是，乃至诸根寂静。’至月满足，便生童子，名曰修罗他(7)。年纪渐长，乃至启白父母，求出家学道，父母即听于我法中出家学道。勤行精进，修习道业，便得漏尽，证阿罗汉果。然寡闻、少欲、知足及少知，旧居在山薮林间，山名揵陀摩罗。
    “时彼圣人，恒来为难当王说法。彼父王当无常，无常之日，难当见父过世，两手抱父尸，悲号啼哭，忧恼伤心。时彼三藏，将多眷属，来诣王所，为王说法。王闻法已，忧恼即止，于佛法中生大敬信，而发声唱言：‘自今以后，我施诸比丘无恐畏，适意为乐。’而问比丘：‘前四恶王，毁灭佛法，有几年岁？’诸比丘答云：‘经十二年。’王心念口言，作狮子吼：‘我当十二年中，当供养五众(8)。’乃至办诸供具，即便行施。行施之日，天当降香泽之雨，遍阎浮提，一切实种皆得增长。诸方人众，皆持供养，来诣拘睒弥国，供养众僧。
    “时诸比丘，大得供养。诸比丘辈，食人信施，而不读诵经书，不萨阇为人受经。戏论过日，眠卧终夜。贪著利养，好自严饰，身着妙服。离诸出要、寂静、出家、三菩提乐(9)。形类比丘，离沙门功德。是法中之大贼，助作末世。坏正法幢，建恶魔幢。灭正法炬，燃烦恼火。坏正法鼓，毁正法轮，消正法海，坏正法山，破正法城，拔正法树。毁禅定智慧，断戒璎珞，污染正道。
    “时彼天、龙、鬼、神、夜叉、乾闼婆等，于诸比丘所生恶意，毁訾诸比丘。厌恶远离，不复相亲。异口同音：‘呜呼！如是恶比丘，不应于如来法中。’而说偈言：

‘非吉行恶行，行诸邪见法，
此诸愚痴人，打坏正法山。
行诸恶戒法，弃诸如法行，
舍诸胜妙法，拔除今佛法。
不信不调伏，乐行诸恶行，
谄伪诳世间，打破牟尼法。
毁形习诸恶，凶暴及千行，
依法诳世人，忿恨自贡高。
贪著求名利，无恶业不备。
如佛所说法，法没有是相，
今者悉已见，智者所轻贱。
此法今出已，牟尼正法海，
不久当枯竭。正法今少在，
恶人复来灭，毁坏我正法。’

    “时彼诸天、龙、神等，皆生不欢喜心，不复当护诸比丘。而同声唱言：‘佛法却后七日灭尽！’号啕悲泣，共相谓言：‘至比丘说戒日，共相斗诤，如来正法于中而灭。’如是诸天，悲恼啼泣。
    “时拘睒弥城中，有五百优婆塞，闻诸天之言，共诣诸比丘众中，谏诸比丘斗诤。而说偈言：

‘呜呼苦剧岁，愍念群生生，
其法今便灭，释狮子王法。
恶轮坏法轮，如是尽金刚，
乃能不即坏。安隐时已灭，
危险法已起，明智人已过，
今见如是相，当知不复久。
牟尼法断灭，世间无复明，
离垢寂灭口，牟尼日今没。
世人失伏藏，善恶无差别，
善恶无差已，谁能得正觉？
法灯今在世，及时行诸善，
无量诸福田，此法今当灭。
是故我等辈，知财不坚牢，
及时取坚实。’

    “至十五日说戒时法当没，尔日五百优婆塞，一日之中造五百佛塔。时诸优婆塞各有余务，不复来往众僧众中。
    “尔时住揵陀摩罗山修罗他阿罗汉，观阎浮提，今日何处有众僧说戒。见有拘睒弥国，如来弟子说戒为布萨，即诣拘睒弥。
    “时彼僧众，乃有百千人。中唯有一阿罗汉，名曰修罗他。又复有一三藏，名曰弟子。此是如来最后大众集。尔时维那(10)行沙罗筹，白三藏上座言：‘众僧已集，有百千人，今为说波罗提木叉。’时彼上座答言：‘阎浮提如来弟子，皆来集此，数有百千。如是众中，我为上首，了达三藏，尚不学戒律。况复余者，而有所学？今当为谁，而说戒律？’而说偈言：

‘今是十五日，夜静月清明，
如是诸比丘，令集听说戒，
一切阎浮提，众僧最后集。
我是众中上，不学戒律法，
况复余僧众，而有所学习？
何能牟尼法，释迦狮子王，
彼戒谁有持，是人乃能说。’

    “尔时彼阿罗汉修罗他，立上座前，合掌白上座言：‘上座，但说波罗提木叉。如佛在世时，舍利弗、目揵连等大比丘众所学法，我今已悉学。如来虽灭度，于今已千岁，彼所制律仪，我悉已备足。’而说偈言：

‘上座听我语，我名修罗他，
漏尽阿罗汉，僧中狮子吼，
牟尼真弟子。’

信佛诸鬼神，闻彼圣所说，
悲哀泣流泪，低头念法灭：
‘从今去已后，无有说法者。
毗尼别解脱，不复在于世。
法桥今已坏，法水不复流，
法海已枯竭，法山已崩颓。
法会从今绝，法幢不复见。
法足不复行，律仪戒永没。
法灯不复照，法轮不复转，
闭塞甘露门，法师不在世。
善人说妙道，众生不识善，
不异于野兽。’

    “尔时佛母摩诃摩耶夫人，天上来下，诣诸众僧所，号啕啼泣：‘呜呼苦哉！是我之子经历阿僧祇劫，修诸苦行，不顾劳体，积德成佛。今者忽然消灭！’而说偈言：

‘我是佛亲母，我子积苦行，
经历无数劫，究竟成真道。
悲泣不自胜，念法忽磨灭，
呜呼智慧人，尔今何所在？
持法舍诤讼，从佛口所生，
诸王无上尊，真实佛弟子。
头陀修妙行，宿止林薮间，
如是真佛子，今为何所在？
今者于世间，无有诸威德，
旷野山林间，诸神寂无言。
施戒愍群生，信戒自庄严，
忍辱质直行，观察诸善恶。
如是诸胜法，今忽都已尽！’

    “尔时彼上座弟子，作是念言：‘彼修罗他比丘，自言如来所制戒律，我悉备持。’尔时上座，有弟子名曰安伽陀，起不忍之心，极生忿恨，从座起，骂辱彼圣：‘汝是下座比丘，愚痴无智，而毁辱我和尚(11)！’即持利刀，杀彼圣人。而说偈言：

‘我名安伽陀，失沙(12)之弟子，
利剑杀汝身，自谓我有德。’

    “尔时有一鬼，名曰大提木佉，作是念言：‘世间唯有此一阿罗汉，而为恶比丘弟子所害！’执持金刚利杵，杵头火燃，以此打破彼头，即便命终。而说偈言：

‘我是恶鬼神，名大提木佉，
以此金刚杵，破汝头七分！’

    “尔时阿罗汉弟子，见彼弟子杀害其师，忿恨不忍，即杀三藏。
    “尔时诸天、世人，悲哀啼泣：‘呜呼苦哉！如来正法，今便都尽。’寻即此大地六种震动，无量众生号啕啼泣，极为愁恼：‘呜呼！今日正法不复现世。’作是语已，各各离散。
    “尔时拘睒弥国五百优婆塞闻已，往诣寺中，举手拍头，高声大哭：‘呜呼！如来愍念世间，济诸群生，无有巨细，谁当为我说法义？今者人天解脱，不复可得！众生今日，犹在暗瞑，无有引导，长习诸恶，以此为欢，如诸野兽。不闻牟尼妙法，身坏命终，堕在三途，譬如流星。世人从今已后，无复念慧、寂静、三昧、十力妙法。’
    “尔时拘睒弥王，闻诸比丘杀真人阿罗汉，及三藏法师，心生悲恼，惋慨而坐。尔时诸邪见辈，诤竞打破塔庙，及害比丘，从是佛法索然顿灭。”
    尔时世尊语释提桓因、四大天王：“诸天、世人，于我灭度之后，法尽之相，如上所说。是故汝等今者不可不以勤力加于精进，护持正法，久令在世。”
    尔时诸天、世人，闻佛所说，各各悲颜，以手挥泪，顶礼佛足，各自退去。

    【注释】
    (1) 非法：与佛法相违的见解、行为。
    (2) 中国：指佛陀生前教化的古代天竺地域。
    (3) 拘睒弥国：又作憍赏弥国，位于中印度。
    (4) 难当：《大集月藏经·法灭尽品》译作“难看”。
    (5) 论议：与人举行辩论。
    (6) 弟子：《大集月藏经·法灭尽品》译作“失师迦”，《迦丁比丘说当来变经》译作“尸依仇”，《佛使比丘迦旃延说法没尽偈》译作“尸师”。
    (7) 修罗他：《大集月藏经·法灭尽品》译作“涷罗多”，《迦丁比丘说当来变经》译作“须陀流”（此言“日善”），《佛使比丘迦旃延说法没尽偈》译作“须赖”。
    (8) 五众：指出家五众，即比丘、比丘尼、式叉摩那、沙弥、沙弥尼。
    (9) 即出要乐、寂静乐、出家乐、三菩提乐四种法乐。出要：即出离。三菩提：即正智。
    (10) 维那：统管僧众事务之知事僧。
    (11) 和尚：即授戒师，此指会中三藏上座。
    (12) 失沙：即会中三藏上座，别经译作“失师迦”、“尸依仇”等，见上注。

据《乾隆大藏经》、《大正藏》校订

·清凉书屋校注·


佛临涅槃记法住经

唐三藏法师玄奘奉诏译

    如是我闻，一时薄伽梵(1)在拘尸城(2)力士生地(3)娑罗双林(4)，与无量无数声闻、菩萨摩诃萨俱，并诸天、人、阿素洛(5)等，一切大众，前后围绕。
    时薄伽梵临般涅槃，愍众生故，以慈软音告阿难曰：“吾今不久当般涅槃，一切有为无不悉舍，一切佛事皆已究竟。我已宣说离窟宅法、妙甘露法、最自在法、极安乐法。是法深妙，难解难知。不可寻思，超寻思境。诸大圣者，自内所证。我又三转无上法轮，其轮威猛，具十二相。诸余沙门，或婆罗门、天、魔、梵等，皆无有能如实转者。我已为诸天人吹大法螺，击大法鼓，觉悟长夜无明睡眠。我已为诸天人建大法幢，燃大法炬，普照一切，除灭暗冥。我已为诸有情作大法桥，为大法船，济渡一切暴流所溺。我已为诸有情注大法流，降大法雨，一切枯槁皆令润洽。我已开显解脱正路，引诸世间迷失道者。若诸有情我应度者，皆已度讫。诸未度者，皆亦为作得度因缘。我已降伏一切外道，我已摧灭一切邪论，我已倾覆诸魔宫殿，我已破坏一切魔军，正狮子吼，作大佛事，圆满丈夫本所誓愿。护持法眼，令无毁缺，化诸声闻，授菩萨记，为未来世无上佛眼，开照世间，常无断绝。阿难，汝等当于如是无上正法，勤加护持，令不灭没。阿难，我今更无所作，唯大涅槃，是所归趣。”
    尔时阿难闻佛语已，悲慕感绝，良久而言：“未审如来为诸有情三无数劫勤苦，所得无上正法，于佛灭后住世几时？饶益天、人、阿素洛等，当渐隐没。”
    尔时世尊，重以慈音告阿难曰：“诸佛化迹，法皆如是，勿复忧悲。无上正法于我灭后住世千年，饶益天、人、阿素洛等。从是已后，渐当隐没。
    “阿难当知，我涅槃后第一百年，吾圣教中圣法坚固。我诸弟子聪慧多闻，无畏辩才，能伏邪论，具大神力，于诸有情多所饶益。由是义故，天龙欢喜，勤加守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹。一百年末，有大国王名阿输迦(6)，出现于世，具大威力，王赡部洲。建窣堵波(7)，高广严饰，其数满足八万四千，供养吾身所留舍利。令无量众，见闻欢喜，皆树生天解脱之业。
    “我涅槃后第二百年，吾圣教中寂静坚固。我诸弟子聪慧多闻，如天人师，具大威德，多所饶益。以是义故，天龙欢喜，常加守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹。
    “我涅槃后第三百年，吾圣教中正行坚固。我诸弟子证慧解脱(8)、俱分解脱(9)、身证(10)，见至无量百千。由是多人得圣果故，天龙欢喜，常加守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹。
    我涅槃后第四百年，吾圣教中远离坚固。我诸弟子乐住空闲，勤修寂定。以是义故，天龙欢喜，常随守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹。
    “我涅槃后第五百年，吾圣教中法义坚固。我诸弟子爱乐正法，精勤修学，论议决择。由是义故，天龙欢喜，常勤守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹。
    “我涅槃后第六百年，吾圣教中法教坚固。我诸弟子多于教法精勤诵习，心无厌倦，能多饶益无量有情。以是义故，天龙欢喜，勤加守护。国王、大臣、长者、居士亦复如是，善识福田，于佛、法、僧深生净信，供养恭敬，尊重赞叹，然于义趣多有怀疑。
    “我涅槃后第七百年，吾圣教中利养坚固，天、龙、药叉(11)、阿素洛等，于佛、法、僧供养恭敬，尊重赞叹。我诸弟子多著利养、恭敬、名誉，于增上学戒、定、慧等不勤修习。
    “我涅槃后第八百年，吾圣教中乖争坚固。我诸弟子多相嫌嫉，结构恶人，尘坌讪谤。轻诃持戒，鄙贱多闻，不念六和，专思乖争，见不善巧。不敬师长，不正知住，欺诳谄曲，言词粗犷，如栴荼罗(12)。依附国王、大臣、长者，方便损费三宝财物，结恶朋党，折挫善人。
    “我涅槃后第九百年，吾圣教中事业坚固。我诸弟子多营俗业，耕种商估，通致使命，以自存活。于诸如来所制学处，慢缓毁犯。
    “我涅槃后第十百年，吾圣教中戏论坚固。我诸弟子多勤习学种种戏论，舍出世间诸佛正教，所谓契经、应颂、记别、讽诵、自说、缘起、譬喻、本事、本生、方广、希法及与论义(13)。精勤习诵世间戏论，所谓王论、贼论、战论、食论、饮论、衣论、乘论、我论、淫论、男论、女论、诸国土论、诸河海论、诸外道论，由乐此等种种戏论，令诸沙门、婆罗门等轻毁退失我之圣教。于我正法毗奈耶(14)中，当有如斯诸恶苾刍、苾刍尼等，不善修习身戒、心慧，更相忿争，谋毁诽谤，耽着妙好种种衣钵、房舍、敷具。由与诸恶徒党集会，虽经多年守护净戒，于须臾顷，悉皆毁犯。虽经多年集诸善本，由多忧恚，悉皆退失。以是因缘，天、龙等众，悲伤懊恼，舍不守护。国王、大臣、长者、居士，于三宝所不生净信，诽谤轻毁。由是因缘，令正法灭。
    “从是已后，诸苾刍等，造恶转深。国王、大臣、长者、居士，益不恭敬。三宝余势，犹未全灭。故于彼时，复有苾刍、苾刍尼等，少欲知足，护持禁戒，修行静虑，爱乐多闻，受持如来三藏教法，广为四众分别演说，利益安乐无量有情。复有国王、大臣、长者及居士等，爱惜正法，于三宝所供养恭敬，尊重赞叹，护持建立，无所顾恋。当知皆是不可思议诸菩萨等，以本愿力，生于此时，护持如来无上正法，与诸有情作大饶益。”
    尔时阿难、声闻、菩萨、天、龙、药叉、人非人等一切大众，闻薄伽梵悬记(15)当来法住时分、诸苾刍等行业差别，皆增悲叹，信受奉行。

    【注释】
    (1) 薄伽梵：意译作“世尊”，如来十号之一。
    (2) 拘尸城：又作拘尸那揭罗、拘夷那竭城、鸠尸那竭国等，古印度都城名。其城北熙连河侧的娑罗树林，为佛陀涅槃处。
    (3) 力士生地：拘尸城聚居着大力族人，其人力大无比，可敌千人。故拘尸城又称为力士城、力士生地。
    (4) 娑罗双林：释尊于拘尸城外将入涅槃时，其卧床四边各有同根娑罗树一双，故称此树林为娑罗双林、双树林。
    (5) 阿素洛：又作阿修罗。
    (6) 阿输迦：阿育王之名。
    (7) 窣堵波：塔的音译，此指佛舍利塔。
    (8) 慧解脱：七圣之一。由智慧力断除烦恼障而证得解脱的阿罗汉，但尚未得灭尽定，不具三明。
    (9) 俱分解脱：即俱解脱，七圣之一。由慧、定之力，断除烦恼、解脱二障而证得解脱的阿罗汉，已得灭尽定，三明具足。
    (10) 身证：七圣之一。已证得阿那含果位中的利根人，入灭尽定而证得与涅槃相近的寂静之乐。
    (11) 药叉：又作夜叉，天龙八部之一。
    (12) 栴荼罗：又作旃陀罗，地位在印度第四种姓首陀罗之下，从事屠宰、渔猎等恶行的贱民阶层。
    (13) 佛陀说法的十二种类别，即“十二部经”。
    (14) 毗奈耶：又作毗尼，“律”的音译。指佛所制定的有关比丘、比丘尼所应遵守的禁戒。
    (15) 悬记：对未来之事的预言。

据《乾隆大藏经》、《大正藏》校订

·清凉书屋校注·
2003.06


大般涅槃经·梵行品(节录)

大般涅槃经
梵行品（节录）

北凉天竺三藏昙无谶译

    迦叶复言：“世尊，我今始知菩萨摩诃萨不可思议，佛、法、众僧、《大涅槃经》及受持者、菩提、涅槃不可思议。世尊，无上佛法当久近住几时而灭？”
    “善男子，若《大涅槃经》乃至有是五行，所谓圣行、梵行、天行、病行、婴儿行，若我弟子有能受持、读诵、书写、演说其义，为诸众生之所恭敬、尊重、赞叹、种种供养，当知尔时佛法未灭。善男子，若《大涅槃经》具足流布，当尔之时我诸弟子多犯禁戒，造作众恶，不能敬信如是经典。以不信故，不能受持、读诵、书写、解说其义，不为众人之所恭敬，乃至供养。见受持者，轻毁诽谤：‘汝是六师，非佛弟子。’当知佛法将灭不久。”
    迦叶菩萨复白佛言：“世尊，我亲从佛闻如是义：迦叶佛法住世七日，然后灭尽。世尊，迦叶如来有是经否？如其有者，云何言灭？如其无者，云何说言《大涅槃经》是诸如来秘密之藏？”
    佛言：“善男子，我先说言唯有文殊师利乃解是义。今当重说，至心谛听。善男子，诸佛世尊有二种法：一者世法，二者第一义法。世法者则有坏灭，第一义法则不坏灭。复有二种：一者无常无我无乐无净，二者常乐我净。无常无我无乐无净则有坏灭，常乐我净则无坏灭。复有二种：一者二乘所持，二者菩萨所持。二乘所持则有坏灭，菩萨所持则无坏灭。复有二种：一者外，二者内。外法者则有坏灭，内法者则无坏灭。复有二种：一者有为，二者无为。有为之法则有坏灭，无为之法无有坏灭。复有二种：一者可得，二者不可得。可得之法则有坏灭，不可得者无有坏灭。复有二种：一者共法，二者不共法。共法坏灭，不共之法无有坏灭。复有二种：一者人中，二者天中。人中坏灭，天无坏灭。复有二种：一者十一部经，二者方等经。十一部经则有坏灭，方等经典无有坏灭。善男子，若我弟子受持、读诵、书写、解说方等经典，恭敬供养，尊重赞叹，当知尔时佛法不灭。
    “善男子，汝向所问迦叶如来有是经否者。善男子，《大涅槃经》悉是一切诸佛秘藏。何以故？诸佛虽有十一部经，不说佛性、不说如来常乐我净，诸佛世尊永不毕竟入于涅槃。是故此经名为如来秘密之藏，十二部经所不说故，故名为藏。如人七宝不出外用，名之为藏。善男子，是人所以藏积此物，为未来事故。何等未来事？所谓谷贵、贼来侵国、值遇恶王为用赎命、道路涩难、财难，得时乃当出用。善男子，诸佛如来秘密之藏，亦复如是。为未来世诸恶比丘畜不净物，为四众说：‘如来毕竟入于涅槃。’读诵世典，不敬佛经。如是等恶现于世时，如来为欲灭是诸恶，令得远离邪命利养，如来则为演说是经。若是经典秘密之藏灭不现时，当知尔时佛法则灭。善男子，《大涅槃经》常不变易，云何难言迦叶佛时有是经否？
    “善男子，迦叶佛时，所有众生贪欲微薄，智慧滋多。诸菩萨摩诃萨等调柔易化，有大威德，总持不忘，如大象王。世界清净，一切众生悉知如来终不毕竟入于涅槃，常住无变。虽有是典，不须演说。善男子，今世众生多诸烦恼，愚痴喜忘，无有智慧，多诸疑网，信根不立。世界不净，一切众生咸谓如来无常迁变，毕竟入于大般涅槃。是故如来演说是经。善男子，迦叶佛法实亦不灭。何以故？常不变故。
    “善男子，若有众生，我见无我，无我见我；常见无常，无常见常；乐见无乐，无乐见乐；净见不净，不净见净；灭见不灭，不灭见灭；罪见非罪，非罪见罪；轻罪见重，重罪见轻；乘见非乘，非乘见乘；道见非道，非道见道；实是菩提见非菩提，实非菩提谬见菩提；苦见非苦，集见非集，灭见非灭，实见非实；实是世谛见第一义谛，第一义谛见是世谛；归见非归，非归见归；以真佛语名为魔语，实是魔语以为佛语。如是之时，诸佛乃说《大涅槃经》。
    “善男子，宁说蚊觜尽大海底，不可说言如来法灭。宁言以索系缚猛风，不可说言如来法灭。宁说口吹须弥散坏，不可说言如来法灭。宁言佉陀罗火中生于莲华，不可说言如来法灭。宁说阿伽陀药而为毒药，不可说言如来法灭。宁说月可令热、日可令冷，不可说言如来法灭。宁说四大各舍己性，不可说言如来法灭。
    “善男子，若佛初出得阿耨多罗三藐三菩提已，未有弟子解甚深义，彼佛世尊便涅槃者，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，佛虽涅槃，当知是法久住于世。
    “复次善男子，若佛初出得阿耨多罗三藐三菩提已，虽有弟子解甚深义，无有笃信白衣檀越敬重佛法，佛便涅槃，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，多有笃信白衣檀越敬重佛法，佛虽涅槃，当知是法久住于世。
    “复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，虽有笃信白衣檀越敬重佛法，而诸弟子演说经法贪为利养，不为涅槃，佛复灭度，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，复有笃信白衣檀越敬重佛法，彼诸弟子凡所演说不贪利养，为求涅槃，佛虽灭度，当知是法久住于世。
    “复次善男子，若佛初出得阿耨多罗三藐三菩提已，虽有弟子解甚深义，复有笃信白衣檀越敬重佛法，而诸弟子多起诤讼，互相是非，佛复涅槃，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，复有笃信白衣檀越敬重佛法，彼诸弟子修和敬法，不相是非，互相尊重，佛虽涅槃，当知是法久住不灭。
    “复次善男子，若佛初出得阿耨多罗三藐三菩提已，虽有弟子解甚深义，复有笃信白衣檀越敬重佛法，彼诸弟子为大涅槃而演说法，互相恭敬，不起诤讼，然畜一切不净之物，复自赞言我得须陀洹果乃至阿罗汉果，佛复涅槃，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子解甚深义，复有笃信白衣檀越敬重佛法，彼诸弟子为大涅槃演说经法，善修和敬，互相尊重，不畜一切不净之物，亦不自言得须陀洹乃至得阿罗汉，彼佛世尊虽复灭度，当知是法久住于世。
    “复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子乃至不畜不净之物，又不自言得须陀洹至阿罗汉，各执所见，种种异说，而作是言：‘长老，诸佛所制四重之法，乃至七灭诤法，为众生故或遮或开。十二部经亦复如是。何以故？佛知国土时节各异，众生不同，利钝差别，是故如来或遮或开，有轻重说。善男子，譬如良医，为病服乳，为病遮乳，热病听服，冷病则遮。如来亦尔，观诸众生烦恼病根，亦开亦遮。长老，我亲从佛闻如是义，唯我知义，汝不能知。唯我解律，汝不能解。我知诸经，汝不能知。’彼佛复灭，当知是法不久住世。复次善男子，若佛初出得阿耨多罗三藐三菩提已，有诸弟子乃至不言我得须陀洹果至阿罗汉，亦不说言：‘诸佛世尊，为众生故，或遮或开。长老，我亲从佛闻如是义，如是法，如是律。长老，当依如来十二部经。此义若是，我当受持。如其非者，我当弃舍。’彼佛世尊虽复涅槃，当知是法久住于世。
    “善男子，我法灭时，有声闻弟子，或说有神，或说神空。或说有中阴，或说无中阴。或说有三世，或说无三世。或说有三乘，或说无三乘。或言一切有，或言一切无。或言众生有始有终，或言众生无始无终。或言十二因缘是有为法，或言因缘是无为法。或言如来有病苦行，或言如来无病苦行。或言如来不听比丘食十种肉，何等为十？人、蛇、象、马、驴、狗、狮子、猪、狐、猕猴，其余悉听；或言一切不听。或言比丘不作五事，何等为五？不卖生口、刀、酒、酪沙、胡麻油等，其余悉听。或言不听入五种舍，何等为五？屠儿、淫女、酒家、王宫、旃陀罗舍，余舍悉听。或言不听着憍奢耶衣，余一切听。或言如来听诸比丘受畜衣食卧具，其价各直十万两金；或言不听。或言涅槃常乐我净，或言涅槃直是结尽，更无别法名为涅槃。譬如织缕，名之为衣，衣既坏已，名之无衣。实无别法，名无衣也。涅槃之体，亦复如是。善男子，当尔之时，我诸弟子，正说者少，邪说者多。受正法少，受邪法多。受佛语少，受魔语多。
    “善男子，尔时拘睒弥国有二弟子，一者罗汉，二者破戒。破戒徒众，凡有五百。罗汉徒众，其数一百。破戒者说：‘如来毕竟入于涅槃。我亲从佛闻如是义：如来所制四重之法，若持亦可，犯亦无罪。我今亦得阿罗汉果、四无碍智，而阿罗汉亦犯如是四重之法。四重之法若是实罪，阿罗汉者终不应犯。如来在世，制言坚持。临涅槃时，悉皆放舍。’时阿罗汉比丘言：‘长老，汝不应说如来毕竟入于涅槃，我知如来常不变易。如来在世，及涅槃后，犯四重禁，罪无差别。若言罗汉犯四重禁，是义不然。何以故？须陀洹人尚不犯禁，况阿罗汉？若长老言我是罗汉。阿罗汉者，终不生想我得罗汉。阿罗汉者，唯说善法，不说不善。长老所说，纯是非法。若有得见十二部经，定知长老非阿罗汉。’善男子，尔时破戒比丘徒众，即共断是阿罗汉命。善男子，是时魔王，因是二众忿恚之心，悉共害是六百比丘。尔时凡夫各共说言：‘哀哉！佛法于是灭尽。’而我正法实不灭也。尔时其国有十二万诸大菩萨，善持我法，云何当言我法灭耶？
    “当于尔时，阎浮提内，无一比丘为我弟子。尔时波旬悉以大火焚烧一切所有经典。其中或有遗余在者，诸婆罗门即共偷取，处处采拾，安置己典。以是义故，诸小菩萨，佛未出时，率共信受婆罗门语。诸婆罗门虽作是说：‘我有斋戒。’而诸外道真实无也。诸外道等，虽复说言有我乐净，而实不解我乐净义，直以佛法一字二字，一句二句，说言我典有如是义。”
    尔时拘尸那城娑罗双树间，无量无边阿僧祇众，闻是语已，悉共唱言：“世间虚空！世间虚空！”
    迦叶菩萨告诸大众：“汝等且莫忧愁啼哭。世间不空，如来常住，无有变易。法、僧亦尔。”
    尔时大众闻是语已，啼哭即止，悉发阿耨多罗三藐三菩提心。

据《乾隆大藏经》、《大正藏》校订


佛垂涅槃略说教诫经

姚秦三藏法师鸠摩罗什译

    释迦牟尼佛，初转法轮，度阿若憍陈如。最后说法，度须跋陀罗。所应度者，皆已度讫。于娑罗双树间，将入涅槃。是时中夜，寂然无声。为诸弟子，略说法要：
    “汝等比丘，于我灭后，当尊重珍敬波罗提木叉。如暗遇明，贫人得宝。当知此则是汝等大师，若我住世，无异此也。持净戒者，不得贩卖贸易，安置田宅，畜养人民、奴婢、畜生。一切种植及诸财宝，皆当远离，如避火坑。不得斩伐草木，垦土掘地。合和汤药，占相吉凶，仰观星宿，推步盈虚，历数算计，皆所不应。节身时食，清净自活。不得参预世事，通致使命。咒术仙药，结好贵人，亲厚媟慢，皆不应作。当自端心，正念求度。不得包藏瑕疵，显异惑众。于四供养，知量知足。趣得供事，不应畜积。此则略说持戒之相。戒是正顺解脱之本，故名波罗提木叉。因依此戒，得生诸禅定，及灭苦智慧。是故比丘，当持净戒，勿令毁缺。若人能持净戒，是则能有善法。若无净戒，诸善功德皆不得生。是以当知，戒为第一安隐功德住处。
    “汝等比丘，已能住戒，当制五根，勿令放逸入于五欲。譬如牧牛之人，执杖视之，不令纵逸犯人苗稼。若纵五根，非唯五欲，将无涯畔，不可制也。亦如恶马不以辔制，将当牵人坠于坑坎。如被劫贼，苦止一世。五根贼祸，殃及累世。为害甚重，不可不慎。是故智者制而不随，持之如贼，不令纵逸。假令纵之，皆亦不久见其磨灭。此五根者，心为其主，是故汝等当好制心。心之可畏，甚于毒蛇、恶兽、怨贼、大火越逸，未足喻也。譬如有人，手执蜜器，动转轻躁，但观于蜜，不见深坑。譬如狂象无钩，猿猴得树，腾跃踔踯，难可禁制。当急挫之，无令放逸。纵此心者，丧人善事。制之一处，无事不办。是故比丘，当勤精进，折伏汝心。
    “汝等比丘，受诸饮食，当如服药。于好于恶，勿生增减。趣得支身，以除饥渴。如蜂采华，但取其味，不损色香。比丘亦尔，受人供养，趣自除恼。无得多求，坏其善心。譬如智者，筹量牛力所堪多少，不令过分以竭其力。
    “汝等比丘，昼则勤心修习善法，无令失时。初夜、后夜，亦勿有废。中夜诵经，以自消息。无以睡眠因缘，令一生空过，无所得也。当念无常之火，烧诸世间。早求自度，勿睡眠也。诸烦恼贼，常伺杀人，甚于怨家。安可睡眠，不自警寤？烦恼毒蛇，睡在汝心，譬如黑蚖，在汝室睡。当以持戒之钩，早摒除之。睡蛇既出，乃可安眠。不出而眠，是无惭人。惭耻之服，于诸庄严，最为第一。惭如铁钩，能制人非法。是故常当惭耻，无得暂替。若离惭耻，则失诸功德。有愧之人，则有善法。若无愧者，与诸禽兽无相异也。
    “汝等比丘，若有人来，节节支解。当自摄心，无令瞋恨。亦当护口，勿出恶言。若纵恚心，则自妨道，失功德利。忍之为德，持戒、苦行所不能及。能行忍者，乃可名为有力大人。若其不能欢喜忍受恶骂之毒，如饮甘露者，不名入道智慧人也。所以者何？瞋恚之害，则破诸善法，坏好名闻。今世后世，人不喜见。当知瞋心，甚于猛火，常当防护，无令得入。劫功德贼，无过瞋恚。白衣受欲非行道人，无法自制，瞋犹可恕。出家行道无欲之人，而怀瞋恚，甚不可也。譬如清冷云中，霹雳起火，非所应也。
    “汝等比丘，当自摩头，已舍饰好，着坏色衣，执持应器，以乞自活。自见如是，若起骄慢，当疾灭之。增长骄慢，尚非世俗白衣所宜。何况出家入道之人，为解脱故，自降其身而行乞耶？
    “汝等比丘，谄曲之心，与道相违，是故宜应质直其心。当知谄曲，但为欺诳。入道之人，则无是处。是故汝等宜当端心，以质直为本。
    “汝等比丘，当知多欲之人，多求利故，苦恼亦多。少欲之人，无求无欲，则无此患。直尔少欲，尚宜修习，何况少欲能生诸功德。少欲之人，则无谄曲以求人意，亦复不为诸根所牵。行少欲者，心则坦然，无所忧畏。触事有余，常无不足。有少欲者，则有涅槃。是名少欲。
    “汝等比丘，若欲脱诸苦恼，当观知足。知足之法，即是富乐安隐之处。知足之人，虽卧地上，犹为安乐。不知足者，虽处天堂，亦不称意。不知足者，虽富而贫。知足之人，虽贫而富。不知足者，常为五欲所牵，为知足者之所怜愍。是名知足。
    “汝等比丘，欲求寂静无为安乐，当离愦闹，独处闲居。静处之人，帝释诸天所共敬重。是故当舍己众、他众，空闲独处，思灭苦本。若乐众者，则受众恼，譬如大树，众鸟集之，则有枯折之患。世间缚著，没于众苦，譬如老象溺泥，不能自出。是名远离。
    “汝等比丘，若勤精进，则事无难者，是故汝等当勤精进。譬如小水长流，则能穿石。若行者之心，数数懈废，譬如钻火，未热而息，虽欲得火，火难可得。是名精进。
    “汝等比丘，求善知识，求善护助，无如不忘念。若有不忘念者，诸烦恼贼则不能入。是故汝等，常当摄念在心。若失念者，则失诸功德。若念力坚强，虽入五欲贼中，不为所害。譬如着铠入阵，则无所畏。是名不忘念。
    “汝等比丘，若摄心者，心则在定。心在定故，能知世间生灭法相。是故汝等，常当精勤修习诸定。若得定者，心则不散。譬如惜水之家，善治堤塘。行者亦尔，为智慧水故，善修禅定，令不漏失。是名为定。
    “汝等比丘，若有智慧，则无贪著，常自省察，不令有失。是则于我法中，能得解脱。若不尔者，既非道人，又非白衣，无所名也。实智慧者，则是度老、病、死海坚牢船也，亦是无明黑暗大明灯也，一切病者之良药也，伐烦恼树之利斧也。是故汝等，当以闻、思、修慧而自增益。若人有智慧之照，虽无天眼，而是明见人也。是名智慧。
    “汝等比丘，种种戏论，其心则乱。虽复出家，犹未得脱。是故比丘，当急舍离乱心戏论。若汝欲得寂灭乐者，唯当善灭戏论之患。是名不戏论。
    “汝等比丘，于诸功德，常当一心，舍诸放逸，如离怨贼。大悲世尊所说利益，皆已究竟，汝等但当勤而行之。若于山间，若空泽中，若在树下，闲处静室，念所受法，勿令忘失。常当自勉，精进修之，无为空死，后致有悔。我如良医，知病说药，服与不服，非医咎也。又如善导，导人善道，闻之不行，非导过也。
    “汝等若于苦等四谛有所疑者，可疾问之。毋得怀疑，不求决也。”
    尔时世尊如是三唱，人无问者。所以者何？众无疑故。
    时阿[少/兔]楼驮，观察众心，而白佛言：“世尊，月可令热，日可令冷，佛说四谛不可令异。佛说苦谛实苦，不可令乐；集真是因，更无异因；苦若灭者，即是因灭，因灭故果灭；灭苦之道，实是真道，更无余道。世尊，是诸比丘，于四谛中，决定无疑。于此众中，所作未办者，见佛灭度，当有悲感。若有初入法者，闻佛所说，即皆得度。譬如夜见电光，即得见道。若所作已办，已度苦海者，但作是念：‘世尊灭度一何疾哉！’”
    阿[少/兔]楼驮虽说此语，众中皆悉了达四圣谛义。
    世尊欲令此诸大众皆得坚固，以大悲心，复为众说：“汝等比丘，勿怀悲恼。若我住世一劫，会亦当灭。会而不离，终不可得。自利利他，法皆具足。若我久住，更无所益。应可度者，若天上、人间，皆悉已度。其未度者，皆亦已作得度因缘。自今以后，我诸弟子展转行之，则是如来法身常在而不灭也。
    “是故当知，世皆无常，会必有离，勿怀忧恼，世相如是。当勤精进，早求解脱，以智慧明，灭诸痴暗。世实危脆，无坚牢者。我今得灭，如除恶病。此是应舍罪恶之物，假名为身，没在老病生死大海。何有智者得除灭之，如杀怨贼而不欢喜？
    “汝等比丘！常当一心，勤求出道。一切世间动、不动法，皆是败坏不安之相。汝等且止，勿得复语。时将欲过，我欲灭度，是我最后之所教诲。”

据蕅益大师《佛遗教经解》校订


摩诃摩耶经卷下

箫齐沙门释昙景译

    尔时世尊，为波斯匿王，及诸大众，说妙法已。与比丘众，前后围绕，从舍卫国，渐次游行村邑聚落。所应度者，皆悉周遍。乃至到于尼连禅河。
    于时世尊，既至河已，着于浴衣，入河洗浴。时无量百千天、龙、夜叉、乾闼婆、阿修罗、迦楼罗、紧那罗、摩睺罗伽、人非人等，既见如来在河澡浴，各持种种涂香、末香而来供养。时尼连禅河侧，水、陆、虚空一切众生，见如来身犹如明镜，睹妙形像，皆生欢喜，悉起慈心，三毒消伏，不相吞食，咸发阿耨多罗三藐三菩提心。
    尔时阿难即白佛言：“今此水、陆、虚空之中诸众生等，见佛身已，尚生欢喜，发菩提心。而提婆达多，生在释宫，佛之亲属，又作沙门，口常读诵深妙经典。而于如来恒造逆事，破和合僧，出佛身血。教阿阇世，杀害父王。日日招集，丰美饮食。而自骄慢，谓与佛等。为小利养，以火自烧。设令诸佛欲救拔之，不能为益。如骡怀妊，会丧身命。”
    尔时世尊告阿难言：“如汝所说，提婆达多恒于我所生怨害心，自造阿鼻地狱因缘，一切诸佛不能救脱。我于提婆达多，极生慈愍。但其不久，苦业所逼。”
    时提婆达多在佛左右，闻此语已，心大瞋恚。即舍于佛，与其弟子往摩竭提国，投阿阇世。而于中路，有诸群鸟，急声鸣唤，翻飞乱扰。又逢恶牛，欲触蹈之。其诸弟子见此相已，而语之言：“我等今者观此诸瑞，非为吉祥。若所往处，必无利益。”提婆达多而答之言：“汝等愚痴，何所知耶？但急随我，不须多云。”既至摩竭提国，语守门者：“汝入白王，道我在此。”时守门人即入白王。阿阇世王闻提婆达多来在外已，心大瞋忿，而作是言：“乃至不欲闻其名字，何况而应眼见之耶！譬如雨雹，摧折草木，在地不久还自消散。如此恶人亦复如是，教人行恶，坏他善根，复还自败善根种子。”敕守门者勿听其前。
    时提婆达多见阿阇世王不许前已，心大苦恼，举手拍头，切齿骂詈。时郁波罗比丘尼从王宫出，而于门外见提婆达多，即呵之言：“汝令释种不得炽盛，于佛法中作大留碍。”时提婆达多闻此语已，极大忿恚，即以手拳而打其头，彼比丘尼寻便命终。提婆达多又害罗汉比丘尼故，地即开裂，有大猛火缠绕其身，牵入地狱。
    尔时世尊澡浴讫已，向诸比丘而说偈言：

    “譬如行恶道，登涉长忧怖，
    若到平坦处，安隐无愁患。
    生死险隘路，众生恒恐怖，
    唯有涅槃道，行者获安隐，
    我今欲至彼，功德常乐处。”

    尔时世尊说此偈已，与阿难俱至王舍城，为众比丘广说诸法。渐次到巴连弗邑，为诸人民、长者、居士及梵志等广说诸法。渐次复到毗耶离城，为众离车及奈女等广演诸法。
    尔时世尊举身疾生，处处皆痛。即便顾语尊者阿难：“我于今者身体皆痛，唯欲舍此朽故之身。阿难当知，若比丘、比丘尼得四神足，则能住寿一劫在世、若减一劫。况复如来，所欲自在。”
    是时阿难，魔所蔽故，默然无答。乃至再三，亦皆默然。
    尔时世尊语阿难言：“汝今可往别一树下，专精思惟，正观诸法。”
    时魔波旬，即来佛所，稽首礼足，而白佛言：“我于往昔劝请世尊入于涅槃，于时世尊而答我言：‘我诸弟子比丘、比丘尼、优婆塞、优婆夷未具足故，所以未应入于涅槃。’世尊今者诸四部众皆悉具足，所度已毕。唯愿善逝，速入涅槃！”
    尔时世尊即答魔言：“善哉波旬！当知如来却后三月入于涅槃。”
    时魔波旬见佛许已，欢喜踊跃，不能自胜，顶礼佛足，还归天宫。
    尔时如来既许天魔，却后三月当入涅槃，即便舍于无量之寿。以神通力故，住命三月。于时大地六种震动，日无精光，风雨违常。天龙八部莫不骇怖，来至佛所，畟塞空中。
    时尊者阿难见此相已，心惊毛竖，疾诣佛所，而白佛言：“今者何缘，忽有此相？”
    佛告阿难：“恶魔波旬向来我所，劝请于我，令入涅槃。我已许之，即便舍寿。以神力故，住命三月。”
    阿难白佛言：“世尊常说四神足人则能住寿一劫住世、若减一劫，随意自在。云何如来不久住世，同于诸行？”
    于时如来答阿难言：“我向为汝说如此语，魔蔽汝故，不知请住。我已许之，云何住寿？阿难当知，一切诸行，法皆如是，不得常存。”
    尔时阿难闻佛此语，迷闷懊恼，不能自胜。悲号啼泣，深追悔责。
    尔时世尊与阿难俱，渐次游行，到诸国界，村邑聚落，广说诸法。所可化度，不可称计。渐次复到鸠尸那竭国力士生地，熙连河侧，娑罗双树间。而语阿难：“可安绳床，而令北首。我今身体，极大苦痛。入于中夜，当取涅槃。”阿难受教，施绳床已。佛即就卧，右胁着地。
    尔时阿难见佛卧已，隐于佛后，悲泣流泪，极大苦恼。
    世尊即便问诸比丘：“阿难今者为在何许？”
    诸比丘言：“近在于后，垂泪忧恼。”
    如来即以大慈梵音告阿难言：“汝今不应犹如婴儿，而自啼泣。所以者何？生死之中，皆悉如此。但当专念，思惟诸法。汝从往昔看侍我来，身口意业极为纯善，未曾见汝有毫过失。今者宜应勤求解脱，忍割悲心，勿自煎恼。”
    尔时阿难而白佛言：“如来入于般涅槃后，阇维之法，当云何耶？”
    佛告阿难：“阇维之法，如转轮圣王。取于千端新净之毡，用缠佛身，香油洒灌，内金棺中。又以金棺，内银棺中。又以银棺，内铜棺中。又以铜棺，内铁棺中。积众香薪，而用阇维。收拾舍利，起立塔庙，表刹幡盖，种种供养。”
    尔时世尊告阿难言：“汝今入城告诸力士，道我在此夜入涅槃。若欲来者，宜自知时。”
    阿难受敕，即便入城。街巷道路，高声唱言：“三界大师如来应供，今近在于双树之间，当于中夜而取涅槃。诸人若欲礼拜供养，并欲咨决，宜知是时！”
    时诸力士闻此语已，皆大懊恼，问阿难言：“世尊灭度一何驶哉！我等从今，无所依怙。”涕泪沿路往诣佛所。
    时熙连河侧娑罗双树，周匝纵广四百八十里。天龙八部充塞盈满，间无空缺，莫不恋慕，悲号苦恼，咸言：“世间失于慈父！”各相谓言：“我等从今方沦生死，谁拔济者？”
    尔时城中，有一梵志，名须跋陀罗，年百二十岁。闻佛近在双树之间，当于中夜而入涅槃，即往佛所，白阿难言：“我闻如来一切智者，当于中夜而入涅槃。欲少决疑，唯愿听前。”
    是时阿难心自念言：“今此梵志，久习异见，必于今者与佛论议。世尊身痛，而作扰乱。”即便默然，不听许之。乃至三请，亦复如是。
    尔时世尊天耳遥闻，语阿难言：“汝可听是老梵志前，此则是吾最后弟子。”
    须跋陀罗既见佛已，欢喜踊跃，头面作礼。尔时世尊随应为说八正道法。即于座上，得罗汉果。而白佛言：“生死苦海，已蒙得过。不忍当见大师涅槃。我今当先而取灭度。”即于佛前，入般涅槃。
    尔时世尊，为诸八部一切大众，说妙法已。既至中夜，涅槃时到，而说偈言：

    “我于诸众生，应度缘今毕，
    夜静气恬和，涅槃时已到。”

    尔时世尊说此偈已，即入初禅。入初禅已，复入二禅。入二禅已，次入三禅。入三禅已，次入四禅。入四禅已，次入空处。入空处已，次入识处。入识处已，次入无所有处。入无所有处已，次入非想非非想处。入非想非非想处已，次入灭尽正受。
    时会大众，既见如来诸根不动，即便问于阿那律言：“世尊今者，入涅槃未？”
    时阿那律语诸人言：“世尊今入灭尽正受。”
    尔时如来出灭尽正受，还入非想非非想处。出非想非非想处，还入无所有处。出无所有处，还入识处。出于识处，还入空处。出于空处，还入四禅。出于四禅，还入三禅。出于三禅，还入二禅。出于二禅，还入初禅。即于初禅，还入二禅。出于二禅，而入三禅。出于三禅，而入四禅。出于四禅，而入空处。出于空处，而入识处。出于识处，入无所有处。出于无所有处，入非想非非想处。出非想非非想处，入灭尽正受。则于彼处，而般涅槃。
    当于尔时，大地震动。天龙八部，悲泣骚扰。
    时天帝释，及梵天王，而说偈言：

    “生死无真实，虚诳诸众生，
    今者牟尼尊，弃之犹涕唾。”

    时诸众生共相谓言：“如来灭度，何其驶哉！三界牢狱，谁为解脱？”其中或有宛转于地，或有牵绝衣服、璎珞，或拔头发，捶胸大叫。
    尔时阿难即便入城，普告力士：“如来昨夜已入涅槃，汝等宜应供养、阇维。”
    诸力士等闻此语已，心大苦痛，皆悉相随至双树所。既见世尊已般涅槃，闷绝震恸，不能自胜。即问阿难：“我等不知云何阇维如来之身。”
    阿难答言：“我于昨日已咨问佛。世尊遗敕，令如转轮圣王阇维之法。”阿难具为次第说之。
    诸力士众闻此语已，即便严办供养之具，事事皆依阿难所说，如转轮圣王棺殡之法。
    尔时摩耶，即于天上，见五衰相：一者头上华萎，二者腋下汗出，三者顶中光灭，四者两目数瞬，五者不乐本座。又于其夜，得五大恶梦：一梦须弥山崩，四海水竭。二梦有诸罗刹手执利刀，竞挑一切众生之眼。时有黑风，吹诸罗刹，皆悉奔驰，归于雪山。三梦欲、色界诸天，忽失宝冠，自绝璎珞，不安本座，身无光明，犹如聚墨。四梦如意珠王在高幢上，恒雨珍宝，周给一切。有四毒龙，口中吐火，吹倒彼幢，吸如意珠，猛疾恶风，吹没深渊。五梦有五狮子从空来下，啮摩诃摩耶乳，入于左胁，身心疼痛，如被刀剑。
    时摩诃摩耶见此梦已，即便惊寤，而作是言：“我于向者眠寝之中，忽然见此非吉祥事，令我身心极为愁苦。往昔在于白净王宫，因昼寝中，得希有梦。见一天子，身黄金色，乘白象王，从诸天子作妙妓乐。贯日之精，入我右胁，身心安乐，无有痛恼。即便怀妊悉达太子，光显宗族，为世照明。今此五梦甚可怖畏，必是我子释迦如来入般涅槃之恶相也。”即便向余诸天子等，广说梦中所见诸事。
    尔时尊者阿那律，既见棺殡如来身已，即便升于忉利天上，往摩诃摩耶所，而说是偈：

    “大师最胜天中天，善导一切世间者，
    今已为彼无常海，摩竭大鱼之所吞。
    在于鸠尸那竭国，娑罗林中双树间，
    不久当出城东门，种种供养而阇维，
    天人八部众盈满，号泣震动彻三千。”

    时阿那律说此偈已，即便还下如来棺所。
    尔时摩诃摩耶，闻阿那律说此偈已，闷绝躄地。诸天女等以冷水洒，良久乃苏。自拔头发，绝庄严具，悲泣垂泪，而作此言：“我于昨夜得五恶梦，决定当知佛入涅槃。今者果见阿那律来，云已灭度，在双树间，不久便应而就阇维。何其苦哉！世间眼灭。何其疾哉！人天福尽。昔日在于白净王宫，始生七日，我便命终，竟未抱育，展母子情。付嘱摩诃波阇波提，令其姨母而乳养之。及已长大，年至十九，便于中夜逾城而出，举宫内外莫不悲恼。既成道已，开世慧眼，覆护一切，犹若慈父。如何一旦便入涅槃？无常恶贼，极为凶暴，忍能害我正觉之子！”即于众中而说偈言：

    “于无量劫来，常共为母子，
    汝既成正觉，此缘方永断，
    而复于今者，便入般涅槃！
    譬如高大树，众鸟依共栖，
    晨旦各分离，到暮还归集。
    与汝为母子，共在生死树，
    既得成道果，长绝此源本，
    又复取灭度，无有会见期。”

    时摩诃摩耶说此偈已，涕泣懊恼，不能自胜。与于无量诸天女等，眷属围绕，作妙妓乐，烧香散华，歌颂赞叹，从空来下，趣双树所。到娑罗林中已，遥见佛棺，即又闷绝，不能自胜。诸天女等以水洒面，然后方苏。前至棺所，头顶作礼，垂泪悲恼，而作此言：“共于过去无量劫来长为母子，未曾舍离，一旦于今无相见期！呜呼苦哉！众生福尽。方当昏迷，谁为开导？”即以天曼陀罗华、摩诃曼陀罗华、曼殊沙华、摩诃曼殊沙华，用散棺上。而说偈言：

    “今此双树间，天龙八部众，
    唯闻啼哭音，不知何所说，
    譬鹦鹉乱鸣，无能解其语。
    充塞在于地，犹如铩翮鸟，
    不能起飞趣，如来涅槃林。
    旷劫积恩爱，似遮迦罗鸟，
    今者无常风，吹散各异处。
    在苦诸众生，希望法甘露，
    犹迦兰提鸟，渴仰待天雨。
    何故便于今，而速入涅槃，
    潜身重棺中，知我来此否？”

    尔时摩诃摩耶说此偈已，顾见如来僧伽梨衣，及钵多罗，并以锡杖。右手执之，左手拍头，举身投地，如太山崩，悲号恸绝，而作是言：“我子昔日执着此等，广福世间，利益天人。今此诸物，空无有主。呜呼苦哉！痛不可言。”
    时诸八部，及以四众，见摩诃摩耶忧恼如是，倍更悲感，泪下如雨。帝释力故，变成河流。
    尔时世尊，以神力故，令诸棺盖皆自开发。便从棺中合掌而起，如狮子王初出窟时奋迅之势，身毛孔中放千光明。一一光明有千化佛，悉皆合掌向摩诃摩耶，以梵软音问讯母言：“远屈来下此阎浮提。诸行法尔，愿勿啼泣。”即便为母而说偈言：

    “一切福田中，佛福田为最。
    一切诸女中，玉女宝为最。
    今我所生母，超胜无伦比，
    能生于三世，佛法僧之宝。
    故我从棺起，合掌欢喜赞，
    用报所生恩，示我孝恋情。
    诸佛虽灭度，法僧宝常住，
    愿母莫忧愁，谛观无常行。”

    尔时世尊说此偈已，摩诃摩耶小自安慰，颜色暂悦，如莲华敷。
    于时阿难见佛起已，又闻说偈，垂泪呜咽，强自抑忍，即便合掌而白佛言：“后世众生必当问我，世尊临欲般涅槃时，复何所说。云何答之？”
    佛告阿难：“汝当答言：世尊已入般涅槃后，摩诃摩耶从天来下，至金棺所。尔时如来为后不孝诸众生故，从金棺出，如狮子王奋迅之势，身毛孔中放千光明。一一光明有千化佛，悉皆合掌向摩诃摩耶，并又说于如上诸偈。”
    阿难又言：“当何名此经，云何奉持？”
    佛告阿难：“我于昔日忉利天上为母说法，及摩诃摩耶夫人自有所说。今复在此母子相见。汝可为后诸众生等，次第演说。此经名曰《摩诃摩耶经》，亦名《佛升忉利天为母说法经》，又名《佛临涅槃母子相见经》，如是奉持。”
    尔时世尊说此语已，与母辞别，而说偈言：

    “我生分已尽，梵行久已立，
    所作皆已办，不受于后有，
    愿母自安慰，不须苦忧恼。
    一切行无常，信是生灭法，
    生灭既灭已，寂灭为最乐。”

    尔时世尊说此语已，即便阖棺。三千大千世界，普皆震动。摩诃摩耶及众八部，悲泣懊恼，不能自胜。
    摩诃摩耶问阿难言：“我子悉达临灭度时，有何教敕？”
    阿难白言：“世尊中夜为诸比丘略说教诫。又以所说十二部经，付嘱尊者摩诃迦叶。末后敕我令助宣布。”
    时摩诃摩耶闻此语已，又增感绝，即问阿难：“汝于往昔侍佛以来，闻世尊说如来正法几时当灭？”
    阿难垂泪而便答言：“我于往昔，曾闻世尊说于当来法灭之后事云：佛涅槃后，摩诃迦叶共阿难结集法藏。事悉毕已，摩诃迦叶于狼迹山中入灭尽定。我亦应当而得果证，次第随后入般涅槃。当以正法付优波掬多，善说法要，如富楼那，广度之众。又复劝化阿输迦王，令于佛法得固正信，以佛舍利广起八万四千诸塔。二百岁已，尸罗难陀比丘善说法要，于阎浮提度十二亿人。三百岁已，青莲华眼比丘善说法要，度半亿人。四百岁已，牛口比丘善说法要，度十万人。五百岁已，宝天比丘善说法要，度二万人，八万众生发阿耨多罗三藐三菩提心。正法于此，便就灭尽。六百岁已，九十六种诸外道等，邪见竞兴，破灭佛法。有一比丘名曰马鸣，善说法要，降伏一切诸外道辈。七百岁已，有一比丘名曰龙树，善说法要，灭邪见幢，燃正法炬。八百岁后，诸比丘等，乐好衣服，纵逸嬉戏。百千人中，或有一、两得道果者。九百岁已，奴为比丘，婢为比丘尼。一千岁已，诸比丘等，闻不净观、阿那波那，瞋恚不欲。无量比丘，若一、若两思惟正受。千一百岁已，诸比丘等，如世俗人，嫁娶行媒，于大众中毁谤毗尼。千二百岁已，是诸比丘，及比丘尼，作非梵行。若有子息，男为比丘，女为比丘尼。千三百岁已，袈裟变白，不受染色。千四百岁已，时诸四众，犹如猎师，好乐杀生，卖三宝物。千五百岁，俱睒弥国有三藏比丘，善说法要，徒众五百。又一罗汉比丘，善持戒行，徒众五百。于十五日布萨之时，罗汉比丘升于高座，说清净法云：‘此所应作，此不应作。’彼三藏比丘弟子，答罗汉云：‘汝今身口自不清净，云何而反说是粗言？’罗汉答言：‘我久清净身口意业，无诸过患。’三藏弟子闻此语已，倍更恚忿，即于座上杀彼罗汉。时罗汉弟子而作是言：‘我师所说，合于法理。云何汝等害我和尚！’即以利刀，杀彼三藏。天龙八部，莫不忧恼。恶魔波旬及外道众，踊跃欢喜，竞破塔寺，杀害比丘。一切经藏皆悉流移至鸠尸那竭国，阿耨达龙王悉持入海。于是佛法而灭尽也。”
    时摩诃摩耶闻此语已，号哭懊恼，即向阿难而说偈言：

    “一切皆归灭，无有常安者，
    须弥及海水，劫尽亦消竭，
    世间诸豪强，会必还衰朽。
    我子于往昔，勤苦集众行，
    故得成正觉，为众说经藏，
    如何于尔时，皆悉潜没尽？
    呜呼生死法，可畏可厌离！”

    尔时摩诃摩耶说此偈已，语阿难言：“如来遗敕既以正法付嘱尊者及摩诃迦叶，宜应精勤护持诵说。我今不忍见于如来阇维之时。”即礼佛棺，右绕七匝，涕泪号叫，还归天上。
    于时娑罗双树间，天人八部、比丘、比丘尼、优婆塞、优婆夷，既见如来母子相见，及闻所说，有发无上道心者，有得须陀洹者、斯陀含者、阿那含者、阿罗汉者，或有发于辟支佛心。一切大众，受持佛语，顶戴奉行。

据《乾隆大藏经》、《大正藏》校订


佛使比丘迦旃延说法没尽偈

失译人名

尊者迦旃子，体道修律护，
见诸卒暴者，以偈开法路：
“心当怀怆恨，思惟悲感事，
常勤务精进，顾后大恐惧！
正法垂欲灭，人年才寿百，
正法之光明，在世不久没。
正法已灭尽，比丘众迷惑，
当舍诸经法，圣觉之所讲。
反受杂文章，废捐佛所说，
见训诸浅经，心意为欣悦。
常当共诤讼，违教背典经，
展转兴诽谤，各各相慢轻。
愚痴课难化，无智如株杌，
卿无所别知，不学佛正法。
释置经义理，更互相求短，
吾身所闻传，独步无俦伴。
持中以着下，举下着于中，
不复识次第，所说贵不穷。
证据设乖谬，反说无本末，
闻受皆浮漫，讲论无清话。
斯徒众恶意，谤讪于和尚，
见尊睹师父，傲慢不崇敬。
是等共辩诤，心念甚愁毒，
著世慕豪富，堕缚不自觉。
‘我觉甚真谛，卿诚无所知，
卿讲殊倒错，我言顺典义。’
各各共诤讼，用生毒害心，
贪得利供养，随俗共浮沉。
习乐于居屋，不能自拔度，
从贪共谈话，但说世间务。
时诸比丘舍，树间及闲暇，
行止于聚落，闹中立精舍。
喜乐于愦扰，不慕处静默，
展转相侵欺，以自养妻息。
或时有比丘，客从远方来，
寺主先自安，闲居乃听之。
妒其所止居，嫉其有德名，
亦嫉于族姓，又复吝法经。
见远方比丘，颜色不悦和，
得其舍之去，于心乃为快。
贪著于供养，用兴毒恶嫉，
矜庄相贡高，由是成忿失。
常念瞋恚恶，骄慢为自大，
所求无厌足，恣意随尘秽。
毒事不应行，不欲诵受经，
终日笑歌舞，旦暮寝不醒。
斯等共聚会，言不及经理，
但说县官贼，流俗行来事。
假使有学者，众人所供养，
羡者求出家，言学比丘法。
假使有学者，白衣所崇敬，
务于杂碎事，因是得名闻。
所行不如教，自从利养起，
其年既幼少，多畜众弟子。
其心怀诤乱，不能究所学，
沙门二三年，广畜诸眷属。
莫能谨慎戒，堕落于邪见，
或有说断灭，或有讲有人。
已住如是学，堕恶人须发，
门徒多鄙猥，少年相围绕。
或时甚枯旱，或时复大水，
雀鼠及蝗虫，灾害并辐至。
五谷普罄匮，民庶咸饥馑，
穷逼于糊口，出家求安隐。
便行作沙门，不调越轨度，
不解于禁戒，众会无救护。
苟且无羞耻，不能修慎行，
亦不乐法会，汲汲著财养。
以非法为法，所说违道义，
举罪反轻重，乱经背贤规。
集会至夜半，斗诤事弥滋，
然后乃说经，粗略不周备。
希简说禁戒，具足斗诤事，
处处失义理，故正法灭尽。
适共斗诤已，遂乃结仇怨，
诸魔及官属，用斯得人便。
诸天龙鬼神，求欲听经教，
倾企迟闻法，但更斗诤讼。
诸天人怀恨，不可比丘行，
行来共讲言：‘佛法欲灭尽！
吾等舍天乐，故来欲受法，
不得闻正法，不如弃之去。’
其有尊鬼神，心乐佛法者，
不念诸比丘，不复行拥护。
于时弊鬼神，凶暴行毒害，
取比丘精气，令命无有余。
比丘多疾病，羸劣无气力，
失神颜色变，勤苦遭众厄。
展转相憎嫉，疾病不相瞻，
或有至死亡，无护横夭终。
贪著利财宝，衣食无限节，
晓知习俗法，邪业以自活。
贩卖规贾利，出入求生息，
志尚存匆务，孜孜无懈极。
乐于杂碎事，求利欲救命，
弃捐度世业，细务自婴累。
衣服不整齐，仪节不闲修，
不能将顺行，如野马猕猴。
遥见贤比丘，分卫知止足，
远近骂詈之，言不顺禁戒。
如今日比丘，澹然无过失，
彼时诸比丘，默声犯众恶。
偷苟无羞惭，懈怠怀毒意，
斯等将来世，反当见敬事。
有仁贤比丘，具足知廉耻，
于彼失法时，乃更不见待。
譬如狮子王，处在林树间，
豺狼及犬狐，不敢食其肉。
命过身出虫，还自啖其肉，
昼夜共啖食，毁灭其形体。
能仁大圣人，泥洹灭度后，
诸地水火风，不能毁佛法。
世间珍奇宝，不妄忽自亡，
苍金出于世，紫金乃不彰。
正法在于世，终不自没尽，
因有像法故，正法则灭尽。
譬如海中船，贪重故沉没，
佛法斯亦然，利养故灭尽。
背经及圣典，以此为正法，
以法违于律，以非作法义。
诸邪见异学，五通诸学士，
不能毁法义，及所兴布施。
其从释迦文，因佛作沙门，
当毁于正法，令法至灭尽。
计劣诸男子，除发被袈裟，
皆当败正法，令典没不现。
不肯顺禁教，戮力存法务，
恣心从所乐，犹如尘蔽驴。
于时诸学人，受取妄保任，
改定其券别，令错所寄信。
畏于县官吏，怨贼及债主，
战战相恶难，恐怖衣毛竖。
耕种及治生，遭值诸吏卒，
朝夕习秽欲，众患所见恼。
将有三恶王，大秦在于前，
拨罗在于后，安息在中央，
由于是之故，正法有弃亡。
夷王大凶恶，处在于北方，
兴师伐恶国，伤害诸万民。
轻毁诸沙门，多犯于众恶，
毁坏佛塔寺，破败学精庐。
当于尔时世，郡国皆丘墟，
是等皆恐惧，愁忧而懊恼，
舍其北方土，奔趣于中国。
病瘦目不明，尪瘵无气力，
不能舍北方，当为其所贼。
时少年比丘，不务沙门者，
便当脱衣服，恐怖欲自全。
于是中国君，当来伐夷王，
既已诛夷王，来还居监尼。
彼有尊比丘，名号曰尸师，
博闻靡不达，能悦诸国王。
王闻尸师言，心意怀欣踊，
愿欲请众僧，兴设大布施。
遣使诣十方，宣命于诸国：
‘诸人来诣此，今当大布施！’
诸僧皆集至，其数有百千，
遭难皆憔悴，愿乐见大施。
诸比丘已会，百千设备足，
展转相推求，各各相问讯：
‘仁和尚所在？阿阇梨所至？
常所从沙弥，恶师今所师？’
‘或伤或死亡，或亦见驱逐。’
比丘既相见，啼哭不自胜。
彼时诸会者，其数百千众，
怀恼失颜色，乐见大布施。
四面并云集，同会十五日，
讲说佛典戒，寻复相忿怼。
斯等既忿怼，展转不共和。
尊比丘教告：‘诸比丘默然！
吾当说卿等，示有佛法律。
听我之所说，无得乱语言。
计此阎浮地，沙门佛门徒，
会同当共和，不宜长嫌故。
有大比丘众，其数有百千，
欲得学道义，往会十五日。
有大比丘众，虽有百千数，
我学设明达，卿等不能知。
设有一比丘，学能达悟者，
便可说本末，我学知其经。’
时有一比丘，所学普通达，
有德名须赖，如是狮子吼。
即时从座起，叉手而住立，
稽首耆年足，便当狮子吼：
‘吾不怀狐疑，其心无犹豫，
身所学经戒，今设为通利。
吾亦无众难，心亦不进退，
吾所前学者，法律无所疑。
通畅于经典，明达于道义，
吾所学如此，诸贤宜奉持。’
‘卿不达众经，亦不解法律，
云何尊者前，而多自称叹！’
尊师恶弟子，性凶怀毒害，
其名曰阿斯，即便害须赖。
时有大鬼神，信乐于佛法，
手自执金刚，遂打杀阿斯。
当于尔时世，地六返震动，
四方自然响，非人击霹鼓。
至尔时四方，当有四大烟，
又复四大火，上方四面堕。
于尔之世时，世间为幽冥，
从是往不返，生民没愚痴。
黎庶无央数，悲哀怀懊恼：
‘今日最末世，佛正法未尽！’
曾见佛鬼神，信乐于道义，
纵身自投地，号躄不自堪：
‘诸比丘遭患，如人丧二亲，
今日最末世，佛正法灭尽！
从今日以往，无复说经典，
法律及禁戒，当何从闻听？’
诸天树木鬼，旷野居神明，
悲感心忧恼，宛转不自宁：
‘法灯为已没，正典已毁灭，
今世最崩颓，法鼓不复鸣！’
诸魔设欢喜，众会相庆贺，
举手而赞言：‘今是佛末世！’
却后将来世，当有是患难，
益当加精进，勉力求度脱。
譬如有贾客，失时心怀恼，
故宜加慕励，无得复后悔。
闻时道法兴，经典普流布，
说法者常存，勤心修佛教。
今日四辈人，展转相恭敬，
闻佛法尚在，夙宵加精进。
身体自康强，未遭老病死，
以故当殷勤，念后大危惧。
及时诸国安，无有众患难，
丰熟乞易得，奉修佛教禁。”

沙门解罗刹，闻是法教戒，
前稽首作礼，耆年迦旃子：
“惟吾身战栗，毛竖心为寒，
失志不知法，不复识方面。
今我闻此言，心生大恐惧，
将来世见此，安能心不碎！”

尊者迦旃子，兴此悲哀已，
则为诸弟子，说正法未尽：
“三百岁多解脱，三百岁闻戒定，
三百岁修佛寺，入千年责怨害。
诸比丘乐无乐，习独处床席居，
在于彼行无方，当降伏诸爱欲。”

据《乾隆大藏经》、《大正藏》校订


迦丁比丘说当来变经

失译人名

    是时迦丁比丘告众会曰：“汝等静听，吾今所说。初、中、竟语，如佛所说，言无违错。当来之世，当有恶变，甚可怖畏。汝等欲知，我今说之。来事大恐，好当勤加修精进业。吾蒙佛恩，今得安隐。汝等出家，宜顺佛教。
    “人寿百岁，少出多减(1)。当来之世，恶法兴盛。恶比丘出，破坏佛法。法欲尽时，人意薄弱，无有志勇，务怀嫉妒，更相谤毁。贪着文字，务亲纸墨而自光，自谓之为上。若有比丘从师口受，讽诵通利，分别句义，而为他人分部说之，而更轻慢。此二学家，更共斗诤，吾所说是，汝所说非。贪利财宝，心口相违。愚痴之人，不解经意，倒释其义。说者亦反，受者复倒。语言不正，经偈参错。所学既少，但怀骄慢，轻蔑他人。当来之世，如此之辈人，甚为众多。傲慢师长，不复承事，谓三师(2)言：‘我所说真实，汝所说妄伪。’
    “此辈比丘，亲着俗服。白衣所行，而习学之。闲居静处，而不乐之。人间愦闹，贪慕系恋，不能远之。虽于人间起佛塔寺，更相嫉妒。四方比丘经过止住(3)，要报寺主，尔乃得住。然虽得住，内心恚恨，意不喜之。若去之后，尽共欢喜。佛寺之中，所住比丘，还相妒忌。或妒钱财，或妒颜色，或妒供养，或妒种姓，或妒经法，秘惜不传。追逐贵人有力势者，心意沮败，崩坏佛法。贮聚钱财、奴婢、六畜，修治园圃，以此为上。内外以变，强着袈裟，剔头而已。昼夜殷勤，勤修营事。国中臣吏有力势者，追逐奉之，犹如奴仆。檀越之家，敬三宝故，减妻夺子，不敢衣食，起佛塔寺，施僧房舍、衣服、卧具，悉令饶足。复恐乏少，即出家中名珍上宝，着其塔中。住寺沙门，追逐官长，欲望敬事(4)，即取檀越塔中所有，持上官长。官长贪财，不推本末(5)，益得为善(6)，用是贪嫉，死入地狱。其比丘者，贪着名利，取三宝物，妄为私惠(7)，用是罪故，死入地狱。或有比丘身犯众恶，以三尊(8)钱财，求谢他人，以求解脱。或有比丘，及诸白衣，贪三尊财，强获罪负(9)，极取持去。斯辈之人，尽入地狱。
    “若作法师，作持律行者，通《四阿含》者，各与白衣有力势者，共为亲友。坐白衣床，便共密语，谈说余人善恶好丑。依着白衣，恃其力势，意所不喜，便危害之。若为说法，以邪为正，以正为邪。作是行者，名为天下非法分部。佛有三藏经，夫为师者秘惜不传，不教弟子。所以者何？恐弟子知与我等者，便轻慢师，是以秘之。为弟子者，何名出家，无所学识，则便空出。至使弟子遂怀瞋恚，轻慢于师，无复上下，语言凶粗。
    “此辈比丘，兴乎恶行，魔及官属尽得其便，堕魔部界。反自称誉：‘谁与我等？’心变意恶，三毒炽盛，不能自禁。贪利供养，达嚫(10)财物，不避罪福，益得为善。用供养故，便共斗诤。外着法服，不知戒行，出入行来，不从法教。摇头顾影，迷着色欲，甚于凡俗。居贱卖贵，或出倍息，务贪赢利。比丘行法，舍弃不行，得少利入，则便欢喜。比丘僧聚，坐禅、学问，不能堪耐，而远避之。贪求财利，四出求索，不觉疲倦。欺调百姓，无有厌足。若有塔寺，僧房卧具肥浓之处，竞入其中。外像持戒，内怀奸非，人见恭敬。渐渐日日追逐白衣，奉事供给。白衣欢喜，复敬望之，展转叹美，言此比丘戒行清纯，不知其内专为虚伪。多畜弟子、沙弥、奴婢，四向求索，积聚无足。言我持戒，年岁未满，行便将从。戒法日缓，不信罪福，出言凶强。好与酒客、淫荡女家，与之从事。或入官长宫阁，出入以自荣美。或投人聚，或喜作务百种生活。谈说王事治政好丑，或谈军马斗诤胜负，或谈盗贼，或谈饮食，或说妇女情欲，昼夜谈说世间邪事。明师善友，不肯亲附。更与屠儿、恶贼、嗜酒、盗劫、贩卖、邪淫之人共为亲厚，饮酒卧起，心渐染恋，习彼所行。或勤家业，或为白衣走使(11)，不避远近。如此辈人，不知正法，复使作沙门，名曰坏法。既自不孝父母尊老，若见持戒比丘、清高梵志，而骂辱之。无有慈心，贼害群命，劫人财宝，私人妇女。口好妄言闺门淫乱，不避上下。若净洁比丘尼，淫意为起，而追逐之，破毁戒行。如此辈人，现世为王法所得，收系于狱，五毒治之。
    “若有国王、大臣、人民，犯斯恶者，则令风雨不时，五谷不丰，人民穷困，盗贼并起，军革数兴，万民逃迸，五族离散，聚落空虚。彼时世人困无衣食，避世苦故，竞作沙门。作沙门已，破坏佛法，轻慢上下。合聚恶人，意合志同，而为结友。便相称扬：‘某戒行清，某行禅定。’人民闻见，谓为审然。若檀越请转经说法，便窃裸卧，不肯听采。若分达嚫，则竞诤之，求索供养、衣被、饮食，无有厌足。多畜弟子，不以法训。佛之正戒，不以诲之。弟子不解戒行、禅定、修道之法。而为师者，务相聚会，谈讲世俗非法之事，以为常业。如此辈人，受他供养，施者福少，受者有殃。若有四辈聚会说经，不乐听之。若有白衣来欲听经，竞共迎送，供给所须，不失其意。若说禁戒，则共斗诤，乃至夜半，言众人疲，但说四事。若理斗诤，不以疲厌。若说净戒、讲经法时，不欲闻之。
    “当来比丘，欲乱法者，竞起佛寺，处处聚会。其十五日有布萨说戒者，虽共聚会，但共斗诤，亦不说戒讲法。诸天人民，见僧聚会，欲听经法，但闻斗诤。即相谓言：‘我为法来，反闻斗诤，于此何求？’心中不乐，愁惨而去，自念不久佛法将灭。诸天龙神，及诸夜叉，诸善鬼神，皆共愁悒，不复拥护佛法众僧。令诸恶鬼吸食其血，令皆多病，薄色力劣，颜貌枯悴，无有威德，皆由此矣。比丘若病，不相看视，心畏恶之，乐欲令死。时病比丘，无看视故，遂便丧亡。
    “佛法欲灭，比丘、白衣皆共悭贪，积聚财产，不肯惠施，但贪欲得。摩摩帝(12)者，不信罪福，无复上下，亦不分别三尊财物，无道用之。或共妇女，或共白衣，杂厕居止，饮酒歌舞，快相娱乐。凡俗无别，更相嫉妒。缘是之故，财物衰耗，业不谐偶(13)。此辈比丘，用淫欲故，乐在家居，不厌为苦，好与童女相结为姻。所以者何？童女之意，特为深重，初得男子，心相恋着，俱不忘舍。或与淫荡女子就共生活。或比丘尼为家居者。
    “若有比丘，不畜遗余，乞丐充身。诸破戒比丘尽共憎恶，不欲见之，告诸檀越言：‘此比丘内怀谀谄，外现持戒，不足可与。’于今之世，若有犯戒比丘，尽共恶之。将来之世，见有清净持戒比丘，反共憎之。今时比丘，屏处(14)犯戒，畏人见之。将来之世，若有比丘奉戒禅定，畏人见之。所以尔者，将来之世，憎持戒故。当来比丘，强知贪利，不知羞耻。如此人辈，彼世痴人，尽恭敬之。见持戒者，反轻毁之。
    “一切万物，悉皆是宝，用(15)人不识，皆即化没。佛法亦尔，由是之故，正法转没，用不敬奉，令法没尽。譬如大船，多所负载，重则沉没。将来之世，多有比丘贪惑供养，令法毁没。若有比丘奉戒护律，法当久存。如狮子王，虽死卧地，飞鸟走兽无敢近者。旬日之间，身中生虫，还食其肉，毁坏身形。佛虽泥洹(16)，正法续存。梵魔众圣，一切邪道，无能毁佛法者。将来当有无行(17)之人，入佛法中，求作沙门，破坏佛法，更相轻毁。学三藏者，转相嫉妒。为嫉妒故，佛法疾灭。欲护佛法，当除骄慢，弃捐嫉妒。将来比丘，妒佛法者，如猪处溷，不自知臭。多所唐突，如无羁驴。不顾禁戒，饮酒啖肉，不以时节。共结亲友，或穿人墙屋，劫人财物。或受人寄，共相罔冒(18)，更相证明，忍于搒笞(19)，改易券信，多得为幸。若僧因缘共会聚时，诸下坐辈，呵骂上座。上座默然，愁惨出去。尔时下座，不以礼教以自拘制。可为师者，更不受之。
    “比丘有是斗诤之时，法将灭尽。天下骚动，尽共不安。国主调役，无复厌足。盗贼并起，劫夺民财，转入于王。王者得财，遂长益贼，治政崩坏，相杀不问。人民穷苦，奸巧滋生。天下枯旱，风雨不时，谷米饥贵，王贾贩卖，逾越境界。耕田种作，收入薄少，昼夜勤苦，身口不系，无用充官。万民嗷嗷，乃不思存。尔时比丘亦复耕田，四出贾作，经理官私，与俗无异，甚为苦哉。
    “将来之世，当有三天子出，破坏天下。一名耶来那，近在南方。中国(20)当有一天子出。北方晋土有一天子，名曰揵秋。佛法将灭，此三天子(21)乃出晋，破坏国土，杀害人民，破塔僧园，轻慢沙门，拷治五毒。亦率兵众，诣天竺国，破坏土地，多所残害。尔时中国天子，当复兴兵，破坏晋土及其臣民，还其本土。是时晋土沙门为官所困，或有死者，或有返俗者。或巡四出向天竺者，或有达者，有不达者。或有盲聋跛蹇、羸老病瘦，不任去者，为官所杀。
    “尔时中国天子，敬佛法众，惠施一切。见犯戒者，即诃谏之。时有上座比丘，名尸依仇(22)，通知三藏(23)，为王说法。王甚欢喜，即请众僧，于拘睒弥国(24)作般阇于瑟(25)，尽请一切释迦文弟子在阎浮提者，悉令集会。时有百千比丘末后大会。大会者，佛法向尽，更不复会，故言末后。
    “尔时会中转相问言：‘汝等和尚(26)，及阿阇梨，为在何许？’各答之曰：‘我等之师，中道病死者，贼所杀者，疲劣不能前者。’言已，达者(27)皆共悲结，举声号哭。当此之时，十五日夜，天大恶风暴雨。说二百五十戒，中有闻者，或不闻者。时诸比丘，便共斗诤大语呼。上座比丘谏众人曰：‘仁等小言，当用法故，更勿乱语。吾用比丘法，当解汝意。今阎浮提释迦文弟子尽来会此，是会末后。今我所学，更不复学，唯愿默然，听我所说。’复有比丘，聪明智慧，深入禅定，语众人曰：‘我所入禅，悉已备足。今此大会百千比丘，欲闻法戒，能持行者，我当说之。愿诸释子，默然静听。’复有比丘，字须陀流(28)（此言“日善”），以得罗汉，即从坐起，一心叉手，礼上座足，便狮子吼：‘我欲说经，众坐勿闹。经中所说，吾悉学之，无有错误，终不复疑，如佛所言。’上座弟子，名曰上头，亦是上足，志行凶恶，即从坐起，谓须陀流曰：‘汝何所知？不解经法戒律。上座欲说，竟共说之！’尔时上头，即以铁杵，打杀须陀流。须陀流已度生死。中有持戒比丘，默然便起出去。尔时有信佛夜叉，复以铁杵，击杀上头比丘。
    “当于尔时，天地六反震动。虚空之中，自然有叫唤称怨之声。四向复有雷震雨堕。四向复有恶气满于虚空，雷震四至。尔时一切众生之类，见是变怪，悉共相对，举声悲哭。皆相谓言：‘今日末后，佛法尽矣！’上至二十八天、无色诸天，及龙、阿须轮(29)，满于空中，举声大哭，自扑堕地。复有奉法罗刹，及见佛夜叉，悉皆举身自投于地。口说是言：‘从今以往，天下更不复闻说二百五十戒声，比丘不复奉行之。天下孤寡，众生失目甚速！柰何天下不久，人民相杀，无有问者，犹如野畜。法行已堕，法鼓已裂，甘露门已闭，诸经法师命已丧失。法炬已灭，法轮已倒，十二部经已散已解。法轮已折，法水已止，法海已竭，法山已崩，诸山谷间无复精进坐禅比丘。’诸天善神，见山谷空，无所奉敬，悉皆自扑。人民盲冥，无法可行。时诸魔众，皆大欢喜，以名衣上服更相贡上：‘佛法已灭，我等邪法今始得兴！’更相庆赖。”
    迦丁比丘告诸弟子：“当来恶变，其事如斯。今日佛法犹故存在，宜勤行之。佛之正法，如深草泽，众生仰之，无所乏少。若草泽枯竭，众生饥困，堕于生死。犹如贾客不勤用心，财宝日耗，父母妻子无所济活，身心焦燃，悔无所及。今正法存，极可行之，恣取何道(30)。若复放逸，不欲精进，空出无获，返为三途之所没溺，悔之无及！今汝四辈，思佛重恩。奉上如父，亲下如子。汝等四大强健，心坚意猛，勤行精进，可得度苦。若复一旦身心微弱，而为老病所见蹋蹈，悔无所及。今国土人民未至盛恶，兵革未起，人民安隐，米谷平贱(31)，分卫(32)易得。念勤精进，可无后悔。”
    时诸弟子闻说是法，悉皆稽首礼大仙足，心意惶怖，身体战掉，悲泣白言：“将来之世法没尽时，见此世者意当云何？何忍见之！我等今日闻说是事，心用崩破。彼世之人遭此恶者，身心岂不裂作百段耶？”时诸弟子忽复自议，至心投地，同声白师：“我甚惶怖！云何得道，免于斯苦，不遭斯恼？”
    大仙告曰：“道无远近，勤求则得，无有前后。此经名曰《大仙迦丁所记当来秘谶要集》，宜勤精进，可免斯苦。”
    时诸弟子闻经，悲泣饮泪，稽首奉行。

    【注释】
    (1) 少出多减：意为超过百岁的很少。
    (2) 三师：指比丘受具足戒时的戒和尚、羯磨师、教授师。
    (3) 经过止住：路过时想在寺中住宿。
    (4) 欲望敬事：想使官长满意。
    (5) 不推本末：不考虑物品的来历。
    (6) 益得为善：尽量多取多得。益：增多。
    (7) 妄为私惠：擅自施送于人。
    (8) 三尊：即佛、法、僧三宝。
    (9) 强获罪负：强行劫夺。
    (10) 达嚫：指檀越所布施的金银财物。
    (11) 走使：为人服役奔走。
    (12) 摩摩帝：即寺主、知事。
    (13) 业不谐偶：诸事不顺利。
    (14) 屏处：隐蔽处。
    (15) 用：由于。
    (16) 泥洹：涅槃。
    (17) 无行：行为不端。
    (18) 罔冒：假冒。
    (19) 搒笞：用鞭、杖等击打。搒：笞打。
    (20) 中国：佛典中所言“中国”，指古代天竺，佛陀生前教化的地域。
    (21) 此三天子：指第三位天子，即北方晋土天子。
    (22) 尸依仇：《大集月藏经·法灭尽品》译作“失师迦”，《杂阿含经》卷第二十五译作“弟子”、“失沙”，《佛使比丘迦旃延说法没尽偈》译作“尸师”。
    (23) 通知三藏：通晓经、律、论三藏。
    (24) 拘睒弥国：又作憍赏弥国，位于中印度。
    (25) 般阇于瑟：无遮大会。
    (26) 和尚：指授戒师。
    (27) 达者：前来赴会者。
    (28) 须陀流：《大集月藏经·法灭尽品》译作“涷罗多”，《杂阿含经》卷第二十五译作“修罗他”，《佛使比丘迦旃延说法没尽偈》译作“须赖”。
    (29) 阿须轮：阿修罗。
    (30) 恣取何道：各种法门均可任意修学。
    (31) 平贱：便宜。
    (32) 分卫：即乞食。

据《乾隆大藏经》、《大正藏》校订

·清凉书屋校注·


大阿罗汉难提蜜多罗所说法住记

唐三藏法师玄奘奉诏译

    如是传闻。佛薄伽梵般涅槃后八百年中，执师子国胜军王都，有阿罗汉名难提蜜多罗（唐言“庆友”），具八解脱、三明、六通、无诤愿智、边际定等无量功德，皆悉具足。有大威神，名称高远。以愿智力，能知此界一切有情种种心行，复能随顺作诸饶益。化缘既毕，将般涅槃，集诸苾刍、苾刍尼等，说己所证诸妙功德，及应所行利乐有情诸胜事业，皆悉成办。告时众曰：“自今已后，无复所为，唯无余依是所归趣。仁等当知有疑可问。”
    时诸大众，闻是语已，举声号哭，不能自持，宛转于地。或起唱言：“佛薄伽梵久已涅槃，诸圣弟子亦随寂灭，世间久空，无真调御。今唯尊者为天人眼，如何复欲弃舍我等？愿垂哀愍，少留寿命！”
    尊者庆友慰喻众言：“不须啼泣。仁等当知，世间法尔，有生必灭。诸佛如来，降伏四魔，于寿自在。随顺世故，犹示涅槃。况我今者，岂宜恒住？设随汝请，亦无利益。当体此意，勿生忧恼。但有疑者，应可速问。”
    诸苾刍等，虽承告示，犹增涕噎。良久乃问：“我等未知世尊释迦牟尼无上正法，当住几时？”
    尊者告曰：“汝等谛听。如来先已说《法住经》，今当为汝，粗更宣说。佛薄伽梵般涅槃时，以无上法，付嘱十六大阿罗汉并眷属等，令其护持，使不灭没。及敕其身，与诸施主作真福田，令彼施者，得大果报。”
    时诸大众闻是语已，少解忧悲，复重请言：“所说十六大阿罗汉，我辈不知其名何等？”
    庆友答言：“第一尊者名宾度罗跋啰惰阇，第二尊者名迦诺迦伐蹉，第三尊者名迦诺迦跋厘堕阇，第四尊者名苏频陀，第五尊者名诺矩罗，第六尊者名跋陀罗，第七尊者名迦理迦，第八尊者名伐阇罗弗多罗，第九尊者名戍博迦，第十尊者名半托迦，第十一尊者名啰怙罗，第十二尊者名那伽犀那，第十三尊者名因揭陀，第十四尊者名伐那婆斯，第十五尊者名阿氏多，第十六尊者名注荼半托迦。如是十六大阿罗汉，一切皆具三明、六通、八解脱等无量功德，离三界染，诵持三藏，博通外典。承佛敕故，以神通力，延自寿量。乃至世尊正法应住，常随护持，及与施主作真福田，令彼施者，得大果报。”
    尔时苾刍、苾刍尼等，复重请言：“我等不知十六尊者，多住何处，护持正法，饶益有情？”
    庆友答言：“第一尊者与自眷属千阿罗汉，多分住在西瞿陀尼洲。第二尊者与自眷属五百阿罗汉，多分住在北方迦湿弥罗国。第三尊者与自眷属六百阿罗汉，多分住在东胜身洲。第四尊者与自眷属七百阿罗汉，多分住在北俱卢洲。第五尊者与自眷属八百阿罗汉，多分住在南赡部洲。第六尊者与自眷属九百阿罗汉，多分住在耽没罗洲。第七尊者与自眷属千阿罗汉，多分住在僧伽荼洲。第八尊者与自眷属千一百阿罗汉，多分住在钵剌拏洲。第九尊者与自眷属九百阿罗汉，多分住在香醉山中。第十尊者与自眷属千三百阿罗汉，多分住在三十三天。第十一尊者与自眷属千一百阿罗汉，多分住在毕利扬瞿洲。第十二尊者与自眷属千二百阿罗汉，多分住在半度波山。第十三尊者与自眷属千三百阿罗汉，多分住在广胁山中。第十四尊者与自眷属千四百阿罗汉，多分住在可住山中。第十五尊者与自眷属千五百阿罗汉，多分住在鹫峰山中。第十六尊者与自眷属千六百阿罗汉，多分住在持轴山中。
    “诸仁者，若此世界，一切国王、辅相、大臣、长者、居士，若男若女，发殷净心，为四方僧设大施会；或设五年无遮施会；或庆寺、庆像、庆经幡等，施设大会；或延请僧至所住处，设大福会；或诣寺中经行处等，安布上妙诸坐卧具、衣、药、饮食，奉施僧众。时此十六大阿罗汉，及诸眷属，随其所应，分散往赴。现种种形，蔽隐圣仪，同常凡众，密受供具，令诸施主得胜果报。如是十六大阿罗汉，护持正法，饶益有情。
    “至此南赡部洲人寿极短，至于十岁，刀兵劫起，互相诛戮。佛法尔时当暂灭没。刀兵劫后，人寿渐增至百岁位，此洲人等，厌前刀兵残害苦恼，复乐修善。时此十六大阿罗汉与诸眷属，复来人中，称扬显说无上正法，度无量众，令其出家，为诸有情作饶益事。如是乃至此洲人寿六万岁时，无上正法流行世间，炽然无息。
    “后至人寿七万岁时，无上正法方永灭没。时此十六大阿罗汉与诸眷属，于此洲地，俱来集会。以神通力，用诸七宝造窣堵波，严丽高广。释迦牟尼如来、应、正等觉所有遗身驮都，皆集其内。尔时十六大阿罗汉与诸眷属，绕窣堵波，以诸香华，持用供养，恭敬赞叹。绕百千匝，瞻仰礼已，俱升虚空，向窣堵波作如是言：‘敬礼世尊释迦如来、应、正等觉！我受教敕，护持正法，及与天人作诸饶益。法藏已没，化缘已周，今辞灭度！’说是语已，一时俱入无余涅槃。先定愿力，火起焚身，如灯焰灭，骸骨无遗。时窣堵波便陷入地，至金轮际，方乃停住。尔时世尊释迦牟尼无上正法，于此三千大千世界永灭不现，从此无闻。此佛土中，有七万俱胝独觉，一时出现。至人寿量八万岁时，独觉圣众复皆灭度。
    “次后，弥勒如来、应、正等觉出现世间。时赡部洲广博严净，无诸荆棘、溪谷、堆阜，平正润泽，金沙覆地，处处皆有清池、茂林、名华、瑞草，及众宝聚，更相辉映，甚可爱乐。人皆慈心，修行十善，以修善故，寿命长远，丰乐安隐。士女殷稠，城邑邻次，鸡飞相及。所营农稼，一种七获，自然成实，不须耘耨。诸仁者，于彼时中，国界庄严、有情果报，陈之难尽，具如《弥勒成佛经》说。弥勒如来成正觉已，为声闻众三会说法，令出生死，得证涅槃。第一会度九十六俱胝声闻众，第二会度九十四俱胝声闻众，第三会度九十二俱胝声闻众。
    “若诸国王、大臣、长者、居士，男女一切施主，于今释迦牟尼佛正法中，能为佛事，自种善根，或教他种。谓以七宝、金、银、真珠、璧玉、香材、鍮石、铜、铁、木、石、泥、漆，或以缯缕，或以彩画，作佛形像，及窣堵波，若大若小，乃至最小如指节量。或以香华，诸妙供具，若多若少，而为供养。彼由如是善根力故，至弥勒如来成正觉时，善得人身。于彼佛第一会中，以净信心，舍俗出家，净除须发，披着法服。既预圣众，随宿愿力，便得涅槃。是名第一为佛事故种善根者，所得果报。
    “若诸国王及以臣、庶一切施主，于今释迦牟尼佛正法中，能为法事，自种善根，或教他种。谓于大乘素呾缆藏所有甚深空性相应诸大乘经，谓《般若波罗蜜多经》、《妙法芬陀利迦经》、《金光明经》、《金刚手藏经》、《首楞伽摩三摩地经》、《幻喻三摩地经》、《大神变三摩地经》、《集诸功德三摩地经》、《逮如来智印三摩地经》、《具诸威光三摩地经》、《宝台经》、《集诸菩萨三摩地经》、《诸佛摄受经》、《集请问经》、《梵王问经》、《善吉问经》、《勇猛问经》、《能满问经》、《海龙王问经》、《无热恼龙王问经》、《树幢龙王问经》、《宝掌问经》、《宝髻问经》、《虚空音问经》、《虚空吼问经》、《幻网问经》、《宝女问经》、《妙女问经》、《善臂问经》、《师子问经》、《猛授问经》、《金光女问经》、《说无尽慧经》、《说无垢称经》、《未生怨王经》、《谛实经》、《那罗延经》、《佛华严经》、《莲华手经》、《千佛名经》、《无量光众经》、《极乐众经》、《集净华经》、《大集经》、《入一切道经》、《宝幢经》、《宝聚经》、《宝箧经》、《彩画经》、《高顶王经》，如是等大乘经，有百俱胝部党差别。复有大乘毗奈耶藏、阿毗达磨藏众多部类，一切皆是菩萨藏摄。复有声闻三藏，谓素怛缆藏、毗奈耶藏、阿毗达磨藏。素怛缆藏有五阿笈摩，谓《长阿笈摩》、《中阿笈摩》、《增一阿笈摩》、《相应阿笈摩》、《杂类阿笈摩》。毗奈耶藏中有《苾刍戒经》、《苾刍尼戒经》、《分别戒本诸蕴差别》及《增一律》。阿毗达磨藏中有《摄六问》、《相应》、《发趣》等众多部类，复有《本生鬘赞》、《独觉鬘赞》。于如是等正法藏中，或是佛说，或菩萨说，或声闻说，或诸仙说，或诸天说，或智者说。能引义利，乃至有能于四句颂，若自诵，若教他诵，若自读，若教他读，若自持，若教他持，若自解说，若教他解说。或于法师恭敬供养，或于经卷恭敬供养，谓以种种香华、幡盖、伎乐、灯明，而为供养。或于经卷，以诸杂彩囊帕、缕带而严饰之。由如是等善根力故，至弥勒如来成正觉时，善得人身。于彼佛第二会中，以净信心，舍离家法，出趣非家，净除须发，披着法服。既预圣众，随宿愿力，便得涅槃。是名第二为法事故种善根者，所得果报。
    “若诸国王及臣、庶等一切施主，于今释迦牟尼佛正法中，能为僧事，自种善根，或教他种。谓诸苾刍、苾刍尼众，或次第请，或随缘请，于月一日，或月八日，或十五日，设斋供养。或往寺中，若供养一，若供养众，或作给侍。或有供养修静虑者，或有供养诸说法者。或见有人欲于正法学习、流布、从师听受，不作留难，施其所安，无令怯退。或设五年无遮施会，或施四方僧。或施寺舍，及坐卧具，或施钟磬，或施园林。如是等类，供养僧众。彼由如是善根力故，至弥勒如来成正觉时，善得人身。于彼佛第三会中，以净信心，舍离家法，出趣非家，净除须发，披着法服。既预圣众，随宿愿力，便得涅槃。是名第三为僧事故种善根者，所得果报。”
    尔时庆友大阿罗汉，为诸大众，广说如上事已。以神通力，于大众前，身升虚空，高七多罗树，示现种种不可思议大神变事。令所观众，增进胜道。时彼尊者现神变已，即于空中结跏趺坐，舍诸寿行，及诸命行，入无余依般涅槃界。先定愿力，火起焚身，于虚空中，雨身遗骨。
    时诸大众，悲叹希有，竞收遗骨，起窣堵波。以诸香华、宝幢、幡盖、伎乐、灯明，常为供养。
    此《法住记》，古昔诸师，展转相承，诵持不忘。为令一切国王、大臣、长者、居士诸施主等，了达因果，厌生、老、病、死，芭蕉、幻焰、泡沫之身，修诸胜业。于当来世逢事弥勒，解脱烦恼，得大涅槃，生爱乐故，于佛正法护持建立，令久不灭。

据《乾隆大藏经》、《大正藏》校订